Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Zellen nach Hintergrundfarben zählen
#1
Moin zusammen,

hatt hier einer einen Plan oder einen Lösungsansatz wie ich ohne Makro Zellen nach ihrer Hintergrundfrabe zählen kann. So in etwa:=ZÄHLENWENN(A1:A13;"Colorindex gelb").

Danke
Hagen
to top
#2
Hallo Hagen, das kommt darauf an, wie die Zellen gefärbt wurden... Wenn sie händisch (also ohne bedingte Formatierung) gefärbt wurden, geht's nicht ohne Makro bzw. Makro4...
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#3
Hallo,

es ist keine gute Idee Berechnungen aufgrund von Formatierungen durchzuführen, da dies in XL so nicht vorgesehen ist.

Ich würde mir überlegen, ob es andersherum nicht sinnvoller ist:

Eine Kennziffer in die Zelle und dann über die Bedindgte Formatierung die Zelle entsprechend einfärben.

Alternativ könntest du es mit einer Hilfsspalte auch so versuchen und den Colorindex über ein Excel4-Makro bestimmen:

Menü Formeln - Namen definieren - Name in der Arbeitsmappe: 'Schrift' - bezieht sich auf:

=ZELLE.ZUORDNEN(63;INDIREKT("ZS(-1)";FALSCH))

Wenn du nun die folgende Formel eingibst wird die Hintergrundfarbe der jeweils links davon stehenden Zelle ausgegeben:

=Schrift

und dann kannst du wieder mit Zählenwenn() arbeiten.

Aber Achtung: Alle Verfahren, die sich auf die Farbe von Zellen oder Schriften beziehen, haben gemeinsam dass sie sich bei der Veränderung der Farbe nicht automatisch aktualisieren.
Gruß
Peter
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste