Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zellen mit ähnlichem(!) Inhalt markieren?
#1
Information 
Hallo zusammen,

ich habe ein Excel Tabellenblatt mit einer Spalte (welche ca. 1000 Zeilen hat). Die Zellen in dieser Spalte möchte ich dahingehend markieren lassen sobald das gleiche Wort in einer anderen Zelle ebenfalls vorkommt.

Jetzt hier allerdings die Abgrenzung zur Überprüfung von Duplikaten. Ich möchte auch Zellen markieren die nicht als einziges das gleiche Wort beinhalten. Ich versuche das Ganze mal zu skizzieren:

SPALTE A
1 Apfel
2 Banane
3 Mango
4 Kiwi
5 Apfel und Pfirsich
6 Melone
7 Birne
8 Traube
9 Pflaume und Mango
10 Stachelbeere
...
...
...

Ich hätte jetzt gerne die Zellen 1 und 5 sowie 3 und 9 markiert. Da hier das gleiche Wort "Apfel" bzw. "Mango" in einer "ähnlichen" Konstellation ebenso vorkommt.

Gibt es hier eine Möglichkeit das automatisiert mit Excel zu bewerkstelligen?

Ich freue mich auf eure Tipps und Hilfe!

Vielen Dank bereits vorab!
Antwortento top
#2
Hallo wflorian,
Ich vermute, Du hast eine bedingte Formatierung mit ZÄHLENWENN. Du kannst dabei auch Wildcards verwenden, z.B. * Du setzt das dann einfach zusammen:
...;"*" & A1 & "*")
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#3
Hallo schauan!

Danke für diesen ersten hilfreichen Tipp.

Ich bin leider kein Excel Pro. Entsprechend muss ich die Frage auf die bedingte Formatierung verneinen?
Kannst du mir vielleicht konkret erklären wie ich deine "Formel"(?) konkret anwende?

Danke und Grüße!!
Antwortento top
#4
Hallöchen,
Bin derzeit am Smartphone und daher etwas eingeschränkt. Ich dachte, Du hast schon eine Lösung für den "einfachen" Fall. Also, bei der bedingten Formatierung nimmst Du
=zählenwenn($a$1:$a$10;"*"&a1&"*")>=1
Statt a1'a10 ($ nicht vergessen) nimmst Du Deinen Bereich.
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#5
Hi André,

ich tüftel auch schon eine ganze Weile und habe auch die von dir vorgeschlagene Formel ausprobiert. Es kommt dabei aber nicht das gewünschte Ergebnis raus. Ich hoffe bloß, dass ich jetzt nicht völlig daneben bin. Aber schau dir mal den Tabellenausschnitt an.

Tabelle1

ABC
1Apfel2WAHR
2Banane1WAHR
3Mango2WAHR
4Kiwi1WAHR
5Apfel und Pfirsich1WAHR
6Melone1WAHR
7Birne1WAHR
8Traube1WAHR
9Pflaume und Mango1WAHR
10Stachelbeere1WAHR
Formeln der Tabelle
ZelleFormel
B1=ZÄHLENWENN($A$1:$A$10;"*"&A1&"*")
C1=ZÄHLENWENN($A$1:$A$10;"*"&A1&"*")>=1
B2=ZÄHLENWENN($A$1:$A$10;"*"&A2&"*")
C2=ZÄHLENWENN($A$1:$A$10;"*"&A2&"*")>=1
B3=ZÄHLENWENN($A$1:$A$10;"*"&A3&"*")
C3=ZÄHLENWENN($A$1:$A$10;"*"&A3&"*")>=1
B4=ZÄHLENWENN($A$1:$A$10;"*"&A4&"*")
C4=ZÄHLENWENN($A$1:$A$10;"*"&A4&"*")>=1
B5=ZÄHLENWENN($A$1:$A$10;"*"&A5&"*")
C5=ZÄHLENWENN($A$1:$A$10;"*"&A5&"*")>=1
B6=ZÄHLENWENN($A$1:$A$10;"*"&A6&"*")
C6=ZÄHLENWENN($A$1:$A$10;"*"&A6&"*")>=1
B7=ZÄHLENWENN($A$1:$A$10;"*"&A7&"*")
C7=ZÄHLENWENN($A$1:$A$10;"*"&A7&"*")>=1
B8=ZÄHLENWENN($A$1:$A$10;"*"&A8&"*")
C8=ZÄHLENWENN($A$1:$A$10;"*"&A8&"*")>=1
B9=ZÄHLENWENN($A$1:$A$10;"*"&A9&"*")
C9=ZÄHLENWENN($A$1:$A$10;"*"&A9&"*")>=1
B10=ZÄHLENWENN($A$1:$A$10;"*"&A10&"*")
C10=ZÄHLENWENN($A$1:$A$10;"*"&A10&"*")>=1
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A11. / Formel ist =ZÄHLENWENN($A$1:$A$10;"*"&A1&"*")>=1Abc
A21. / Formel ist =ZÄHLENWENN($A$1:$A$10;"*"&A1&"*")>=1Abc
A31. / Formel ist =ZÄHLENWENN($A$1:$A$10;"*"&A1&"*")>=1Abc
A41. / Formel ist =ZÄHLENWENN($A$1:$A$10;"*"&A1&"*")>=1Abc
A51. / Formel ist =ZÄHLENWENN($A$1:$A$10;"*"&A1&"*")>=1Abc
A61. / Formel ist =ZÄHLENWENN($A$1:$A$10;"*"&A1&"*")>=1Abc
A71. / Formel ist =ZÄHLENWENN($A$1:$A$10;"*"&A1&"*")>=1Abc
A81. / Formel ist =ZÄHLENWENN($A$1:$A$10;"*"&A1&"*")>=1Abc
A91. / Formel ist =ZÄHLENWENN($A$1:$A$10;"*"&A1&"*")>=1Abc
A101. / Formel ist =ZÄHLENWENN($A$1:$A$10;"*"&A1&"*")>=1Abc

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
Antwortento top
#6
Hallöchen,
Das ist wahr. Aber die Korrektur sollte einfach sein Smile Entweder statt der 1 eine 2 nehmen -so war das eigentlich gedacht - oder das = nach dem > ist zu viel. Die korrekte Rechnung sieht man ja in Spalte B.
Am Smartphone ist wohl alles etwas kleiner, anscheinend auch die Zahlen Smile)
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#7
Hallo André und Günter,

in der Frage steht doch aber, dass die Zeilen 5 und 9 ebenfalls markiert werden sollen, was ja bis jetzt nicht der Fall ist, weil es da jeweils nur 1 zählt. Da müssten die Wörter wohl erst einmal getrennt werden, um sie anschließend nacheinander zu prüfen. So trivial ist das wohl doch nicht.

Gruß Uwe
Antwortento top
#8
Hi Uwe,


Zitat:in der Frage steht doch aber, dass die Zeilen 5 und 9 ebenfalls markiert werden sollen, was ja bis jetzt nicht der Fall ist,[...]

daran hatte ich ja gestern auch schon eine Weile getüftelt. Deshalb auch mein Kommentar, dass das gewünschte Ergebnis nicht nicht auftritt. Ich werde mal, sehen, dass ich nachher nochmals ein wenig "rumspielen" kann.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
Antwortento top
#9
Hallo Uwe

Stimmt, ganz so einfach ist es nicht. Vielleicht schafft es jemand das noch zu verkürzen.
 A
1Apfel
2Banane
3Mango
4Kiwi
5Apfel und Pfirsich
6Melone
7Birne
8Traube
9Pflaume und Mango
10Stachelbeere

Zellebedingte Formatierung...Format
A11: =ODER(ZÄHLENWENN($A$1:$A$10;"*"&A1&"*")>1;SUMMENPRODUKT(ZÄHLENWENN(A1;"*"&$A$1:$A$10&"*"))>1)abc
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#10
Hallo Detlef,

so sieht das gut aus.  Thumps_up

Gruß Uwe
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste