Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Zellen aufteilen
#1
Exclamation 
Hey,

eine Frage.

Ist es möglich, die folgenden Inhalt aus einer Zelle AA/BB/Cc/DD in 4 Zellen auszuteilen? Zeile 2= AA, Zeile 3=BB und so weíter?

Beste Grüße
to top
#2
Hola,

Daten - Text in Spalten.

Gruß,
steve1da
to top
#3
Hi,

schau Dir mal die Funktionen =LINKS(), =TEIL() und =RECHTS() an ...

Arbeitsblatt mit dem Namen 'Tabelle1'
 A
1AA/BB/CC/DD
2AA
3BB
4CC
5DD

ZelleFormel
A2=LINKS(A1;2)
A3=TEIL(A1;4;2)
A4=TEIL(A1;7;2)
A5=RECHTS(A1;2)
to top
#4
Hi,

ich würde Text in Spalten nehmen, Trenner = / und dann transponieren.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#5
Außer Konkurrenz!  05

Function TeilString(rng, Trenner, Teil) As String
Dim arrTemp
arrTemp = Split(rng, Trenner)
TeilString = arrTemp(Teil - 1)
End Function

A
1AA/BB/CC/DD
2AA
3BB
4CC
5DD
Formeln der Tabelle
ZelleFormel
A2=TeilString(A$1;"/";ZEILE(A1))

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Formel aus A2 nach unten ziehen.

Gruß Ralf
to top
#6
Hi Philip,

zu den bisherigen Lösungen noch eine weitere Variante. Erster Schritt wieder Text in Spalten.

Tabelle2 (2)

ABCD
1AABBCCDD
2AA
3BB
4CC
5DD
Formeln der Tabelle
ZelleFormel
A2=INDEX($A$1:$D$1;;ZEILE(A1))

Excel Tabellen im Web darstellen >> http://www.excel-jeanie-html.de" target="_blank"> Excel Jeanie HTML 4.8
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#7
Hallo,

für Varianten, bei denen die Länge der Texte ungleichmäßig ist:



Code:
=WENNFEHLER(GLÄTTEN(TEIL("/"&$A1;SUCHEN("#";WECHSELN("/"&$A1;"/";"#";Zeile(A$1)))+1;SUCHEN("#";WECHSELN("/"&$A1&"|";"|";"#";Zeile(B$1)))-SUCHEN("#";WECHSELN("/"&$A1;"/";"#";Zeile(A$1)))-1));"")
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#8
Hi Edgar!
Ich kenne diese Art von Formel (von Excelformeln.de).
Wenn man aber sieht, wie simpel dies meine winzige UDF abfrühstückt, frage ich mich seit langem, wieso MS das simple VBA.Split() nicht einfach in Excel integriert.
Wenn ich weiterhin beobachte, was sich im Formelangebot der letzten Versionen geändert hat (wenige Ausnahmen wie Wennfehler und Aggregat mal ausgenommen), sehe ich andere Baustellen von MS.
Als Beispiel das Suchen von rechts (InstrRev()).

Dies aber nur am Rande!

Gruß Ralf
to top
#9
Besten Dank,

mit euch arbeite ich gerne !

Beste Grüße 19
to top
#10
Hallo Ralf,

ich denke immer an die Leute, die entweder mit VBA nichts am Hut haben oder keine Makros nutzen können/dürfen.
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste