Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Zeilen in Spalten nach definierten Muster
#1
Ich bitte um Hilfe in meiner folgenden Aufgabe.

Ich habe eine Liste mit fast 2.000 Einträgen.

Die Liste ist wie folgt aufgebaut:
?mage

Ich möchte gerne dass die entsprechenden Inhalte in Spalten eingetragen werden:
?mage
Das manuelle Transponieren ist bei fast 2.000 Einträge sehr müssig.

Kann mir jemand aus diesen Forum eine Hilfestellung geben?
to top
#2
Moin!
Bestehen die Blöcke immer aus sechs Zeilen?

Gruß Ralf
to top
#3
Moin Ralf,

ja die "Blöcke" bestehen immer aus 6 Zeilen.

Ich habe es schon versucht mit der normalen Zeilenübernahme.
Allerdings werden nach Übernahme der Formeln nicht die korrekten Zeilen "angesprochen".

Herzliche Grüße
Sven
to top
#4
Hallo mal wieder.

Grob lässt sich dies mit INDEX() realisieren.
Erst mal (Zwischenstand) für Name, Vorname:

ABCDEFGHI
1N1V1F1NVFSOTFax
2S1N1V1
3O1N2V2
4T1N3V3
5Fax1N4V4
6M1
7N2V2F2
8S2
9O2
10T2
11Fax2
12M2
13N3V3F3
14S3
15O3
16T3
17Fax3
18M3
19N4V4F4
20S4
21O4
22T4
23Fax4
24M4
Formeln der Tabelle
ZelleFormel
D2=INDEX(A:A;ZEILE(A1)*6-5)
D3=INDEX(A:A;ZEILE(A2)*6-5)
D4=INDEX(A:A;ZEILE(A3)*6-5)
D5=INDEX(A:A;ZEILE(A4)*6-5)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Gruß Ralf
to top
#5
Hi,

ich würde es so lösen:

Tabelle2 (2)

ABCDEF
1NameAdressdaten
2Name1, Vorname 1Firma 1Firma 1Straße 1Ort 1Telefon 1
3Straße 1
4Ort 1
5Telefon 1
6Name2, Vorname 2Firma 2Firma 2Straße 2Ort 2Telefon 2
7Straße 2
8Ort 2
9Telefon 2
10Name3, Vorname 3Firma 3Firma 3Straße 3Ort 3Telefon 3
11Straße 3
12Ort 3
13Telefon 3
14Name4, Vorname 4Firma 4Firma 4Straße 4Ort 4Telefon 4
15Straße 4
16Ort 4
17Telefon 4
Formeln der Tabelle
ZelleFormel
C2=WENN($A2="";"";INDEX($B2:$B5;SPALTE(A1)))
D2=WENN($A2="";"";INDEX($B2:$B5;SPALTE(B1)))
E2=WENN($A2="";"";INDEX($B2:$B5;SPALTE(C1)))
F2=WENN($A2="";"";INDEX($B2:$B5;SPALTE(D1)))

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8


Formel in C2 nach rechts und nach unten ziehen, in Spalte A Leere wegfiltern, danach alles kopieren und in ein neues Tabellenblatt kopieren.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#6
Hi!
Ich finde Günters Lösung smarter (allerdings ist Spalte C "über"), aber da ich schon mal dran war:

ABCDEFGHIJ
1N1V1F1NVFSOTFaxM
2S1N1V1F1S1O1T1Fax1M1
3O1N2V2F2S2O2T2Fax2M2
4T1N3V3F3S3O3T3Fax3M3
5Fax1N4V4F4S4O4T4Fax4M4
6M1
7N2V2F2
8S2
9O2
10T2
11Fax2
12M2
13N3V3F3
14S3
15O3
16T3
17Fax3
18M3
19N4V4F4
20S4
21O4
22T4
23Fax4
24M4
Formeln der Tabelle
ZelleFormel
D2=INDEX(A:A;ZEILE(A1)*6-5)
E2=INDEX($B:$B;ZEILE(B1)*6-5)
F2=INDEX($B:$B;ZEILE(C1)*6-4)
G2=INDEX($B:$B;ZEILE(D1)*6-3)
H2=INDEX($B:$B;ZEILE(E1)*6-2)
I2=INDEX($B:$B;ZEILE(F1)*6-1)
J2=INDEX($B:$B;ZEILE(G1)*6-0)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Jetzt hast Du zwei Lösungen …

Gruß Ralf
to top
#7
Hi Sven,

Ralf hat ja richtigerweise bemerkt, dass bei meiner Lösung die Firmenspalte überflüssig ist. Das kannst du umgehen, indem dun die Formel so abänderst:

=WENN($A2="";"";INDEX($B3:$B5;SPALTE(A1)))

Rest meines Lösungsvorschlages ist gleich geblieben.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#8
Super, vielen Dank für Eure schnelle Hilfe.

Ich werde beide Varianten ausprobieren.
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste