Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Zählenwenn mit Bedingungen
#1
Hallo Zusammen,

ich hoffe ich kann mein Problem verständlich schildern.

Also, ich habe in den Spalten A B und C Zahlen werte stehen. in Spalte D steht ein "x" oder nicht. Mich interessiert jetzt die Anzahl der Datensätze in denen in den Spalten A ODER B ODER C eine "1" steht und in Spalte D ein "x". Mit SUMMENPRODUKT wäre es ja kein Problem, wenn dieses ODER nicht wäre.

Beispiel:

A B C D
1 2 1 y
1 2 3 x
1 1 1 x

Das Ergebnis sollte hier "2" sein, da es nur zwei Datensätze gibt in denen in A B oder C eine 1 und in Spalte D ein X. Es sollen also nicht die Kombinationen aus 1 und x gezählt werden, sondern die Zeilen in denen mindestens eine dieser Kombinationen auftaucht.

Ich hoffe mir kann jemand helfen.

Schöne Grüße,
Robert
to top
#2
Hallo Robert


Code:
=SUMMENPRODUKT((MMULT(--(A1:C10=1);{1;1;1})>0)*(D1:D10="x"))
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#3
Hallo shift,

wow...funktioniert super. Kannst Du mir noch erklären was - - und {1;1;1} bewirkt?

Aber vielen Dank schon mal!

Viele Grüße,
Robert
to top
#4
Hallo Robert

Das erste Array ergibt {1.0.1;1.0.0;1.1.1;0.0.0;0.0.0;0.0.0;0.0.0;0.0.0;0.0.0;0.0.0} (10 Zeilen, 3 Spalten).
Multipliziert man das mit dem zweiten Array {1;1;1} (3 Zeilen, 1 Spalte) dann erhält man {2;1;3;0;0;0;0;0;0;0} (10 Zeilen, 1 Spalte).
Man erhält also für jede Zeile ein Zwischenergebnis.

10x3 * 3x1 = 10x1
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#5
(13.05.2015, 17:16)shift-del schrieb: Hallo Robert

Das erste Array ergibt {1.0.1;1.0.0;1.1.1;0.0.0;0.0.0;0.0.0;0.0.0;0.0.0;0.0.0;0.0.0} (10 Zeilen, 3 Spalten).
Multipliziert man das mit dem zweiten Array {1;1;1} (3 Zeilen, 1 Spalte) dann erhält man {2;1;3;0;0;0;0;0;0;0} (10 Zeilen, 1 Spalte).
Man erhält also für jede Zeile ein Zwischenergebnis.

10x3 * 3x1 = 10x1

Klasse. Vielen Dank!
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste