Das letzte Clever-Excel-Forum.de - Treffen
fand vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt.

"Zählenwenn" bei bestimmtem Wertebereich und bestimmten Zellen
#1
Hallo Leute,

ich stehe gerade vor einem Problem bei einer Tabelle, die ich im Excel aufbauen möchte und hoffe, dass ihr mir helfen könnt.

Ich würde gerne die Funktion "ZählenWenn" benutzen, allerdings soll diese nur auf jedes vierte Feld der Tabelle angewendet werden und auch dann nur, wenn der enthaltene Wert in der Zelle ungleich 0 ist.
Ein Beispiel:

A1: 5
A2: 3
A3: 4
A4: 0 (soll geprüft werden: Wird nicht gezählt, weil 0)
A5: 2
A6: 3
A7: 3
A8: 1 (soll geprüft werden: Wird gezählt, weil ungleich 0)
...
A200: ZählenWenn-Ausgabe

Grüße
Jubeldibub
to top
#2
Hola,

meinst du das so? (für den Bereich A1 bis A100):


Code:
=SUMMENPRODUKT((REST(ZEILE(1:100);4)=0)*(A1:A100<>0))


Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • Jubeldibub
to top
#3
Perfekt, Steve Smile Tausend Dank!

Noch eine kleine Zusatzfrage: Kann man auch mehrere Werte von der Zählung ausschließen? Z.B. nicht nur die Nullen, sondern auch bestimmte Zeichen (z.B. "-")?
to top
#4
Hola,

so?


Code:
=SUMMENPRODUKT((REST(ZEILE(1:100);4)=0)*(A1:A100<>0)*(A1:A100<>"-"))


Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • Jubeldibub
to top
#5
Genau! Danke Smile
to top
#6
Ein Ausschluss bestimmter Zellen bei der Zählung anhand der dort verwendeten Schriftfarbe ist aber nicht möglich, oder?
to top
#7
Hola,

sind die Zellen über die bedingte Formatierung gefärbt, oder per Hand?

Gruß,
steve1da
to top
#8
Derzeit noch per Hand (wobei auch nicht die Zellen gefärbt sind, sondern die Schrift der enthaltenen Daten). Würde das einen Unterschied für die Umsetzbarkeit machen? Ansonsten könnte ich es auch auf Bedingte Formatierung und eine passende Zellfärbung umstellen.

Grüße
Jubeldibub
to top
#9
Hola,

einen großen Unterschied. Farben auslesen ist recht schwierig. Bei einer bedingten Formatierung weißt du ja, wann gefärbt wird - das kann man formelmäßig dann bestimmt einbauen.


Gruß,
steve1da
to top
#10
Ah okay, verstehe. Dann passt es so wie es ist, die Formel deckt es ja ab. Nochmals Danke!
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste