Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zählenwenn: Bereich variieren
#1
Guten Tag,

folgende Problematik:


Das Datum neben Tagesstärke ist veränderlich. Sprich, ich möchte derzeit wissen wie viele Leute am 05.Juni anwesend waren.

Darunter soll die Zahl erscheinen, die der Anzahl der Leute entspricht, die in der Spalte 5 (grün), ein "x" haben.
Das ist mit Zählenwenn kein Problem. Aber ich möchte gerne dass ich nur das Datum ändern muss und nicht die Formel jedes mal.

Ich hoffe das Problem ist klar geworden. Ich hoffe auf Hilfe.

mit freundlichen Grüßen

xDice


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#2
Hola,

dann ersetze deine Zählenwenn() Formel durch eine Zählenwenns() Formel.

Gruß,
steve1da
Antwortento top
#3
Diese Funktion ermöglicht nur die Nutzung mehrerer Kriterien, aber mein Problem ist etwas anders.


Ich versuch das mal als Pseudo-Code deutlich zu machen.

Zähle alle "x" in der Spalte (Zelle "Tagesstärke")
Beispiel:
Zähle alle "x" in der Spalte(5), weil Tagesstärke 5.Juli ist.


Die grünen Zahlen sind die Tage des Monats Juli, lediglich im Format TT angezeigt.
Wenn ich also das Datum neben Tagesstärke ändere soll darunter die zugehörige Anzahl an "x" in der Spalte angezeigt werden.
Antwortento top
#4
Hola,

zum Glück sind keine Xe im Bild zu sehen.
Bitte eine Beispielatei, mit Daten. Kein Bild.

Gruß,
steve1da
Antwortento top
#5
Ich hab die Frage in der Datei nochmal geschrieben, aber hier nochmal.

In Zelle E10 ändert der Nutzer das Datum.
Dadurch soll in Zelle B12 nun die Anzahl der "x" in zugehöriger Spalte angezeigt werden.

Beispiel: bei 03.Juli Zellen D3:D6
             bei 04.Juli Zellen E3:E6
             usw.


Angehängte Dateien
.xlsx   Beipsiel.xlsx (Größe: 9,53 KB / Downloads: 2)
Antwortento top
#6
Hallo, das geht so..:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGH
2 123456 
3Hansx xx   
4Peterxx xx  
5Holger xxxxx 
6Günther x xx  
7        
8        
9        
10 Tagesstärke04.Juli4

ZelleFormel
H10=ZÄHLENWENN(INDEX(B3:G6;;VERGLEICH(E10;B2:G2;0));"x")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • xDice
Antwortento top
#7
Das war erstaunlich einfach.
Könntest du mir die Formel mal kurz erklären, wie die funktioniert? :D

Vielen, vielen Dank auf jeden Fall schonmal!
Antwortento top
#8
Hi!
Noch ne Ecke einfacher, vielleicht auch leichter zu verstehen:

ABCDEFGH
1
2123404.06.20162
3x
4xx
5xx
6xx
7x
8x
9x
10x
11x
Formeln der Tabelle
ZelleFormel
H2=ZÄHLENWENN(INDEX(B:E;;TAG(G2));"x")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#9
Mal ne kurze Erklärung:
Für den 4. würdest Du ja schreiben:
=Zählenwenn(E:E;"x")
Das Problem ist jetzt die Spalte variabel zu halten.
Dafür gibt es
=Index(Bereich;Zeile;Spalte)
Aus dem Bereich B:E brauchst Du die vierte Spalte, die Zeile ist hier nicht erwünscht.
Die 4 ermittelst Du mit Tag("4.6.2016")

Das Ganze dann zusammengestückelt ergibt:
=ZÄHLENWENN(INDEX(B:E;;TAG(G2));"x")

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#10
(29.06.2016, 12:47)RPP63 schrieb: Hi!
Noch ne Ecke einfacher...

Gruß Ralf

Hallo Ralf, aber nur, wenn wir im gleichen Monat bleiben...!!!!
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste