Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Zählen, wenn mehrmals gleicher Wert in Folge
#1
Hallo Smile

In Spalte A meines Arbeitsblatts stehen Datumswerte (Format 01.01.2010) und in Spalte B meines Arbeitsblatts stehen nur entweder 0 oder 1.

Ich möchte, dass gern in Spalte C für jeden Monat, d.h. für den Januar 2010, den Februar 2010 etc., gezählt wird, wie oft, z.B. mindestens dreimal nacheinander in B eine 1 stand.

In dem angehängte Beispiel sollte als in Spalte C eine 2 stehen.

Ich würde mich sehr über eure Hilfe freuen.

Danke Smile


Angehängte Dateien
.xlsx   Example.xlsx (Größe: 10,79 KB / Downloads: 7)
to top
#2
Hallo,

mit einer Hilfsspalte:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDE
1DateValuecount  
201.01.20100 02
302.01.20100 0 
403.01.20100 0 
504.01.20100 0 
605.01.20101 1 
706.01.20101 0 
807.01.20101 0 
908.01.20100 0 
1009.01.20101 1 
1110.01.20101 0 
1211.01.20101 0 
1312.01.20101 0 
1413.01.20100 0 
1514.01.20100 0 
1615.01.20100   

ZelleFormel
D2=(MONAT(A4)=MONAT(A2))*(B1<>1)*(B2=1)*(SUMME(B2:INDEX(B3:$B$999;VERGLEICH(0;B3:$B$999;0)))>2)
E2=SUMMENPRODUKT((MONAT(A2:A999)=1)*(D2:D999=1))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste