Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Am Sonntag (23.09.) wird das Forum zwischen 06:00 Uhr und 09:00 Uhr kurzzeitig nicht erreichbar sein. Wir stellen auf SSL / HTTPS um.


Zählen wenn? - Zahlen durch Buchstaben ersetzen? HILFE :(
#1
Mein Problem scheint mir etwas komplex. Ich versuche mal mich verständlich auszudrücken.

Es geht um die neue Allergenverordnung, die ab 13.12 alle Gaststätten und Verpflegungsbetriebe betrifft. Ich habe eine Tabelle angelegt, die folgendermaßen aussieht:

[Bild: Tabelle%201.png]

und folgendes hätte ich gerne, (ich weiß aber leider nicht, ob excel das überhaupt kann 29 )

[Bild: Tabelle%202.png]

Es geht mir nicht darum, wie oft die Spalten angekreuzt sind, sondern nur DASS sie es sind, ideal wäre natürlich, dass die Ergebnisse in EINER Zelle dargestellt werden, damit sie dann einfach mit copy&paste in andere Dokumente eingefügt werden können, bzw. in einem Serienbrief weiterverwendet werden können.

Ich hoffe ihr wisst, was ich will, und bedank mich mal im Voraus ;)

alles Liebe,

Caly.
Antwortento top
#2
Hallo,

ankreuzen musst Du wohl selbst. Was willst Du sonst noch?
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#3
na klar, muss ich die kreuze selber setzen, ich will halt nur dass mir excel sagt, welche Spalten angekreuzt wurden, und mir die Spaltennamen in eine Zelle zusammensetzt.
Antwortento top
#4
Hallo Calypso

Zum Beispiel so:
Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEF
1ACGLM 
2  X   
3 X    
4      
5      
6      
7      
801100 
9 CG  C G

ZelleFormel
A8=ANZAHL2(A2:A6)
A9=WENN(A8;A1;"")
F9=GLÄTTEN(A9&" "&B9&" "&C9&" "&D9&" "&E9)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#5
Hallo,

ich habe da auch noch was gebastelt:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFG
1  A   M
2  ACGLM
3      x
4A M      
5  x    
6       
7       

ZelleFormel
C1=WENN(ZÄHLENWENN(C$3:C$10;"X");C2;"")
E1=WENN(ZÄHLENWENN(E$3:E$10;"X");E2;"")
F1=WENN(ZÄHLENWENN(F$3:F$10;"X");F2;"")
G1=WENN(ZÄHLENWENN(G$3:G$10;"X");G2;"")
A4=GLÄTTEN(C1&" "&D1&" "&E1&" "&F1&" "&G1)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Nachtrag: Hier noch eine zweite Variante mit einer benutzerdefinierten Funktion:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFG
1  A   M
2  ACGLM
3      x
4A M      
5  x    
6       

ZelleFormel
C1=WENN(ZÄHLENWENN(C$3:C$10;"X");C2;"")
E1=WENN(ZÄHLENWENN(E$3:E$10;"X");E2;"")
F1=WENN(ZÄHLENWENN(F$3:F$10;"X");F2;"")
G1=WENN(ZÄHLENWENN(G$3:G$10;"X");G2;"")
A4=VERKETTEN2(C1:G1;" ")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Die benutzerdefinierte Funktion

Code:
Function Verketten2(ByRef bereich As Range, Trennzeichen As String) As String
Dim rng As Range
   For Each rng In bereich
      If rng <> "" Then
      Verketten2 = Verketten2 & rng & Trennzeichen
      End If
   Next
If Len(Verketten2) > 0 Then _
Verketten2 = Left(Verketten2, Len(Verketten2) - Len(Trennzeichen))
End Function

muss in ein allgemeines Modul der Datei:

- Öffne mit Alt+F11 den VBA-Editor
- mit Strg+R den Projekt-Explorer öffnen und aktivieren
- die gewünschte Datei per Doppelklick markieren
- Tastenkombination Alt+E und dann M drücken
- in der rechten Fensterhälfte ist jetzt ein leeres Modul eingefügt worden
- in dieses Modul muss der Code eingefügt werden
- im Projektexplorer wird das Modul unter der Datei angezeigt
- speichen und den VBA-Editor mit Alt+F4 schliessen
- die Funktion steht dir jetzt in dieser Datei zur Verfügung

Diese Variante hat dann einen Vorteil wenn du sehr viele Allergene hast, du ersparst dir damit etwas Tipparbeit bei der Formel in A4.
Gruß
Peter
Antwortento top
#6
Zitat:Diese Variante hat dann einen Vorteil wenn du sehr viele Allergene hast, du ersparst dir damit etwas Tipparbeit bei der Formel in A4.
Oder man hat zufällig SpeedTools oder FastExcel installiert. Dann geht es auch so:
Code:
=CONCAT.RANGE(Tabelle1!A9:E9;" ";;WAHR)
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#7
Hallo,

aufgrund ihrer Vorstellung gehe ich mal davon aus, dass Sie das zufällig nicht installiert hat. 05
Gruß
Peter
Antwortento top
#8
Hallo,

da würde ich eine einfache Lösung mit Hilfszeile bevorzugen (ich denke UDF´s sind deutlich oberhalb des vorhanden Levels):

Arbeitsblatt mit dem Namen 'Tabelle2'
 ABCDEFGHIJKL
1  ACGLMFDEHN
2Wiener SchnitzelFleischx         
3A C G L MMehl x x      
4 Eier  x       
5 Brösel x  x     
6 Salz/Pfeffer          
7 Fett/Öl          
8  AA CA C GA C G LA C G L MA C G L MA C G L MA C G L MA C G L MA C G L M

ZelleFormel
A3=VERWEIS(9;1/(B8:R8<>"");B8:R8)
C8=WENN(ZÄHLENWENN(C2:C7;"x");C1;"")
D8=C8&" "&WENN(ZÄHLENWENN(D2:D7;"x");D1;"")
E8=D8&" "&WENN(ZÄHLENWENN(E2:E7;"x");E1;"")
F8=E8&" "&WENN(ZÄHLENWENN(F2:F7;"x");F1;"")
G8=F8&" "&WENN(ZÄHLENWENN(G2:G7;"x");G1;"")
H8=G8&" "&WENN(ZÄHLENWENN(H2:H7;"x");H1;"")
I8=H8&" "&WENN(ZÄHLENWENN(I2:I7;"x");I1;"")
J8=I8&" "&WENN(ZÄHLENWENN(J2:J7;"x");J1;"")
K8=J8&" "&WENN(ZÄHLENWENN(K2:K7;"x");K1;"")
L8=K8&" "&WENN(ZÄHLENWENN(L2:L7;"x");L1;"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

oder auch so:

Arbeitsblatt mit dem Namen 'Tabelle2'
 ABCDEFGHIJKLMNOP
1  ACGLMFDEHNOPRB
2Wiener SchnitzelFleischx             
3A C G L MMehl x x          
4 Eier  x           
5 Brösel x  x         
6 Salz/Pfeffer              
7 Fett/Öl              
8  AA CA C GA C G LA C G L MA C G L MA C G L MA C G L MA C G L MA C G L MA C G L MA C G L MA C G L MA C G L M

ZelleFormel
A3=P8
C8=WENN(ZÄHLENWENN(C2:C7;"x");C1;"")
D8=C8&" "&WENN(ZÄHLENWENN(D2:D7;"x");D1;"")
E8=D8&" "&WENN(ZÄHLENWENN(E2:E7;"x");E1;"")
F8=E8&" "&WENN(ZÄHLENWENN(F2:F7;"x");F1;"")
G8=F8&" "&WENN(ZÄHLENWENN(G2:G7;"x");G1;"")
H8=G8&" "&WENN(ZÄHLENWENN(H2:H7;"x");H1;"")
I8=H8&" "&WENN(ZÄHLENWENN(I2:I7;"x");I1;"")
J8=I8&" "&WENN(ZÄHLENWENN(J2:J7;"x");J1;"")
K8=J8&" "&WENN(ZÄHLENWENN(K2:K7;"x");K1;"")
L8=K8&" "&WENN(ZÄHLENWENN(L2:L7;"x");L1;"")
M8=L8&" "&WENN(ZÄHLENWENN(M2:M7;"x");M1;"")
N8=M8&" "&WENN(ZÄHLENWENN(N2:N7;"x");N1;"")
O8=N8&" "&WENN(ZÄHLENWENN(O2:O7;"x");O1;"")
P8=O8&" "&WENN(ZÄHLENWENN(P2:P7;"x");P1;"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#9
ich bin ganz entzückt, dass mir da so schnell und unglaublich kompetent geholfen wird. leider muss ich euch enttäuschen, und euch sagen, dass gerade die letzten antworten von Peter meine Kompetenz definitiv übersteigen 29

Sehe ich das richtig das das nicht als "einfache" Funktion - damit meine ich, dass das ganze mit einer Formel in der Zielzelle nicht möglich ist?

Es geht ja nicht um meine Datei, sondern die von Muttern 30
Antwortento top
#10
Hallo,

ich habe dir zwei Vorschläge gemacht - einer mit einer benutzerdefinierten Funktion.

Der andere Vorschlag (und auch die Vorschläge von shift-del und Edgar) basiert auf Formellösungen.

Schau dir die Formeln einfach mal in Ruhe an und baue das einfach mal nach, dann wirst du sehen, dass die vorgeschlagenen Formellösungen alle gar nicht so schwierig sind.
Gruß
Peter
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste