Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zählen über lange Liste mit verschiedenen Bedingungen
#1
Hallo,

ich beschäftige mich schon ein paar Stunden mit einem Problem. Vielleicht denke ich auch zu kompliziert oder habe nur ein Brett vor dem Kopf. Ich konnte dazu aber auch nichts in Foren oder sonstwo finden, bei dem ich die Problemstellung übertragen kann:

Es geht darum, zu berechnen, wie viele Personen in einem vorgegebenen Zeitraum in einem Haus gewohnt haben. Diese sollen gezählt werden, sobald sie mindestens einen Tag da waren. Dafür hat man ein Einzugs- und Auszugsdatum, sowie den gewünschten Zeitraum angegeben.

Anschauliches Beispiel:
Person1: Einzug 22.12.2014 - Auszug 13.05.2015
Person2: Einzug 22.03.2015 - Auszug 01.05.2015
Person3: Einzug 22.01.2014 - Auszug 04.02.2015
Person3: Einzug 01.01.2014

Zeitraum für die Erfassung wäre 01.01.2015 bis 28.02.2015

Ich muss dann überprüfen ob
1. Einzugsdatum vor Enddatum

2. Auszugsdatum nach Einzugsdatum

3. Wenn kein Auszugsdatum vorhanden trotzdem mitzählen



Ergebnis müsste dann 3 sein.

Bei mir sieht es so aus:
Einzugsdatum steht jeweils in LISTE!K15 bis LISTE!K30 (Listen erweiterbar - gehen mit mehr Einträgen über K30 oder L30 hinaus)
Auszugsdatum steht in LISTE!L15 bis LISTE!L30 (Kann aber auch sein, dass einzelne Zellen beim Auszugsdatum leer sind, wenn die Person noch nicht ausgezogen ist - diese sollen aber trotzdem mitgezählt werden - ich nehme dann einfach als Auszugsdatum HEUTE() mit gleicher Berechnung)

Zeitspanne: z.B. 01.01.2015 bis 28.02.2015
(die nehme ich aus einer bestimmten Zelle in der sie als „01.01.2015 bis 28.02.2015“ formatiert steht mit: LINKS(B3;FINDEN("-";B3;1)-1)*1 bzw. RECHTS(B3;FINDEN("-";B3;1)-1)*1

Für eine Zeile klappt es beispielhaft wunderbar mit folgender Formel:
=WENN(ISTLEER(LISTE!L20);SUMME(UND(LISTE!K20;(Liste!K20<=RECHTS(B3;FINDEN("-";B3;1)-1)*1);(HEUTE()>=LINKS(B3;FINDEN("-";B3;1)-1)*1)));SUMME(UND(LISTE!K20;(Liste!K20<=RECHTS(B3;FINDEN("-";B3;1)-1)*1);(Liste!L20>=LINKS(B3;FINDEN("-";B3;1)-1)*1))))

sobald ich aber versuche, dass ganz über mehrere Zeilen z.B. die Zeilen 15-100 laufen zu lassen kommt nur 0 raus.

Folgende Sachen habe ich dafür ausprobiert:
=SUMME(WENN(ISTLEER(LISTE!L15:LISTE!L20);ZÄHLENWENNS(LISTE!K15:LISTE!K20;(LISTE!K15:Liste!K20<=RECHTS(B3;FINDEN("-";B3;1)-1)*1);LISTE!L15:LISTE!L20;(HEUTE()>=LINKS(B3;FINDEN("-";B3;1)-1)*1));ZÄHLENWENNS(LISTE!K15:LISTE!K20;(LISTE!K15:Liste!K20<=RECHTS(B3;FINDEN("-";B3;1)-1)*1);LISTE!L15:LISTE!L20;(LISTE!L15:LISTE!L20>=LINKS(B3;FINDEN("-";B3;1)-1)*1))))

Auch mit der folgenden Formel geht es nicht (wobei der Fall, dass kein Auszugsdatum angegeben ist, damit auch noch nicht abgedeckt wäre):
=ZÄHLENWENNS(LISTE!K15:LISTE!K20;LISTE!K15:Liste!K20<=RECHTS(B3;FINDEN("-";B3;1)-1)*1;LISTE!L15:LISTE!L20;LISTE!L15:LISTE!L20>=LINKS(B3;FINDEN("-";B3;1)-1)*1)

Kann mir jemand weiterhelfen?
Antwortento top
#2
(10.07.2015, 14:12)syquest schrieb: Hallo,

ich beschäftige mich schon ein paar Stunden mit einem Problem. Vielleicht denke ich auch zu kompliziert oder habe nur ein Brett vor dem Kopf. Ich konnte dazu aber auch nichts in Foren oder sonstwo finden, bei dem ich die Problemstellung übertragen kann:

Es geht darum, zu berechnen, wie viele Personen in einem vorgegebenen Zeitraum in einem Haus gewohnt haben. Diese sollen gezählt werden, sobald sie mindestens einen Tag da waren. Dafür hat man ein Einzugs- und Auszugsdatum, sowie den gewünschten Zeitraum angegeben.

Anschauliches Beispiel:
Person1: Einzug 22.12.2014 - Auszug 13.05.2015
Person2: Einzug 22.03.2015 - Auszug 01.05.2015
Person3: Einzug 22.01.2014 - Auszug 04.02.2015
Person3: Einzug 01.01.2014

Zeitraum für die Erfassung wäre 01.01.2015 bis 28.02.2015

Ich muss dann überprüfen ob
1. Einzugsdatum vor Enddatum

2. Auszugsdatum nach Einzugsdatum

3. Wenn kein Auszugsdatum vorhanden trotzdem mitzählen



Ergebnis müsste dann 3 sein.

Bei mir sieht es so aus:
Einzugsdatum steht jeweils in LISTE!K15 bis LISTE!K30 (Listen erweiterbar - gehen mit mehr Einträgen über K30 oder L30 hinaus)
Auszugsdatum steht in LISTE!L15 bis LISTE!L30 (Kann aber auch sein, dass einzelne Zellen beim Auszugsdatum leer sind, wenn die Person noch nicht ausgezogen ist - diese sollen aber trotzdem mitgezählt werden - ich nehme dann einfach als Auszugsdatum HEUTE() mit gleicher Berechnung)

Zeitspanne: z.B. 01.01.2015 bis 28.02.2015
(die nehme ich aus einer bestimmten Zelle in der sie als „01.01.2015 bis 28.02.2015“ formatiert steht mit: LINKS(B3;FINDEN("-";B3;1)-1)*1 bzw. RECHTS(B3;FINDEN("-";B3;1)-1)*1

Für eine Zeile klappt es beispielhaft wunderbar mit folgender Formel:
=WENN(ISTLEER(LISTE!L20);SUMME(UND(LISTE!K20;(Liste!K20<=RECHTS(B3;FINDEN("-";B3;1)-1)*1);(HEUTE()>=LINKS(B3;FINDEN("-";B3;1)-1)*1)));SUMME(UND(LISTE!K20;(Liste!K20<=RECHTS(B3;FINDEN("-";B3;1)-1)*1);(Liste!L20>=LINKS(B3;FINDEN("-";B3;1)-1)*1))))

sobald ich aber versuche, dass ganz über mehrere Zeilen z.B. die Zeilen 15-100 laufen zu lassen kommt nur 0 raus.

Folgende Sachen habe ich dafür ausprobiert:
=SUMME(WENN(ISTLEER(LISTE!L15:LISTE!L20);ZÄHLENWENNS(LISTE!K15:LISTE!K20;(LISTE!K15:Liste!K20<=RECHTS(B3;FINDEN("-";B3;1)-1)*1);LISTE!L15:LISTE!L20;(HEUTE()>=LINKS(B3;FINDEN("-";B3;1)-1)*1));ZÄHLENWENNS(LISTE!K15:LISTE!K20;(LISTE!K15:Liste!K20<=RECHTS(B3;FINDEN("-";B3;1)-1)*1);LISTE!L15:LISTE!L20;(LISTE!L15:LISTE!L20>=LINKS(B3;FINDEN("-";B3;1)-1)*1))))

Auch mit der folgenden Formel geht es nicht (wobei der Fall, dass kein Auszugsdatum angegeben ist, damit auch noch nicht abgedeckt wäre):
=ZÄHLENWENNS(LISTE!K15:LISTE!K20;LISTE!K15:Liste!K20<=RECHTS(B3;FINDEN("-";B3;1)-1)*1;LISTE!L15:LISTE!L20;LISTE!L15:LISTE!L20>=LINKS(B3;FINDEN("-";B3;1)-1)*1)

Kann mir jemand weiterhelfen?


Problem ist gelöst. Falls es später noch jemanden interessiert:

=SUMMENPRODUKT((LISTE!L15:LISTE!L100+(LISTE!L15:LISTE!L100=0)*(LISTE!K15:LISTE!K100>0)*HEUTE()>=LINKS(B3; FINDEN("-";B3;1)-1)*1)*(LISTE!K15:LISTE!K100<=RECHTS(B3; FINDEN("-";B3;1)-1)*1))
Antwortento top
#3
Hallo,

da genügt diese Formel:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCD
1EinzugAuszug 15.2.15  bis 15.3.15
215.02.201530.03.2015 4
310.01.201517.03.2015  
412.02.201515.06.2015  
515.03.2015   
605.04.201506.04.2015  
708.04.2015   

ZelleFormel
D2=SUMMENPRODUKT((A2:A8<=TEIL($D$1;SUCHEN("bi";$D$1)+4;10)*1)*(($B$2:$B$8>=LINKS($D$1;SUCHEN(" ";$D$1)-1)*1)+($B2:B8=""))*(A2:A8<>""))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste