Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zählen ohne Duplikate (Bedingung Anfangsbuchstabe)
#1
Guten Tag,

Folgende Formel soll jeden Wert der Spalte BF zählen ohne Duplikate. Als Zusatzbedingung darf die Zelle nicht leer sein und der Wert muss mit dem Buchstaben N Anfangen. Weiterhin muss in der Spalte H ein A1 stehen. Leider gibt er mir immer wieder den Wert 0, welcher jedoch falsch ist. Wo liegt der Fehler?

=SUMMENPRODUKT((VERGLEICH(H1:H9999&BF1:BF9999;H1:H9999&BF1:BF9999;0)=ZEILE(1:9999)*(H1:H9999="A1")*(BF1:BF9999="N*")*(BF1:BF9999<>"")*1))

P.S. : Bitte keine Lösung mit Hilfsspalte, da jeder zusätzliche Mausklick die Kollegen stört -.-

Vielen Dank im Vorraus
Antwortento top
#2
Hallo,

wenn ich Dich richtig verstanden habe, sollte es so funktionieren:

 HBFBG
1A1N15
2A1N2 
3A1N3 
4 N3 
5A1N3 
6A1N4 
7A1H1 
8A1N5 
9A1  
10A2N7 

ZelleFormel
BG1=SUMMENPRODUKT((VERGLEICH(H1:H10&BF1:BF10;H1:H10&BF1:BF10;0)=ZEILE(1:10)*(H1:H10="A1")*(BF1:BF10<>""))*1)-(ZÄHLENWENN(BF1:BF10;"<>N*")-ZÄHLENWENN(BF1:BF10;""))

Warum Du allerdings keine Hilfsspalte verwenden willst, ist mir nicht ganz klar: Was hat eine (ggf. ausgeblendete) Hilfsspalte mit den Mausklicks Deiner Kollegen zu tun ???
Überlegen macht überlegen
Gruss aus dem schönen Hunsrück
_______ Klaus-Martin _______
Antwortento top
#3
Hallo,

die Kollegen bei Office-Hilfe und Office-Loesung disktuieren auch darüber.
Gruß
Peter
[-] Folgende(r) 1 Benutzer sagt Danke an Peter für diesen Beitrag:
  • Kl@us-M.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste