Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Zählen
#1
Hallo Leute,

ich möchte eine Zählfunktion bauen die in Spalte A bis zum Wert 50 geht und dann alle Werte aus Spalte B addiert und auswirft. Danach soll die Funktion in Spalte A alle Werte zwischen 50-100 anschauen und die entsprechenden Werte aus B addieren und auswerfen.

Als Beispiel:
?mage

Jetzt hätte ich gerne das dann in Spalte C 4 steht (der erste Block bis 50) und dann 6 (zwischen 50 und 100) etc, ist das möglich?

Vielen Dank im Voraus
to top
#2
Hola,

für 0 bis 50:

Code:
=SUMMEWENNS(B2:B13;A2:A13;">="&0;A2:A13;"<="&50)


Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • Fennek
to top
#3
Hallo,

mit der Hilfsspalte in C:

=verweis(a2; {0;50;100};{1;2;3}

ist die Summe der Zahlen unter 50:

=summewenn(c2:c100;1;b2:b100)

Und über 50:

=summewenn(c2:c100;2; b2:b100)

Mfg
to top
#4
Vielen Dank schonmal,

das Problem ist nur das die Tablle bis zum Wert 5000 geht. Kann ich Exel "sagen" das er beim Verweis automatisch weiter geht also 150;200.. und 4;5.. etc.?

@Steve1da Excel sagt mir ich hätte zu wenig Argumente Sad

Liebe Grüße
to top
#5
Hola,


Zitat:@Steve1da Excel sagt mir ich hätte zu wenig Argumente 


dann hast du nicht die Formel genommen, die ich gespostet habe.

Gruß,
steve1da
to top
#6
Hallo,


C1 leer lassen! Dann in C2:


Code:
=Summewenn(A:A;"<="&Zeile(a1)*50)-Summe($C$1:$C1)


das nach unten ziehen. Zählt in 50er Schritten soweit Du lustig bist!
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#7
Durchaus richtig, hatte wohl ein schreibfehler!

Kann ich die Formel auch ausweiten das er die ganze Tabell in 50 Schritten durchgeht?

Gruß,
Leo

[quote pid='35542' dateline='1456751330']
@Steve1da Excel sagt mir ich hätte zu wenig Argumente 
[/quote]


dann hast du nicht die Formel genommen, die ich gespostet habe.

Gruß,
steve1da
to top
#8
(29.02.2016, 14:13)BoskoBiati schrieb: Hallo,


C1 leer lassen! Dann in C2:


Code:
=Summewenn(C:C;"<="&Zeile(a1)*50)-Summe($C$1:$C1)


das nach unten ziehen. Zählt in 50er Schritten soweit Du lustig bist!

Hallo Edgar, wenn diese Formel in C2 soll gibt's n fetten Zirkelbezug...!?!?
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#9
Hallo Jörg,

gerade geändert!
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#10
(29.02.2016, 14:13)BoskoBiati schrieb: Hallo,


C1 leer lassen! Dann in C2:


Code:
=Summewenn(A:A;"<="&Zeile(a1)*50)-Summe($C$1:$C1)


das nach unten ziehen. Zählt in 50er Schritten soweit Du lustig bist!

Bei mir kommt jetzt 0 raus, müsste nicht irgendwo noch der Bezug zur Spalte B gemacht werden, damit er weiß wo er zählen muss?
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste