Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

ZÄHLENWENNS über mehrere Spalten
#1
Hallo Excel Community,

ich möchte gern etwas nach 2 Kriterien auszählen, weshalb ich ZÄHLENWENNS verwende. Sofern ich die beiden Kriterien in jeweils einer Spalte suche, geht auch alles gut ("ZÄHLENWENNS(O:O;1;Q:Q;3)" als Beispiel). Nur ist es in meinem Fall so, dass ich in meiner Erhebung für diesen einen untersuchten Aspekt die Möglichkeit einer Mehrfachnennung offen gelassen habe, was dazu führt, dass die Kodes (1; 2; 3; ...) bzw. Werte, die ich als zweites Kriterium verwenden möchte, in mehreren Spalten sein können. Soll am Beispiel heißen: Die 3 (als zweites Kriterium) kann irgendwo im Bereich von P bis T vorkommen. Mit der Formel "ZÄHLENWENNS(O:O;1;Q:T;3)" kommt allerdings immer ein "#Wert!" sofern ein Kriterienbereich breiter als eine Spalte ist. Gibt es eine Möglichkeit bei zwei Bedingungen einen der  Kriterienbereiche auszählen zu lassen, der größer als eine Spalte ist?


Ich hoffe ich hab's einigermaßen verständlich beschrieben.
Vielen Dank im Voraus.
Markus
to top
#2
Hi Markus,


Zitat:Ich hoffe ich hab's einigermaßen verständlich beschrieben.

für mich eindeutig nöö. 32   Stelle dein Problem bitte anhand eines Tabellenausschnittes oder einer Mustertabelle vor. Bitte keine Bildchen.

Die farbigen Texte sind anklickbare Links.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#3
Hi,

ein Versuch:

Tabelle2

ABCDEFGHI
1Hund1Kalb1Hund22
2Hund2Käfer2Elefant34
3Maus3Käfer3
4Ratte1Käfer1
5Ratte2Hund2
6Elefant3Biene3
7Hase1Wespe1
8Schlange2Elefant2
9Elefant3Elefant3
10Schlange1Elefant1
11Kuh2Elefant3
12Pferd3Wildschwein3
Formeln der Tabelle
ZelleFormel
I1=ZÄHLENWENNS($A$1:$A$12;G1;$B$1:$B$12;H1)+ZÄHLENWENNS($D$1:$D$12;G1;$E$1:$E$12;H1)
I2=ZÄHLENWENNS($A$1:$A$12;G2;$B$1:$B$12;H2)+ZÄHLENWENNS($D$1:$D$12;G2;$E$1:$E$12;H2)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Markus7
to top
#4
Hallo,


Code:
=Summenprodukt((O:O=1)*((Q:Q=3)+(R:R=3)+(T:T=3)>0))
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • Markus7
to top
#5
Danke ihr beiden für eure Antworten.
Die Formel von BoskoBiati ist genau das, was ich gesucht habe. Nochmals danke, das hat mir ne Menge Arbeit erleichtert Smile

Beste Grüße
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste