Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

ZÄHLENWENN
#1
Hallo Exelfreunde, ich habe ein Problem. In den Zelle "J11:J43" steht entweder
-laut Dienstplan
-Krank
-Urlaub
in der Zelle "A43" versuche ich über die Funktion "ZÄHLENWENN" die Gesamtheit aller drei Optionen zu erfassen, leider gelingt mir das immer nur mit einer Option! (entweder Krank, Urlaub oder laut Dienstplan)
Kann mir jemand erklären warum?
Gruß
Günther
to top
#2
hi Günther, eine möglihkeit wäre..:

PHP-Code:
=SUMME(ZÄHLENWENN(J11:J43;{"laut dienstplan";"krank";"urlaub"})) 
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#3
Vielen Dank Jockel, leider funktioniert der Code bei mir nicht! Meine EXEL Version ist "Exel 2007 Home and Student"
Gruß
Günther
to top
#4
hallo, wenn die liste erweiterbar sein soll, dann könnte man ff. vorschlagen (siehe A44)..:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGHIJ
1laut Dienstplan         
2Krank         
3Urlaub         
4test         
5          
6          
7          
8          
9          
10          
11          
12          
13          
14          
15          
16          
17          
18          
19          
20          
21          
22          
23          
24          
25          
26          
27         laut Dienstplan
28          
29          
30         Krank
31          
32          
33         Urlaub
34          
35          
36          
37         test
38          
39          
40          
41          
42          
433         
444         

ZelleFormel
A43=SUMME(ZÄHLENWENN(J11:J43;{"laut dienstplan";"krank";"urlaub"}))
A44{=SUMME(ZÄHLENWENN(J11:J43;A1:A10))}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#5
(14.06.2014, 11:55)Guenther52 schrieb: Vielen Dank Jockel, leider funktioniert der Code bei mir nicht! Meine EXEL Version ist "Exel 2007 Home and Student"
Gruß
Günther

hi Günther, das ist schon eigenartig, in XL2003 funzen die... ... also müßten sie erst recht in XL2007 funzen...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#6
Vielen,vielen Dank Jockel jetzt funktioniert die Tabelle wie ich es mir vorstellte. Nochmals vielen Dank für deine schnelle Hilfe!
Gruß
Günther
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste