Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Werte pro Tag abspeichern und löschen.
#1
Hallo an alle,

Ich habe eine Frage, ich würde gerne Werte die ich habe, auf einer nebenstehende Tabelle automatisch übertragen. Jedoch würde ich gern jeden Tag die Werte rechts eintragen und damit speichern. Jedoch sollten sie dann aus der kleinen Tabelle wieder gelöscht werden. Das ist ziemlich schwer zum erklären, vielleicht hat es jemand verstanden, sonst einfach Fragen! Ist das überhaupt möglich?

Hab jetzt ein Bild hinzugefügt. Die rechten Tabellen Werte sollen gelöscht werden wenn der Durchschnitts Wert rechts eingetragen wurde. Jedoch soll es für jeden Tag das eintragen, damit man jeden Tag den Durchschnitt sehen kann.


Viele Grüße und schon Mal Vielen Dank. 

PS.: Erklären ist echt nicht meine Stärke.


Angehängte Dateien
.xlsx   Durchschnitt.xlsx (Größe: 12,06 KB / Downloads: 4)
to top
#2
Hi,

Zitat:PS.: Erklären ist echt nicht meine Stärke.

dann hoffe ich, dass Lesen mehr deiner Stärke entspricht 32 : http://www.clever-excel-forum.de/Thread-...ng-stellen
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#3
(11.03.2016, 14:52)WillWissen schrieb: Hi,

Zitat:PS.: Erklären ist echt nicht meine Stärke.

dann hoffe ich, dass Lesen mehr deiner Stärke entspricht 32 : http://www.clever-excel-forum.de/Thread-...ng-stellen

Lesen kann ich tatsächlich besser! Ich hoffe es ist jetzt besser so.
to top
#4
Hi,

zu deinem eigentlichen Problem habe ich aktuell keine Lösung - das wird, wenn überhaupt, vermutlich nur durch VBA zu lösen sein. Da müssen dir aber die VBA-Spezialisten helfen.

Doch zu deinem Tabellenaufbau:

1. Schmeiß bloß deine verbundenen Zellen in den Mülleimer. Dazu lies dir mal bitte diesen Beitrag durch.
2. Was sollen die Formeln, die du weitab der Tabelle versteckt hast? Das ist doch Blödsinn. Hierzu (momentan noch mit verbundenen Zellen) mein Vorschlag:

Tabelle1

ABCD
32A:2,5
33
34
35B:2,5
36
37
38C:2,5
39
40
Formeln der Tabelle
ZelleFormel
C32=MITTELWERT(B3:B22)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Tabelle1

ABCDEF
27Durchschnitt:2,0
28
29
30
Formeln der Tabelle
ZelleFormel
C27=SUMME(C32;C38)/C35

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#5
Hi,

(11.03.2016, 15:27)WillWissen schrieb: Tabelle1

ABCDEF
27Durchschnitt:2,0
28
29
30
Formeln der Tabelle
ZelleFormel
C27=SUMME(C32;C38)/C35

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

inwiefern ist der Durchschnitt aus 3 Zahlen die Summe von der ersten und der dritten geteilt durch die zweite?

Tabelle1
ABCD
1 ABC
21222
32333
43-101
54
65
76
87
98
109
1110
12
13originalRabe
14 Durchschnitt:1,82,3
15    
16originalWillWissen
17A:2,51,3
18B:2,51,7
19C:2,02,0
Schriftart wird in dieser Tabelle nicht dargestellt

verwendete Formeln
Zelle Formel Bereich N/A
C14=SUMME(C17;C19)/C18
D14=MITTELWERT(C17:C19)
C17=SUMMEWENN(B2:B11;">0")/ZÄHLENWENN(B2:B11;">0")
D17=MITTELWERT(B$2:B$11)
C18=SUMMEWENN(C2:C11;">0")/ZÄHLENWENN(C2:C11;">0")
D18=MITTELWERT(C$2:C$11)
C19=SUMMEWENN(D2: D11;">0")/ZÄHLENWENN(D2: D11;">0")
D19=MITTELWERT(D$2: D$11)

Schriftformate
Zelle Rot Grün Blau Color Stil Unterstreichung Effekte Durchgestrichen Schriftart
A1:A11, A14: D15,  B1: D1 0000Fett  
Zellen mit Schriftformatierung automatisch werden nicht dargestellt
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 19.08 einschl. 64 Bit



Hier eine Beispieldatei mit Button zum Übertragen der Tagesdurchschnitte in die Tagesliste:

.xlsb   Durchschnitt - Rabe.xlsb (Größe: 20,41 KB / Downloads: 1)
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#6
Hi Ralf,

ich habe nicht hinterfragt, warum er so oder so einen Mittelwert berechnen will; ich habe lediglich seine bereits vorhandene, etwas umständlichere Formel in eine leichter verständlichere "übersetzt".
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#7
Hi Günter,

(14.03.2016, 21:07)WillWissen schrieb: ich habe nicht hinterfragt, warum er so oder so einen Mittelwert berechnen will; ich habe lediglich seine bereits vorhandene, etwas umständlichere Formel in eine leichter verständlichere "übersetzt".

das ist mir klar, drum habe ich ja auch nicht Dich direkt angesprochen, sondern nur allgemein "Hi" geschrieben, denn wie in meinem Ausschnitt zu erkennen ist, ergibt Deine Formel den richtigen Mittelwert und die Original-Formel einen (in meinen Augen) falschen, also gar keinen Mittelwert.
Ich habe die Mittelwert-Berechnung anders gelernt als: 1. + 3. Zahl geteilt durch 2. Zahl.
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#8
Hallöchen,

Einen Mittelwert wollte der TE gar nicht, er spricht von Durchschnitt.

Wenn z.B. in Spalte A (ich meine jetzt die Überschrift A) Äpfel rein kommen und in Spalte C auch, und in Spalte B stehen die Erntehelfer, dann kann ich nach Addition der Äpfel aus A und C und anschließender Division durch die Erntehelfer in B die durchschnittliche Leistung / Menge pro Helfer errechnen. Dass die Helfer in der Mitte stehen könnte vielleicht daran liegen, dass sie jeweils rechts und links einen Korb mit Äpfeln tragen, ...
Man könnte natürlich auch statt Äpfel Birnen nehmen und das dann vergleichen oder etwas in der Art :-)

Mann, ich hab heute bestimmt einen Clown verschluckt 15
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste