Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wert einer Zelle in einer anderen Zelle suchen
#1
Hi,

ich habe folgende Formel in Verwendung:

=SUMMEWENN(B:B;AM257;Z:Z)-SUMMEWENN(AM:AM;B257;BJ:BJ)

Wenn Excel in der Spalte B den Wert (in dem Fall eine Zahl) von Zelle AM257 findet, soll Excel die Zahlen von Spalte Z, mit dem Wert von AM257 in der gleichen Zeile, addieren.

Jetzt ist es aber so, dass AM257 nicht nur eine Zahl sondern bis zu 3 Zahlen enthalten kann: 156269, 15166, 15067. Spalte B enthält nur 1 Zahl: 15166.

Gibt es eine Formel, die Spalte B nach den einzelnen Zahlen "15269" "15166" und "15067" durchsuchen kann?

Beispieldatei ist im Anhang

Lg


Angehängte Dateien
.xlsx   Beispiel.xlsx (Größe: 9,08 KB / Downloads: 5)
Antwortento top
#2
Hola,

hier jetzt also auch.

http://www.herber.de/forum/messages/1402689.html

http://ms-office-forum.net/forum/showthr...p?t=318026

Gruß,
steve1da
Antwortento top
#3
Hallo,

ohne dass Dopelte eliminiert werden:

Code:
=SUMMENPRODUKT((ISTZAHL(SUCHEN(A2;$C$2:$C$7))*($B$2:$B$7-$D$2:$D$7)))
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • martin84
Antwortento top
#4
danke, funktioniert wunderbar =)

ich hätte jetzt noch eine andere rechnung, bei der ich statt subtrahieren dividieren muss. wenn ich einfach das minus in der gleichen formel auf dividieren ändere, schreibt er aber #DIV/0! in die zelle.

muss ich dann mehr ändern als das vorzeichen?

lg
Antwortento top
#5
und kann man die formel so ändern, dass er die zahlen findet, wenn die zelle mit 3 zahlen als "ausgangswert" in spalte A ist?

siehe anhang

lg


Angehängte Dateien
.xlsx   Beispiel2.xlsx (Größe: 9,13 KB / Downloads: 2)
Antwortento top
#6
Hallo,

könntest Du vielleich in klaren Worten erläutern, was Du durch was dividieren willst, am besten mit Beispielen in der Tabelle????
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#7
Beschreibung ist in der Datei

Danke

Lg


Angehängte Dateien
.xlsx   Beispiel.xlsx (Größe: 11,08 KB / Downloads: 8)
Antwortento top
#8
Hat keiner eine Idee, wie das funktionieren könnte?

Oder ist die Beschreibung unklar?
Antwortento top
#9
Hi,

(22.01.2015, 08:56)martin84 schrieb: Hat keiner eine Idee, wie das funktionieren könnte?

Oder ist die Beschreibung unklar?

Aufgabe aus der Datei:
Zitat:Die Formel sollte die Gewichte in Spalte B addieren, welche zu den Chargen von Spalte C gehören (die Chargen von Spalte C in Spalte A suchen und das Gewicht aus Spalte B in der jeweiligen Zeile addieren.
Danach sollte der Lagerverlust durch diese Summe dividiert werden, damit man den Prozentwert ermitteln kann.

Die Excel Datei hat 530 Zeilen und 67 Spalten und es gibt mehrere Zellen (Spalte C) mit 2 oder 3 Chargen.

also ich würde die Spalte C "Charge" auf mehrere Hilfsspalten aufsplitten und dann mit SUMMEWENN + SUMMEWENN +SUMMEWENN + ... bis zur maximal möglichen Zahl an Chargen summieren.

Das Dividieren des entsprechenden Lagerverlust (Spalte E) durch diese Summe kriegst Du ja alleine hin oder?

Als ersten Ansatz so:

Tabelle1
ABCDEFGHIJKLMNOPQR
1ChargeGewichtChargeRestmengeLagerverlustLagerverlust %Soll Ergebnis
Lagerverlust %
Charge 1Charge 2Charge 3Charge 4Summe 1Summe 2Summe 3Summe 4
2151061725015106, 15121102503441,99420289855072E-021,67038943381567E-02151061512117250334400
315107212015107, 15122, 1516869031060,055,52601397143155E-0315107151221516821201452225400
415110190015110189642,10526315789474E-032,10526315789474E-03151101900000
515121334415106, 15121100003440,1028708133971291,67038943381567E-02151061512117250334400
6151221452215107, 15122, 1516862331067,2992700729927E-035,52601397143155E-0315107151221516821201452225400
715168254015107, 15122, 1516859401064,17322834645669E-025,52601397143155E-0315107151221516821201452225400

verwendete Formeln
Zelle Formel Bereich N/A
H2=E2/(B2+B5)
H3=E3/(B3+B6+B7)
H4=E4/B4
H5=E5/(B2+B5)
H6=E6/(B3+B6+B7)
E2:E7=SUMMENPRODUKT((ISTZAHL(SUCHEN(A2;$C$2:$C$7))*($B$2:$B$7-$D$2:$D$7)))
F2:F7=E2/B2
H7=E7/(B3+B6+B7)
J2:J7=LINKS(C2;5)
K2:K7=WENNFEHLER(TEIL(C2;FINDEN(" ";C2;6)+1;5);"")
L2:L7=WENNFEHLER(TEIL(C2;FINDEN(" ";C2;12)+1;5);"")
M2:M7=WENNFEHLER(TEIL(C2;FINDEN(" ";C2;18)+1;5);"")
O2:R7=SUMMEWENN($A$2:$A$7;J2;$B$2:$B$7)
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit

[-] Folgende(r) 1 Benutzer sagt Danke an Rabe für diesen Beitrag:
  • martin84
Antwortento top
#10
Danke das hat mir schon geholfen.

Ein kleines Problem gibt's noch:

Wenn in J2:M7 keine Zahl steht, schreibt mir die Formel =SUMMEWENN($A$2:$A$7;J2;$B$2:$B$7) keine Null sondern 6838. Ich weiß nicht woher er die Daten nimmt.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste