Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Wert(e) suchen und Summe bilden
#1
In einer Tabelle (C5:N6) -siehe Anhang - soll

a) der Wert des lfd. Monats (hier: März) und

b) die Summe der seit Jahresbeginn bis dahin aufgelaufenen Beträge ermittelt werden.

a) funktioniert über die Formel =WVERWEIS(VERGLEICH(MONAT(HEUTE());C5:H5);C5:H6;2), das Ergebnis ist in B11 abgelegt.

Seine Adresse ergibt sich aus =ADRESSE(SUMMENPRODUKT((C5:N6=B11)*ZEILE(5:6));SUMMENPRODUKT((C5:$N6=B11)*SPALTE(C:N));4) und ist in B 14 abgelegt.

Wie berechne ich b) ?

Hardbopper


.xlsx   Wert suchen und anderen Wert ausgeben.xlsx (Größe: 9,08 KB / Downloads: 7)
to top
#2
Hallo

C11
Code:
=INDEX(C6:N6;VERGLEICH(MONAT(HEUTE());C5:N5;0))

Für die Summe:
Code:
=SUMME(C6:INDEX(C6:N6;VERGLEICH(MONAT(HEUTE());C5:N5;0)))
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#3
Danke shift-del,

funktioniert einwandfrei - eine Frage habe ich aber noch:

Wenn =WVERWEIS(VERGLEICH(MONAT(HEUTE());C5:H5);C5:H6;2) ebenfalls den gesuchten Monatswert ermittelt, warum funktioniert dann =SUMME(C6:WVERWEIS(VERGLEICH(MONAT(HEUTE());C5:H5);C5:H6;2)) nicht ?

Hardbopper
to top
#4
(01.03.2016, 21:09)shift-del schrieb: Hallo

C11
Code:
=INDEX(C6:N6;VERGLEICH(MONAT(HEUTE());C5:N5;0))

Hallo Detlef, wieso hier VERGLEICH()..? Den kann man hier getrost weglassen... ... meinst du nicht auch..?
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#5
Zitat:Wenn =WVERWEIS(VERGLEICH(MONAT(HEUTE());C5:H5);C5:H6;2) ebenfalls den gesuchten Monatswert ermittelt, warum funktioniert dann =SUMME(C6:WVERWEIS(VERGLEICH(MONAT(HEUTE());C5:H5);C5:H6;2)) nicht ?
Weil INDEX() so programmiert wurde und WVERWEIS() nicht.

@Jörg
Du hast selbstredend recht:
Code:
=INDEX(C6:N6;MONAT(HEUTE()))
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
  • Hardbopper
to top
#6
Noch eine letzte Frage an die Experten:

Wieso kann die Formel =INDEX(C6:N6;MONAT(HEUTE())) auch den Bereich C5:N5 mit auswerten, obwohl - abweichend von der "VERGLEICH()"-Variante - kein Bezug zur Zeile 5 erkennbar ist ?

Hardbopper
to top
#7
(02.03.2016, 19:36)Hardbopper schrieb: Noch eine letzte Frage an die Experten:

Wieso kann die Formel =INDEX(C6:N6;MONAT(HEUTE())) auch den Bereich C5:N5 mit auswerten, obwohl - abweichend von der "VERGLEICH()"-Variante - kein Bezug zur Zeile 5 erkennbar ist ?

Hardbopper

Hallo, eigentlich müßte es (politisch) korrekt =INDEX(C6:N6;;MONAT(HEUTE())) heißen... ... du suchst doch den Wert aus Zeile 6. Schau dir doch die Syntax an... MONAT(HEUTE()) bringt den Spaltenwert, da deine Zeile 5 aufsteigend sortiert ist und mit 1 beginnt braucht's kein VERGLEICH()...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#8
Zitat:Hallo Detlef, wieso hier VERGLEICH()..? Den kann man hier getrost weglassen... ... meinst du nicht auch..?

Hallo, eigentlich müßte es (politisch) korrekt =INDEX(C6:N6;;MONAT(HEUTE())) heißen... ... du suchst doch den Wert aus Zeile 6. Schau dir doch die Syntax an... MONAT(HEUTE()) bringt den Spaltenwert, da deine Zeile 5 aufsteigend sortiert ist und mit 1 beginnt braucht's kein VERGLEICH()...




Ich nehme - auch stellvertretend für andere Nutzer, die das "hier" in Deinem Zitat vielleicht überlesen - zur Kenntnis, dass diese Formelvariante nur für oben zitierten Sonderfall gilt, es ansonsten bei 
  
=INDEX(C6:N6;VERGLEICH(MONAT(HEUTE());C5:N5;0))

bleibt.

Hardbopper
to top
#9
(02.03.2016, 23:21)Hardbopper schrieb: Ich nehme - auch stellvertretend für andere Nutzer, die das "hier" in Deinem Zitat vielleicht überlesen - zur Kenntnis, dass diese Formelvariante nur für oben zitierten Sonderfall gilt, es ansonsten bei 
  
=INDEX(C6:N6;VERGLEICH(MONAT(HEUTE());C5:N5;0))

bleibt.

Hardbopper

Hallo, auch hier müsste es korrekt(er) =INDEX(C6:N6;;VERGLEICH(MONAT(HEUTE());C5:N5;0)) oder =INDEX(C6:N6;1;VERGLEICH(MONAT(HEUTE());C5:N5;0)) heißen... ... oder was meinst du mit deiner Annahme..? Ein Blick in die online-Hilfe, Funktionsassistent oder Formelauswertung kann helfen...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#10
Danke, aber ich habe ungeprüft die Version von Jörg (21.9. 16 21:09) übernommen, die bei mir auch funktioniert hat und daher keinen Anlass zur Nachfrage gegeben hat.

Hardbopper
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste