Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Wenn in Zelle best. Wort dann andere Zelle "x"
#1
Hallo,

bin neu hier und würde mich freuen wenn mir jemand helfen könnte.

Ich habe folgendes Problem, wenn in Spalte " D" ab Zeile 4 bis zum letzten Datensatz in Spalte
"D" das Wort "Mindest*" ( konnte Mindestbelegung, Mindestbesetzung, usw. heisen) , dann soll
in Spalte "F" der entsprechenden Zeile ein "x" stehen.

ich würde das als Makro benötigen da sich die Daten in den Spalten A- F immer wieder ändern.

Gruß Johann
to top
#2
Hallo Johann,

diese Formel in F4 dann einfach runterziehen:

=WENN(LINKS(A4;7)="Mindest";"x";"")

Gruß Uwe
to top
#3
Hi Johann,

und hier noch eine Lösung für den Suchtext irgendwo dazwischen.

Tabelle2

ABCDE
1Text110Text100maximal
2Text211Text101mindestensx
3Text312Text102zumindestx
4Text413Text103Mindestlohnx
5Text514Text104Mindestanzahlx
6Text615Text105Höchst-& Mindestlohnx
Formeln der Tabelle
ZelleFormel
E1=WENN(ZÄHLENWENN(D1;"*mindest*")<>0;"x";"")
E2=WENN(ZÄHLENWENN(D2;"*mindest*")<>0;"x";"")
E3=WENN(ZÄHLENWENN(D3;"*mindest*")<>0;"x";"")
E4=WENN(ZÄHLENWENN(D4;"*mindest*")<>0;"x";"")
E5=WENN(ZÄHLENWENN(D5;"*mindest*")<>0;"x";"")
E6=WENN(ZÄHLENWENN(D6;"*mindest*")<>0;"x";"")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#4
Hallo Johann,

hier mal noch eine Variante, bei der Excel zwischen Groß- und Kleinschreibung unterscheidet.
Wie heißt es doch gleich - Aller Cleverer Dinge sind 3 ;-)
(Falls noch Lösungen kommen, die sind bestimmt auch clever ;-) )

Mit einer benutzerdefinerten Formatierung kannst Du WAHR und FALSCH auch in das x umwandeln. Ich habe es zur Verdeutlichung gesondert in Spalte F getan. Die Formel und Formatierung hab ich nur für die erste Zeile dargestellt, brauchst das dann nur nach unten ziehen.

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFG
1Text110Text100maximalWAHRWAHR 
2Text211Text101mindestensFALSCHFALSCHx
3Text312Text102zumindestFALSCHFALSCHx
4Text413Text103MindestlohnWAHRFALSCHx
5Text514Text104MindestanzahlWAHRFALSCHx
6Text615Text105Höchst-& MindestlohnWAHRFALSCHx

ZelleFormatWert
G1"";"";"x"1

ZelleFormel
E1=ISTFEHLER(FINDEN("mindest";D1;1))
F1=ISTFEHLER(SUCHEN("mindest";D1;1))
G1=F1*1
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
to top
#5
Hi André,

wirklich ganz schön clever Wink

Doch hilf mir bitte mal auf die Sprünge bzgl. der ben.-def. Formatierung. Was bewirkt die Kombination "";"";"x" im Einzelnen? Kannst du mir das mal aufdröseln? Ich komme nicht drauf.

Danke.
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#6
Hallo Günter,

das ist für negative Werte, 0 und positive Werte. Daher auch die Multiplikation mit 1, um statt WAHR oder FALSCH einen Zahlenwert zu erreichen. Du kannst in diesem Fall praktisch alle Zahlen durch Buchstaben oder nichts ersetzen.
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
to top
#7
Danke, André,

das mit der Plutimikation wusste ich, dank deiner Erklärung habe ich nun auch die ben.-def. Formatierung verstanden.
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#8
Hallo zusammen,

erst mal Danke für die Antworten, aber ich bräuchte das als Makro, da ich das gern in ein bestehendes Makro mit einbinden möchte, da die Tabelle mit verschiedenen Makros gefüllt und bearbeitet wird.

Würde mich freuen wenn jemand mir ein Makro dazu senden könnte.

Gruß Johann
to top
#9
Hallo Johann,

kannst Du uns erst einmal verraten, welcher Lösungsvorschlag denn passen würde?
Die Formeln würden dann auch nur per Makro eingetragen werden (zumindest bei mir).

Gruß Uwe
to top
#10
Hallo,

wie kann ich den Formeln per Makro eintragen?

Habe mir das so gedacht:

Sub Mein Makro() ' Daten einfügen
Dim .....
....
...
...
...

call Makro_x
...
...

End Sub

So Habe ich mir das gedacht.

Gruß Johann
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste