Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert sind; Die von diesem Forum gesetzten Cookies düfen nur auf dieser Website verwendet werden und stellen kein Sicherheitsrisiko dar. Cookies auf diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Die Updates sind abgeschlossen. Bitte meldet eventuelle Bugs und Auffälligkeiten im entsprechenden Forum.
Sollte das Loginfenster nicht sichtbar sein, ist es unten links. Entweder Ihr loggt Euch dort ein oder löscht den Browsercache und versucht es noch einmal.


Wenn Zelle leer, dann ""
#1
Hallo,

ich habe folgende Formel: INDEX('Drittmittel in Zeilen'!$A:$ZZ;SPALTE(A1);ZEILE(A1)) und möchte erreichen, dass die Zelle leer bleibt, wenn sich eine 0 aus der Formel ergibt.

Dazu habe ich folgende Formeln gefunden:

=WENN(Formel)=0,"",(Formel)) oder
=WENN(ISTLEER(Formel),"",Formel)

Folgende Formel funktioniert einwandfrei:
=WENN(ISTLEER(INDEX('Drittmittel in Zeilen'!$A:$ZZ;SPALTE(A1);ZEILE(A1)));"";(ISTLEER(INDEX('Drittmittel in Zeilen'!$A:$ZZ;SPALTE(A1);ZEILE(A1)))))

Leider kann taucht beim ziehen der Formel nach rechts oder unten "FEHLER" auf. Was mache ich falsch?
Vorab vielen Dank!

Liebe Grüße
Antwortento top
#2
Ich hab's!

=WENN(ISTLEER(INDEX('Drittmittel in Zeilen'!$A:$ZZ;SPALTE(A1);ZEILE(A1)));"";(INDEX('Drittmittel in Zeilen'!$A:$ZZ;SPALTE(A1);ZEILE(A1))))

:-)
Antwortento top
#3
Hallo,

Zitat: dass die Zelle leer bleibt, wenn sich eine 0 aus der Formel ergibt.

Ich würde in diesem Fall einfach mit einem benutzerdefinierten Zahlformat arbeiten. Das könnte z.B. so aussehen:

#.##0,00;-#.##0,00;

oder auch so

0;-0;

Wichtig ist das letzte Semikolon dass die Null ausblendet.
Gruß
Peter
[-] Folgende(r) 1 Benutzer sagt Danke an Peter für diesen Beitrag:
  • veve
Antwortento top
#4
Das ist ein super Tipp!
Danke!

Liebe Grüße
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste