Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wenn Wert von SVerweis1 kleiner als Wert von SVerweis2 ?
#1
Hallo ihr Lieben!

Ich bin gerade etwas am Verzweifeln weil ich hier eine sehr komplexe Aufgabenstellung vor mir habe.

In unserer Arbeitsmappe werten wir Gewinn/Marge von Übersetzungen aus.

Dazu haben wir in einem Blatt Übersetzerpreise (Einkauf) und Kundenpreise (Verkauf) festgelegt.

Für jeden Auftrag muss man drei Punkte festlegen: Kunde, Übersetzer, Sprache
Daraus werden nun für Ein- und Verkauf jeweils Codes generiert. Also z.B. DE-TR-ULLI für Einkauf und DE-TR-MaxGMBH für den Verkauf.

In meiner Auswertung kann ich nun durch den SVERWEIS mit dem Code alle benötigen Preise ansteuern. Ungefähr so =SVERWEIS(C38;UebPreise!$F$4:$T$61;2;FALSCH)*AK38
Soweit so gut.

Das funktioniert auch alles wunderbar. Das Problem ist folgendes, wenn der Wert aus dem SVERWEIS kleiner als ein Mindestwert ist, dann müsste in der Zelle nicht das Ergebnis der SVERWEIS sondern ein Mindestpreis stehen.
Und dieser Mindestpreis müsste ebenfalls durch einen SVERWEIS abgefragt werden.

Ja, total kompliziert und ich bin überfordert. Ich dachte erst an eine Kombination aus WENN ISTZAHL "Das klappt jedoch überhaupt nicht.

Irgendwelche Tipps? :/

Danke!
Antwortento top
#2
Hola,

rein von der Logik her:


Code:
=wenn(SVERWEIS(C38;UebPreise!$F$4:$T$61;2;FALSCH)*AK38<irgendein_Mindestwert;Anderer_Sverweis;SVERWEIS(C38;UebPreise!$F$4:$T$61;2;FALSCH)*AK38)




Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • Bummi
Antwortento top
#3
(14.06.2016, 09:37)steve1da schrieb:
Code:
=wenn(SVERWEIS(C38;UebPreise!$F$4:$T$61;2;FALSCH)*AK38<irgendein_Mindestwert;Anderer_Sverweis;SVERWEIS(C38;UebPreise!$F$4:$T$61;2;FALSCH)*AK38)

Wow super, das funktioniert erst mal ausgezeichnet. Kann denn "irgendein_Mindestwert" auch noch ein SVERWEIS sein? Damit wären dann 4 verschiedene in der Formel.

//Edit: Alles klar, funktioniert. Klappt alles einwandfrei. VIELEN DANK!
Antwortento top
#4
Hi,

geht auch kürzer

=max(SVERWEIS(C38;UebPreise!$F$4:$T$61;2;0);ANDERER_SVERWEIS_MIN)*AK38
lg Chris
Feedback nicht vergessen.
3a2920576572206973742064656e20646120736f206e65756769657269672e
 [Bild: v.gif]

Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste