Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Wenn Wenn Formel
#1
Hallo, 

Ich habe folgendes Problem, ich möchte zwei Werte miteinander abgleichen, und den höheren Wert angezeigt bekommen.

z.B.



A1= 200 B1=
A2=        B2= 50
A3= 80   B3= 

Jetzt habe ich mit der WENN Formel Probiert die Beiden Zeilen abzugleichen. Ich möchte jetzt das in H1 der größere Wert von A1 oder B1 angezeigt wird usw.

Ich habe dazu die Formel =WENN(A1>0,1;A1;"")+WENN(B1>0,1;B1;"")
Entweder sind beide Zeilen leer oder eine von den Beiden hat eine Zahl drin die Größer als 0,1 ist.

Wenn ich diese Formel so nehme kommt als Lösung immer "#WERT!"
wo liegt Fehler, ich hoffe mir kann dabei einer behilflich sein Smile

Gruß
Christian
to top
#2
Moin!
Der höhere Wert ist schlicht MAX()
=MAX(A1;B1)

Gruß Ralf
to top
#3
Hallo Ralf

Danke für deine schnelle Antwort Smile

Da ich keine Nullwerte in der Tabelle haben darf, habe ich die Former einfach auf 

=WENN(MAX(A1;B1)>0;MAX(A1;B1);" ")

geändert, und siehe da.. es Funktioniert und Excel kann so einfach sein Big Grin


Danke für dein Tip
to top
#4
Hallo mal wieder!
Wenn Dich die Nullwerte nur optisch stören, kannst Du die Anzeige auch mittels benutzerdefiniertem Zahlenformat Standard;;; verhindern.
(Sicherlich sinnvoller als Dein " ")
Lesefutter zum Zahlenformat:
http://www.online-excel.de/excel/singsel.php?f=71

Gruß Ralf
to top
#5
heje excelfreunde,

habe mal in etwa alle drei ansätze gemischt und meinen an den von christian_87 "1" angenähert.

=WENN(UND(A1>0;B1>0);MAX(A1:B1);"Zahlenvergleich nicht möglich")
Vielen Dank
--Janosch
                                                     
Excel 2007 (SP3), Win 10 Pro                              
to top
#6
Ich finde dies immer noch besser:

ABC
1

ZelleFormatWert
C1Standard;;;0

ZelleFormel
C1=MAX(A1;B1)

Gruß Ralf
to top
#7
heje excelfreunde, RPP63

RPP63, ich gebe dir recht, in der regel gilt: in der kürze liegt die würze...
aber wir wissen eben nicht alles was christian_87 weiß, bzw. was er mit seiner abfrage genau will...
Vielen Dank
--Janosch
                                                     
Excel 2007 (SP3), Win 10 Pro                              
to top
#8
Hi Janosch!
Aus der Threaderöffnung:
Zitat:Entweder sind beide Zeilen leer oder eine von den Beiden hat eine Zahl drin die Größer als 0,1 ist.
Würde ich in Verbindung mit der Datenüberprüfung angehen:

ABC
1 0,123456790,12345679

ZelleFormatWert
C1Standard;;;0,1234567890142

ZelleFormel
C1=MAX(A1;B1)

ZelleGültigkeitstypOperatorWert1Wert2
A1Dezimalzahlzwischen=0,1 +0,1%%%%=10^306
B1Dezimalzahlzwischen=0,1 +0,1%%%%=10^306

EDIT:
Datenüberprüfung natürlich so:
Dezimal größer als 0,1

Gruß Ralf
to top
#9
heje excelfreunde, RPP63

keine frage, aber bevor man übers ziel hinausschießt, christian_87 hat sich in #3 selbts korrigiert:

Zitat:Da ich keine Nullwerte in der Tabelle haben darf, habe ich die Former einfach auf

=WENN(MAX(A1;B1)>0;MAX(A1;B1);" ")

geändert, und siehe da.. es Funktioniert und Excel kann so einfach sein
Vielen Dank
--Janosch
                                                     
Excel 2007 (SP3), Win 10 Pro                              
to top
#10
(23.02.2016, 12:07)RPP63 schrieb: Hallo mal wieder!
Wenn Dich die Nullwerte nur optisch stören, kannst Du die Anzeige auch mittels benutzerdefiniertem Zahlenformat Standard;;; verhindern.
...

Gruß Ralf

Hallo Ralf, hier sollten zwei Semi's reichen... ... man muss ja nicht immer so aasen... 21
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste