Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wenn Dann Funktion zur Notenberechnung
#1
Guten Abend,

ich habe eine für Sie sicher sehr einfache Frage, mich beschäftigt sie jetzt aber schon seit mehreren Stunden und ich bin mit meinem Latein am Ende.
Ich habe eine Tabelle erstellt, die einem eine Übersicht über bereits geschriebene Klausuren und die Ergebnisse liefert.

Nun möchte ich gerne dass aufgrund der errechneten (aktuellen) Punktzahl die momentane Abschlussnote angezeigt wird.


0-62 Arbeitspunkte: 0 Notenpunkte
63-125 Punkte: 1 Notenpunkt
126-188 Punkte: 2 Notenpunkte
189-251 Punkte: 3 Notenpunkte
252-314 Punkte: 4 Notenpunkte

usw.

Ich habe also beispielsweise im Feld F24 100 Arbeitspunkte und möchte jetzt, dass im Feld A27 der Text "1 Notenpunkt" erscheint.

Ich wäre sehr dankbar, wenn mir hier jemand helfen könnte! :s
Antwortento top
#2
Hallo

Eine Aufgabe für SVERWEIS().
SVERWEIS() hat vier Parameter.
Falls die erste Spalte nicht aufsteigend sortiert ist, muß der vierte Parameter zwingend FALSCH sein.

Die konkrete Aufgabenstellung erfordert eine aufsteigend sortierte Spalte.
Es reicht hier die "von"-Angabe.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#3
Hi,

oder

=VERGLEICH(A2;{0.63.126.189.252};1)-1

in A2 deine Punkte
bzw. leichter veränderbar mit zusätzlichen Datenangaben in einer Spalte siehe Bsp.

.xlsx   notenpunkt.xlsx (Größe: 11,38 KB / Downloads: 7)
lg Chris
Feedback nicht vergessen.
3a2920576572206973742064656e20646120736f206e65756769657269672e
 [Bild: v.gif]

Antwortento top
#4
Das ist wirklich zu hoch für mich.  Huh


Ich habe mal meine bisher zusammengebastelte Tabelle eingefügt. Könnte mir das vielleicht jemand in A27 reinschreiben?
(Zumindest den Anfang, wenn ich den habe kann ich den Rest bestimmt selbst 17 )


Angehängte Dateien
.xlsx   Klausurenrechner.xlsx (Größe: 11,67 KB / Downloads: 6)
Antwortento top
#5
Hola,

da fehlt ja die zu Grunde liegende Tabelle mit den Punkten.

Schreib z.B. in L1 bis L5 die Zahlen: 0, 63, 126, 189, 252
Daneben in M1 bis M5 die Zahlen: 0, 1, 2, 3, 4

Dann in zur Errechnung der Notenpunkte:

=WENNFEHLER(SVERWEIS(D5;L1:M5;2);"")

Gruß,
steve1da
Antwortento top
#6
Code:
=int(F24/62) & " Punkte"

Code:
=ganzzahl(F24/62) & " Punkte"
Antwortento top
#7
Hi snb,

du hast einen kleinen Fehler in deiner Formel. Es muss heißen:



Zitat:=ganzzahl(F24/63) & " Punkte"
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
Antwortento top
#8
Hi,

immer diese Monsterformeln ^^

=KÜRZEN(F24/63)

Wobei wenn sich der Schlüssel ändert, wäre ein Verweis auf eine Matrix wohl besser.

Edit: was wäre jetzt eigentlich bei 62,5?
Ist das 1 oder 0
wenn dies schon 1 sein sollte
=runden(f24/63;0)
lg Chris
Feedback nicht vergessen.
3a2920576572206973742064656e20646120736f206e65756769657269672e
 [Bild: v.gif]

Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste