Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wenn-Dann Funktion auf die letzten 2 Zahlen anwenden
#1
Hallo Leute,


ich bin am verzweifeln.

Ich habe eine Liste mit 100 Nummern welche 10 Stellig sind, bei diesen Nummern möchte ich das Zahlen die kleiner sind als 10, 30, 50, 70 und 90 jeweils + 10 gerechnet werden.

Angenommen die Zahl liegt nahe des 30er bereichs, so soll diese Zahl auch zwischen 30-39 bleiben, wenn die Zahl aber auf 29 fällt, soll sie wieder + 10 gerechnet werden um auf 39 zu kommen.

Das gleiche gilt für die anderen Bereiche 50, 70, 90 usw.

Bekomme das Leider nicht hin.

Hier mal ein Beispiel der Zahlen

5223451210 -> 5223451210
5223451229 -> 5223451239
5223451235 -> 5223451235
5223451250 -> 5223451250
5223451269 -> 5223451279


Die Funktion ansich bekomme ich ja hin, allerdings nicht nur auf die letzten 2 Zahlen.


Hoffe ich konnte gut erklären  wie ich das meinte und was mein problem ist.
Antwortento top
#2
Hallo, meinst du so..?

=WENN(WENNFEHLER(VERGLEICH(REST(A1;100);{9;29;49;69;89};0);0);10)+A1

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCD
15223451210-> 52234512105223451210
25223451229-> 52234512395223451239
35223451235-> 52234512355223451235
45223451250-> 52234512505223451250
55223451269->52234512795223451279

ZelleFormel
D1=WENN(WENNFEHLER(VERGLEICH(REST(A1;100);{9;29;49;69;89};0);0);10)+A1
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • Ostseeman
Antwortento top
#3
Hmm, das sieht schonmal gut aus, kannst du mir die Formal nochmal für nur eine Zahl machen, da sind ja gleich alle drinSmile

Die würde ich mir dann zurecht basteln.


Also Beispiel


5223451229 


Also dann nur die 29 in der Formel mit +10 ersetzen.

#Edit1 : achso und am besten mit kleiner als 29, also <29

#Edit2: Danke dir, bei mir lautet die Richtige Formel nun

=WENN(REST(1;100)<30;A1+10;A1+0)
Antwortento top
#4
Hallo,

vielleicht passt das auch?

=A1+((REST(RECHTS(A1;2);20)<10)*10)

Gruß Uwe
Antwortento top
#5
(25.05.2016, 22:36)Ostseeman schrieb: Hmm, das sieht schonmal gut aus, kannst du mir die Formal nochmal für nur eine Zahl machen, da sind ja gleich alle drinSmile

Die würde ich mir dann zurecht basteln.


Also Beispiel


5223451229 


Also dann nur die 29 in der Formel mit +10 ersetzen.

achso und am besten mit kleiner als 29, also <29

Hallo, das verstehe ich nicht... nur die 29? Oder doch lieber alles was kleiner ist als 29... ... was stimmt denn an dem Vorschlag nicht?
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
Antwortento top
#6
Hi Uwe,


also folgende Lösung habe ich dank Jockel gefunden

Bei 10

=WENN(REST(A1;100)<10;A1+10;A1+0)

bei 30
=WENN(REST(A1;100)<30;A1+10;A1+0)

bei 50
=WENN(REST(A1;100)<50;A1+10;A1+0)

bei 70
=WENN(REST(A1;100)<70;A1+10;A1+0)

bei 90
=WENN(REST(A1;100)<90;A1+10;A1+0)
Antwortento top
#7
(25.05.2016, 22:39)Kuwer schrieb: Hallo,

vielleicht passt das auch?

=A1+((REST(RECHTS(A1;2);20)<10)*10)

Gruß Uwe

Hi Uwe, das sieht sehr gut aus. Ich habe eine Abweichung bei 5223451201. M.E. sollte das so bleiben erst ab 9 mit 10 addiert. Aber das wird der TE vielleicht noch aubröseln...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
Antwortento top
#8
(25.05.2016, 22:44)Ostseeman schrieb: Hi Uwe,


also folgende Lösung habe ich dank Jockel gefunden

Bei 10

=WENN(REST(A1;100)<10;A1+10;1+0)

bei 30
=WENN(REST(A1;100)<30;A1+10;1+0)

bei 50
=WENN(REST(A1;100)<50;A1+10;1+0)

bei 70
=WENN(REST(A1;100)<70;A1+10;1+0)

bei 90
=WENN(REST(A1;100)<90;A1+10;1+0)

Hallo, das habe ich nicht vorgeschlagen und wäre auch deiner Beschreibung nach falsch...!!!

P.S.: =WENN(REST(A1;100)<90;A1+10;1+0) der rote Teil ist mumpitz
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
Antwortento top
#9
Och man ich hab mich paar mal verschrieben und wieder den Beitrag  korrigiert, aber wie gesagt, dank dir habe ich nun ein weg gefunden um an mein Zielergebnis zu kommen.

Aber da hast du recht, die 1 sollte A1 sein, hab ich soeben nochmal bearbeitet
Antwortento top
#10
(25.05.2016, 22:49)Ostseeman schrieb: Och man ich hab mich paar mal verschrieben und wieder den Beitrag  korrigiert, aber wie gesagt, dank dir habe ich nun ein weg gefunden um an mein Zielergebnis zu kommen.

Aber da hast du recht, die 1 sollte A1 sein, hab ich soeben nochmal bearbeitet

Hallo, da braucht's aber die plus null (auch) nicht... und so wie im Beitrag um 23:44 Uhr wird und kann das nicht funktionieren...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste