Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Wenn Arbeitstag..dann
#1
Hallo,
leider habe ich (Excel-Anfänger) schon etliche fehlerhafte Versuche hinter mir, und würde mich über einen Lösungvorschlag sehr freuen.

Habe eine Datei zur Zeiterfassung angelegt.
Von Mo bis Do ist eine Soll-Arbeitszeit von 8,5 Stunden am Fr von 6 Stunden vereinbart.

In Zelle A6  =WOCHENTAG(B6)wird der Tag aufgrund der Zelle B6 mit den Wochentagsabkürzungen Mo, Di, Mi, Do, Fr ausgegeben.
Ich möchte gerne, dass Excel in der Zelle I6 automatisch die Soll-Arbeitszeit aufgrund von Zelle A6 automatisch einträgt.Also Mo bis Do 8,5 Stunden am Fr 6 Stunden.

I6=(WENN(A6=(Mo,Di,Mi,Do);8,5;6))  ????




Vielen Dank
to top
#2
Hallo, zuerst würde ich WOCHENTAG(datum;2) nehmen, und dann so tun..:

Arbeitsblatt mit dem Namen 'Tabelle3'
ABCDE
606.03.20155666
707.03.20156006
808.03.20157000
909.03.201518,58,58,5
1010.03.201528,58,58,5
1111.03.201538,58,58,5
1212.03.201548,58,58,5
1313.03.20155666
1414.03.20156006
1515.03.20157000
1616.03.201518,58,58,5
1717.03.201528,58,58,5

ZelleFormel
B6=WOCHENTAG(A6;2)
C6=WAHL(B6;8,5;8,5;8,5;8,5;6;;)
D6=WENN(B6<5;8,5;WENN(B6=5;6;0))
E6=VERWEIS(B6;{1;5;7};{8,5;6;0})
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#3
Hallo,

diese Thema ist schon sooft durchgekaut worden, wenn man googelt findet man tausende von Lösungen!
1. Wochentag ergibt keine Texte, die man auswerten kann, sondern dahinter stecken Zahlen
2. muß man den Wochentag nicht berechnen, den kann man ja direkt aus dem Datum ermitteln:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDE
31Mo 02.03.15888
42Di 03.03.15888
53Mi 04.03.15888
64Do 05.03.15888
75Fr 06.03.156,56,56,5
86Sa 07.03.15888

ZelleFormatWert
B3TTT TT.MM.JJ;@02.03.2015

ZelleFormel
A3=WOCHENTAG(B3;2)
C3=WENN(WOCHENTAG(B3;2)<>5;8;6,5)
D3=WENN(REST(B3;7)<6;8;6,5)
E3=8-(REST(B3;7)=6)*1,5
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#4
Hallo Edgar, ich lehne mich mal ganz weit aus dem Fenster, aber ich denke (das ist bei mir immer Glücksache), dass der TE am Wochenende keine 8 als Ergebnis haben will (auch keine 8,5). Steht zwar nicht explizit in der Anfrage, aber ich wäre schon sehr verwundert, wenn das so wär... ... weil es auch wenig Sinn machen würde, oder?

Aber vielleicht hat der TE auch nur Zellen belegt mit Mo-Fr, aber auch das würde mich wundern....
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#5
Hi Jörg,

Zitat TE:



Zitat:In Zelle A6  =WOCHENTAG(B6)wird der Tag aufgrund der Zelle B6 mit den Wochentagsabkürzungen Mo, Di, Mi, Do, Fr ausgegeben.
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#6
Hi!

Mein Vorschlag (mal ein wenig abseits der üblichen Lösungsvorschläge):

ABCD
101.03.2015So6
202.03.2015Mo08
303.03.2015Di18
404.03.2015Mi28
505.03.2015Do38
606.03.2015Fr46,5
707.03.2015Sa5
808.03.2015So6
909.03.2015Mo08

ZelleFormatWert
B1TTT01.03.2015
D1Standard;;;0

ZelleFormel
B1=A1
C1=WOCHENTAG(A1;3)
D1=(C1<4)*8+(C1=4)*6,5

Gruß Ralf
to top
#7
(07.03.2015, 06:53)BoskoBiati schrieb: Hi Jörg,

Zitat TE:
In Zelle A6  =WOCHENTAG(B6)wird der Tag aufgrund der Zelle B6 mit den Wochentagsabkürzungen Mo, Di, Mi, Do, Fr ausgegeben.

Hallo Edgar, wer lesen kann... ES war schon spät gestern oder früh heute - egal. Also mir gefallen diese Vorschläge am meisten..:


Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEF
102. MrzMo8,58,58,58,5
203. MrzDi8,58,58,58,5
304. MrzMi8,58,58,58,5
405. MrzDo8,58,58,58,5
506. MrzFr6666

ZelleFormel
C1=VERWEIS(B1;{1;6};{8,5;6})
D1=8,5-(REST(A1;7)=6)*2,5
E1=(B1<6)*8,5+(B1=6)*6
F1=WAHL((B1=6)+1;8,5;6)
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#8
Hi,

(07.03.2015, 13:48)Jockel schrieb: Also mir gefallen diese Vorschläge am meisten..:

Ich habe noch etwas damit gespielt.

da stimmt noch was nicht:

Tabelle1
ABCDEF
1Mo02.03.20158,58,58,58,5
2Di03.03.20158,58,58,58,5
3Mi04.03.20158,58,58,58,5
4Do05.03.20158,58,58,58,5
5Fr06.03.20156,06,06,06,0
6Sa07.03.20156,0008,5
7So08.03.20156,0008,5
8Mo09.03.20158,58,58,58,5

verwendete Formeln
Zelle Formel Bereich N/A
A1:A8=B1
C1:C8=VERWEIS(WOCHENTAG(B1;2);{1;5};{8,5;6})
D1: D8=8,5-(REST(B1;7)=6)*2,5-(REST(B1;7)<=1)*8,5
E1:E8=(WOCHENTAG(B1;2)<5)*8,5+(WOCHENTAG(B1;2)=5)*6
F1:F8=WAHL((WOCHENTAG(B1;2)=5)+1;8,5;6)
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.24 einschl. 64 Bit

Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#9
Hallo Ralf, offenbar wollte der TE nur Mo-Fr...
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#10
Hi Jörg,

Zitat:Hallo Ralf, offenbar wollte der TE nur Mo-Fr...

Dann hätte ich auch noch einen (die bisherigen Verweise berücksichtigten nicht das WE):


Tabelle4

BC
1Mo, 02 Mrz 158,5
2Di, 03 Mrz 158,5
3Mi, 04 Mrz 158,5
4Do, 05 Mrz 158,5
5Fr, 06 Mrz 156
6Sa, 07 Mrz 15
7So, 08 Mrz 15
8Mo, 09 Mrz 158,5
9Di, 10 Mrz 158,5
10Mi, 11 Mrz 158,5
11Do, 12 Mrz 158,5
12Fr, 13 Mrz 156
Formeln der Tabelle
ZelleFormel
C1=SVERWEIS(WOCHENTAG(B1;2);{1.8,5;2.8,5;3.8,5;4.8,5;5.6;6."";7.""};2)
C2=SVERWEIS(WOCHENTAG(B2;2);{1.8,5;2.8,5;3.8,5;4.8,5;5.6;6."";7.""};2)
C3=SVERWEIS(WOCHENTAG(B3;2);{1.8,5;2.8,5;3.8,5;4.8,5;5.6;6."";7.""};2)
C4=SVERWEIS(WOCHENTAG(B4;2);{1.8,5;2.8,5;3.8,5;4.8,5;5.6;6."";7.""};2)
C5=SVERWEIS(WOCHENTAG(B5;2);{1.8,5;2.8,5;3.8,5;4.8,5;5.6;6."";7.""};2)
C6=SVERWEIS(WOCHENTAG(B6;2);{1.8,5;2.8,5;3.8,5;4.8,5;5.6;6."";7.""};2)
C7=SVERWEIS(WOCHENTAG(B7;2);{1.8,5;2.8,5;3.8,5;4.8,5;5.6;6."";7.""};2)
C8=SVERWEIS(WOCHENTAG(B8;2);{1.8,5;2.8,5;3.8,5;4.8,5;5.6;6."";7.""};2)
C9=SVERWEIS(WOCHENTAG(B9;2);{1.8,5;2.8,5;3.8,5;4.8,5;5.6;6."";7.""};2)
C10=SVERWEIS(WOCHENTAG(B10;2);{1.8,5;2.8,5;3.8,5;4.8,5;5.6;6."";7.""};2)
C11=SVERWEIS(WOCHENTAG(B11;2);{1.8,5;2.8,5;3.8,5;4.8,5;5.6;6."";7.""};2)
C12=SVERWEIS(WOCHENTAG(B12;2);{1.8,5;2.8,5;3.8,5;4.8,5;5.6;6."";7.""};2)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste