Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

WENN UND / ODER Kombination
#1
Hallo,

trotz vieler Recherche und Probieren scheitere ich an der WENN UND / ODER Kombination. Folgende Aufgabenstellung:

Ein Kunde bekommt einen bestimmten Preis, wenn folgende Kriterien erfüllt sind:

Kundennummer ist >=15000 und <=20000  ODER Kundennummer ist = 30093 UND Produkt ist = B

Im zweiten Fall müssen also beide Kriterien erfüllt sein (Kd.Nr. und Produktart.)

Code:
    A    B
1    Kunde    Produkt
2    15000    A
3    20000    B
4    33333    A
5    30093    B
Vielen Dank im Voraus für Eure Hilfe.
Antwortento top
#2
Hola,


Code:
=WENN(ODER(UND(A2>=15000;A2<=20000);UND(A2=30093;B2="b"));bestimmter Preis;"")

Gruß,
steve1da
Antwortento top
#3
Hallo

Ungetestet.

Code:
=WENN(ODER(MEDIAN(Kundennummer;15000;20000)=Kundennummer;UND(Kundennummer=30093;Produkt="B"));bestimmter_Preis;anderer_Preis)
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#4
Prima, das klappt wunderbar!
Aber nun wird es leider doch noch etwas komplizierter, denn bei der zweiten Bedingung (rot)
können mehrere Kunden und Produkte auftauchen.

Kundennummer ist >=15000 und <=20000  ODER Kundennummer ist = 30093 UND Produkt ist = B

Kundennummern können z.B. 30093 oder 30094 oder 30095 sein, und Produkt kann B, C, D, oder E sein.
Sobald also eine Kombi eintrifft (also entweder Kunde 30093 und Produkt B, oder Kunde 30093 und Produkt C, oder Kunde 30094 und Produkt C, usw.) gilt ein bestimmter Preis.

Ich hoffe, Ihr könnt mir folgen. 69
Antwortento top
#5
(30.06.2016, 13:45)irgendjemand schrieb: ...
Aber nun wird es leider doch noch etwas komplizierter...
...
Ich hoffe, Ihr könnt mir folgen. 69

Hallo, warum habe ich das vermutet..? Lad' doch bitte (d)eine (Beispiel)datei hoch mit ein paar Musterbeispielen...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
Antwortento top
#6
(30.06.2016, 13:50)Jockel schrieb: Hallo, warum habe ich das vermutet..?
Weil du deine Pappenheimer kennst. Dodgy
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#7
Hallo,

ungetestet:


Code:
=WENN(ODER(UND(A2>=15000;A2<=20000);UND(A2=30093;oder(B2={"b"."c"."e"})));bestimmter Preis;"")
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#8
(30.06.2016, 13:50)Jockel schrieb:
(30.06.2016, 13:45)irgendjemand schrieb: ...
Aber nun wird es leider doch noch etwas komplizierter...
...
Ich hoffe, Ihr könnt mir folgen. 69

Hallo, warum habe ich das vermutet..? Lad' doch bitte (d)eine (Beispiel)datei hoch mit ein paar Musterbeispielen...

Es kommt halt immer was dazu.. Blush
Anbei mein Beispiel.


Angehängte Dateien
.xlsx   Mappe4.xlsx (Größe: 42,4 KB / Downloads: 2)
Antwortento top
#9
@ BoskoBiati:   Vielen Dank!  So klappt es wunderbar. Ich habe die entsprechenden Kunden nun einer einzigen Kundengruppe gruppiert, so passt es dann prima, und ich reihe die Produkte über diese Klammern { } aneinander.

Herzlichen Dank an alle für den tollen Support!
98
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste