Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

WENN-DANN und MITTELWERT Anweisung mit Bezugszelle
#1
Hallo zusammen,
ich habe das Problem, dass ich in der nachfolgenden Tabelle (ist nur ein Teil einer sehr umfangreichen Tabelle) die Werte in B3 und C3 (blau hinterlegte Zellen) als Bezüge für die darunter angezeigten Ergebnisse verwenden möchte.
Also wenn ich in B3 den aktuellen Wert von 2 auf z.B. 4 ändere, dann sollte das aktuelle Feld in Spalte A mit dem vor 4 Tagen verglichen und der entsprechende Wert ausgegeben werden.
Und wenn ich in C3 den Wert von 3 auf 5 ändere, dann sollte der Mittelwert der letzten 5 statt aktuell 3 Tage ausgegeben werden.
Habe schon einiges probiert, da ich mich aber nicht sonderlich mit Excel auskenne, habe ich keine Lösung gefunden.
Die kleine Testdatei habe ich angehängt.
Kann mir bei der Problemlösung jemand helfen?

Tabelle1
ABC
1GrößerMittelwert
2als vorder letzten
323
4DatenTagenTage
5456
6458
7460okay458
8455 457,666666666667
9453 456
10457okay455
11463okay457,666666666667
12460okay460
13461 461,333333333333
14458 459,666666666667
15468okay462,333333333333
16470okay465,333333333333

verwendete Formeln
Zelle Formel Bereich N/A
B7:B16=WENN(A7>A5;"okay";" ")
C7:C16=MITTELWERT(A5:A7)
http://excel-inn.de/dateien/vba_beispiel..._addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 19.15 einschl. 64 Bit


Angehängte Dateien
.xls   TEST.xls (Größe: 16 KB / Downloads: 5)
to top
#2
Hallo,

und wo bitte ist da irgendwo ein Datum??????
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#3
Hallo

@Edgar
Zitat:und wo bitte ist da irgendwo ein Datum??????
Ich würde es so interpretieren dass jede Zeile ein Tag ist.

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABC
1 GrößerMittelwert
2 als vorder letzten
3 55
4DatenTagenTage
5456  
6458  
7460  
8455  
9453 456,40
10457okay456,60
11463okay457,60
12460 457,60
13461okay458,80
14458okay459,80
15468okay462,00
16470okay463,40

ZelleFormel
B5=WENN(ZEILE()-B$3>4;WENN(A5>INDEX(A:A;ZEILE()-B$3);"okay";"");"")
C5=WENN(ZEILE()-C$3+1>4;MITTELWERT(INDEX(A:A;ZEILE()-C$3+1):A5);"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#4
(13.03.2016, 22:00)BoskoBiati schrieb: Hallo,

und wo bitte ist da irgendwo ein Datum??????

Sorry, wenn ich durch die weggelassenen Datumsangaben Verwirrung gestiftet habe.
Waren meiner Ansicht nach aber für die Problemlösung nicht relevant.

shift-del hat es ja auch gleich erkannt, dass jede Zeile einen Tag darstellt.
to top
#5
Hallo,

nach Deinen Formeln zu urteilen, wäre aber der neueste Tag oben!
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#6
Smile 
(14.03.2016, 05:07)shift-del schrieb: Hallo

@Edgar
Zitat:und wo bitte ist da irgendwo ein Datum??????
Ich würde es so interpretieren dass jede Zeile ein Tag ist.

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABC
1 GrößerMittelwert
2 als vorder letzten
3 55
4DatenTagenTage
5456  
6458  
7460  
8455  
9453 456,40
10457okay456,60
11463okay457,60
12460 457,60
13461okay458,80
14458okay459,80
15468okay462,00
16470okay463,40

ZelleFormel
B5=WENN(ZEILE()-B$3>4;WENN(A5>INDEX(A:A;ZEILE()-B$3);"okay";"");"")
C5=WENN(ZEILE()-C$3+1>4;MITTELWERT(INDEX(A:A;ZEILE()-C$3+1):A5);"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Hallo shift-del,

herzlichen Dank, so funktioniert es!!!

Gruß, sonnyboy333
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste