Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Verknüpfung in aus anderer Arbeitsmappe
#1
Guten Morgen,

ich versuche eine Finanzplanung zu erstellen. Zu diesem Zweck sollen mehrere Arbeitsmappen für die unterschiedlichen Abteilungen erstellt werden. Diese sollen dann später in einem einzelen Dashboard zusammengefasst werden.

In den Quellarbeitsmappen möchte ich gerne mit Tabellen arbeiten, welche als 'Tabellenbereiche' formatiert sind, da so vorab einige Berechnungen automatisch durchgeführte werden (aus einem Datum wird autamatisch die Kalenderwoche ermittelt, welche später als Auswertungsstufe dienen soll.)

In der Quelldatei gibt der Einkaufsleiter also die getätigten Bestellungen ein und verzeichnet das Zahlungsziel, wann der dazugehörige Wechsel eingelöst wird - hieraus leitet sich die KW ab, unter der dann diese Ausgabe absummiert werden soll. Die Tabelle, in der diese Eingabe erfolgt, hat den Namen 'Wechsel'.

Im Dashboard versuche ich nun, mit folgender Formel, auf diese Inhalte zuzugreifen:

=SUMMEWENNS('N:\BUCHHALTUNGSABTEILUNG\POHL\Finanzplan\HS Laufende Verbindlichkeiten.xlsx'!Wechsel[[#Alle];[RG-Betrag]];'N:\BUCHHALTUNGSABTEILUNG\POHL\Finanzplan\HS Laufende Verbindlichkeiten.xlsx'!Wechsel[[#Alle];[Status]];"Offen";'N:\BUCHHALTUNGSABTEILUNG\POHL\Finanzplan\HS Laufende Verbindlichkeiten.xlsx'!Wechsel[[#Alle];[Währung]];$B$6;'N:\BUCHHALTUNGSABTEILUNG\POHL\Finanzplan\HS Laufende Verbindlichkeiten.xlsx'!Wechsel[[#Alle];[KW]];C4)

Es sollen also alle Beträge der Spalte RG-Betrag zusammenaddiert werden, in denen der Status= Offen und die KW= dem Inhalt C4 entspricht.

Sind beide (Quelle und Dashboard) offen, funktioniert das auch problemlos. Sind aber beide geschlossen, und man öffnet nur das Dasboard und läßt die Tabelle entsprechend der Aufforderung aktualisieren, erhalte ich eine Fehlermeldung #BEZUG!.

Warum?

Viele Grüße

Oliver Pohl
Antwortento top
#2
Hallo Oliver,

da schon Summewenn nicht bei geschlossenen Mappen funktioniert hat, wird das wohl auch für Summewenns gelten.
Abhilfe war eine Matrix zu erzeugen .. .siehe http://support.microsoft.com/kb/507757/de
lg Chris
Feedback nicht vergessen.
3a2920576572206973742064656e20646120736f206e65756769657269672e
 [Bild: v.gif]

Antwortento top
#3
Das war mir nicht bewußt.... Ich werde mir den Artikel aus der KB mal anschauen.
Bei Rückfragen komme ich nochmal durch....

Danke bis hierhin

Oliver
Antwortento top
#4
Hallo

{=SUMME(WENN('N:\BUCHHALTUNGSABTEILUNG\POHL\Finanzplan\HS Laufende Verbindlichkeiten.xlsx'!Tabelle1[[#Alle];[Status]]="Offen";WENN('N:\BUCHHALTUNGSABTEILUNG\POHL\Finanzplan\HS Laufende Verbindlichkeiten.xlsx'!Tabelle1[[#Alle];[Währung]]="USD";WENN('N:\BUCHHALTUNGSABTEILUNG\POHL\Finanzplan\HS Laufende Verbindlichkeiten.xlsx'!Tabelle1[[#Alle];[KW]]=C$4;'N:\BUCHHALTUNGSABTEILUNG\POHL\Finanzplan\HS Laufende Verbindlichkeiten.xlsx'!Tabelle1[[#Alle];[RG-Betrag]];0))))}

Das als Matrixformel hat nicht geklapt Sad
Antwortento top
#5
Hallo,

ich habe es bei mir auch getestet, und es klappt hier auch nicht, wenn die Bezüge auf ein "Tabellenbereich" verweisen.

Wenn ich aber Zellbezüge nehme, dann klappt es.

Es sieht so aus, das ein als Tabelle formatierter Bereich nicht erkannt wird, wenn die Datei geschlossen ist.
Gruß Atilla
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste