Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert sind; Die von diesem Forum gesetzten Cookies düfen nur auf dieser Website verwendet werden und stellen kein Sicherheitsrisiko dar. Cookies auf diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Die Updates sind abgeschlossen. Bitte meldet eventuelle Bugs und Auffälligkeiten im entsprechenden Forum.
Sollte das Loginfenster nicht sichtbar sein, ist es unten links. Entweder Ihr loggt Euch dort ein oder löscht den Browsercache und versucht es noch einmal.


VERGLEICH mit mehreren möglichen Werten
#1
Hallo,


ich würde gerne den ersten Wert in einer Tabelle finden. Wobei dieser in einer Spalte ist mit mehreren durch Komma getrennten einträgen:

?mage

Ich will mir ausgeben lassen in welcher Zeile mein erster bert steht. Schwierigkeit dabei ist, dass nicht berta ausgegeben werden soll und bert sowohl am Anfang, am Ende, in der Mitte oder alleine stehen kann.
Die Einträge mit der Zählenwenn Funktion ist relativ einfach indem man die Möglichkeiten addiert und mit Wildcards arbeitet:
=ZÄHLENWENN(B:B;"bert") + ZÄHLENWENN(B:B;"bert,*") + ZÄHLENWENN(B:B;"*,bert,*") + ZÄHLENWENN(B:B;"*,bert")

Aber wie kann ich in der Funktion VERGLEICH die oben genannten Suchkriterien übernehmen?
Irgendetwas wie =VERGLEICH("bert" oder "bert,*" oder "*,bert*," oder "*,bert,*";B:B)

Vielen Dank schonmal
Antwortento top
#2
Hallo

Code:
{=VERGLEICH(WAHR;ISTZAHL(SUCHEN("bert,";$B$1:$B$7&","));0)}
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste