Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Um eine Zeile verschobener Vergleich
#1
Hallo ich benötige mal wieder eure Hochgeschätzte Hilfe.

Ich habe einen Dienstplan erstellt wie in der Tabellenblatt Januar in dem Bereich in dem ~~ steht ist eine Dropdownliste aus der unter anderem U für Urlaub auswählen kann. Im Tabellenblatt UrlaubJan
soll dann im Abhängigkeit vom Namen Abgefragt werden ob ein U am entsprechenden Tag ausgewählt ist. Leider ergibt sich die Schwierigkeit, dass die Zeile mit dem Dropdown eine Zeile tiefer ist als der Name der Person.

Ich hoffe ihr habt eine Idee,

Herzlichen Dank



Januar
ABCDEFGHIJKLMNOPQRSTUVWXYZAAABACADAEAFAG
1Januar 161.1.162.1.163.1.164.1.165.1.166.1.167.1.168.1.169.1.1610.1.1611.1.1612.1.1613.1.1614.1.1615.1.1616.1.1617.1.1618.1.1619.1.1620.1.1621.1.1622.1.1623.1.1624.1.1625.1.1626.1.1627.1.1628.1.1629.1.1630.1.1631.1.16
2FrSaSoMoDiMiDoFrSaSoMoDiMiDoFrSaSoMoDiMiDoFrSaSoMoDiMiDoFrSaSo
3Nowack
4Dienst~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

 verbundene Zellen
A1:B2

verwendete Formeln
Zelle Formel Bereich N/A
A1=$C$1
D1:AG1=C1+1
C2:AG2=C1


UrlaubJan
ABCDEFGHIJKLMNOPQRSTUVWXYZAAABACADAEAFAG
1Januar 151.1.152.1.153.1.154.1.155.1.156.1.157.1.158.1.159.1.1510.1.1511.1.1512.1.1513.1.1514.1.1515.1.1516.1.1517.1.1518.1.1519.1.1520.1.1521.1.1522.1.1523.1.1524.1.1525.1.1526.1.1527.1.1528.1.1529.1.1530.1.1531.1.15
2DoFrSaSoMoDiMiDoFrSaSoMoDiMiDoFrSaSoMoDiMiDoFrSaSoMoDiMiDoFrSa
3Nowack#NV
4Hellwig

 verbundene Zellen
A1:B2

verwendete Formeln
Zelle Formel Bereich N/A
A1=$C$1
D1:AG1=C1+1
C2:AG2=C1
C3=WENN(INDEX(Januar!C3:AG62;VERGLEICH(UrlaubJan!B3;Januar!B3:B57;0);VERGLEICH("U";Januar!C3:AG3;0))="U";"U";"~~")
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 19.05 einschl. 64 Bit

to top
#2
Hallo, meinst du so..?

C3=INDEX(Januar!$C$1:$AG$4;VERGLEICH($B3;Januar!$B$1:$B$4;0)+1;SPALTE(A1))

Evetuell mit WENNFEHLER() umzu...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#3
Hallo,

mal ungetestet:


Code:
=WENN(INDEX(Januar!$C$3:$AG$62;VERGLEICH(UrlaubJan!B3;Januar!$B$3:$B$57;0)+1;VERGLEICH(C$1;Januar!$C$1:$AG$1;0))="U";"U";"~~")
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#4
(24.02.2016, 18:03)BoskoBiati schrieb: Hallo,

mal ungetestet:


Code:
=WENN(INDEX(Januar!$C$3:$AG$62;VERGLEICH(UrlaubJan!B3;Januar!$B$3:$B$57;0)+1;VERGLEICH(C$1;Januar!$C$1:$AG$1;0))="U";"U";"~~")

Hi Edgar, ich glaube der zweite VERGLEICH() ist mumpitz... ... schon gleich nach Betrachten der Datei...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#5
Hi,

passt das so?

Tabelle1

ABCDEFGHIJK
1Janur
2
3ABCDEFGHIJK
4Jan 1601.01.201602.01.201603.01.201604.01.201605.01.201606.01.201607.01.201608.01.201609.01.2016
5FrSaSoMoDiMiDoFrSaSoMo
6Nowack
7DienstUUUUUUU~~~~
8
9Urlaub Januar
10
11ABCDEFGHIJK
12Jan 1501.01.201502.01.201503.01.201504.01.201505.01.201506.01.201507.01.201508.01.201509.01.2015
13DoFrSaSoMoDiMiDoFrSaSo
14NowackUUUUUUU~~~~
15Hellwig
Formeln der Tabelle
ZelleFormel
C14=INDEX(C7:C7;VERGLEICH($B$14;$B$6:$B$7;0))
D14=INDEX(D7:D7;VERGLEICH($B$14;$B$6:$B$7;0))
E14=INDEX(E7:E7;VERGLEICH($B$14;$B$6:$B$7;0))

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#6
Hi Jörg,

zumindest ist er nicht zwingend notwendig.
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#7
(24.02.2016, 18:06)BoskoBiati schrieb: Hi Jörg,

zumindest ist er nicht zwingend notwendig.

Hallo, Edgar, was steht denn jeweils in C1..? Das geht nicht..!!!!
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#8
Hallo Jörg,

genau deswegen bringt auch Deine Formel falsche Ergebnisse, da sie das Datum nicht prüft. Meine bringt wenigstens eine Fehlermeldung!
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#9
(24.02.2016, 18:49)BoskoBiati schrieb: Hallo Jörg,

genau deswegen bringt auch Deine Formel falsche Ergebnisse, ...

Du alter Fux...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste