Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Texte zusammenfügen
#1
Hallo
Beim herauslesen von Datensätzen aus einer Standardsoftware im Excel kommt es vor, dass der Textinhalt im Excel in zwei Zeilen dargestellt wird - dabei müsste es in einer Zelle zusammengeführt werden.

Beispiel wie es aus der Standardsoftware ausgelesen wird
A10 Diese Nachricht ist für den Vorabend
A11 bestimmt und kostet
C10 1'100.50
A12 Nachtessen pro Person
C12 65.00

Ergebnis
wenn C11 leer - dann A10 und A11 zusammenfügen
B10 Diese Nachricht ist für den Vorabend bestimmt und kostet
C10 1'100.50

B12 Nachtessen pro Person (Übernahme von A12)
C12 65.00

Gruss Oski
to top
#2
Hallo

Zitat:wenn C11 leer - dann A10 und A11 zusammenfügen
B10 Diese Nachricht ist für den Vorabend bestimmt und kostet
Wo ist das Problem?
Code:
=WENN(C11="";A10&" "&A11;"")
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#3
Hi Oski,

du solltest dir angewöhnen, eine Mustertabelle vorzustellen. Schon in diesem Thread habe ich deine Angaben aus dem Text übernommen und damit eine Tabelle nachgebaut. Das macht kein Helfer gerne - oftmals trifft der Nachbau auch nicht das Aussehen der Originaltabelle.

Schau dir doch bitte hierzu einmal diese beiden unter Wichtige Themen eingestellten Beiträge (Rot = Links) an:

Arbeitsmappen zur Verfügung stellen
Tabellenausschnitte einstellen

Übrigens, ein kurzes Feedback, ob und/oder wie ein Beitrag geholfen hat (oder auch nicht) erhöht im allgemeinen die Bereitschaft zur weiteren Hilfe sehr. Wink Denn ohne Rückmeldung weiß kein Helfer, ob sein Vorschlag weitergeholfen hat oder nicht.
?mage

Misserfolg ist eine Chance, es beim
nächsten Mal besser zu machen.

(Henry Ford)
http://www.sprueche-zum-nachdenken.eu
to top
#4
ja habe mit Tab2Html (v2.4.1) versucht aber bei Excel 2013 funktioniert es nicht. Das Add-In wird nicht geladen

Oski
to top
#5
Hallo oski,

da kann es mehrere Gründe geben.

Funktionieren denn andere AddIns?
Wo liegt AddIn? Ich habe es z.B. nicht in dem Verzeichnis zum automatischen Laden der AddIns bei excelstart, sondern in einem anderen, wo ich es nur bei Bedarf aufrufe.

Es gibt verschiedene Sicherheitseinstellungen für AddIns und Makros in den Optionen.

Siehe dazu in den Optionen im Sicherheitscenter / TrustCenter
Vertrauenswürdige Speicherorte
AddIns
Makroeinstellungen auch Zugriff auf das VBA-Projekt erlauben.


Ich hatte bei der Anzeige der Vorschau auch mal ein Problem. Aber dazu muss es ja erst mal laufen ;-)
In der Registry hab ich einen Wert geändert:
Code:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\15.0\Common\COM Compatibility\{8856F961-340A-11D0-A96B-00C04FD705A2}]
Änderung des Wertes von 400 auf 0
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
[-] Folgende(r) 1 Benutzer sagt Danke an schauan für diesen Beitrag:
  • oski
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste