Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Tabelle durchsuchen
#1
Hallo zusammen

Ich habe eine Excel-Tabelle vorliegen, welche in Spalte A Kundennummern enthält und in Spalte B deren Vertragsnummern.
Die Kundennummern kommen jeweils mehrere Male vor, jeweils mit anderer Vertragsnummer.

Ich möchte nun mittels Formel die Tabelle durchsuchen und in Spalte C pro Zeile ausgeben, ob der Kunde der jeweiligen Zeile irgendwo in der Tabelle bestimmte Vertragsnummern zugewiesen hat.
Weiss jemand Rat? Ich kriege das nicht hin, habe mit der Funktion "Vergleich" versucht, passt aber irgendwie nicht.

Hoffe meine Ausführungen sind einigermassen verständlich,
Danke für eure Bemühungen,
MiZ
to top
#2
Hola,

was möchtest du denn genau als Ergebnis?

Gruß,
steve1da
to top
#3
Hi,

mach eine intelligente Liste (STRG-L) und filtere nach Kundennummet.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#4
ALs Ergebnis würde ich in der Spalte C gerne pro Zeile sehen (zb. durch die Angabe "WAHR" oder "FALSCH"), ob die entsprechende Kundennummer irgendwo in der Tabelle eine Vertragsnummer der Zellen E2:E5 enthält.

Habe versucht dies untenstehend zu illustrieren, der Kunde 1000737239 ist der Einzige, welcher einen der gesuchten Verträge (aus E2:E5) enthält. Dies zwar nur in der Zeile 14, gleichwohl soll aber auch in C5 (weil diesselbe Kundennummer) dies ersichtlich sein.

?mage


Danke und Gruss,
MiZ
to top
#5
Hallo,

Das ginge mit Zählenwenn() oder Zählenwenns()

Hier eine Beispielformel für eine Nummer:

In Zelle C2: =ZÄHLENWENN($B:$B;$E$1) > 0


Wenn mehrere VNR gleichzeitig geprüft werden sollen, dann kannst Du den obigen Term (ohne >0) in einer Oder() Prüfung einbauen, oder Du schaust Dir Zählenwenns(9 in der OH an.
Gruß Atilla
to top
#6
Hola,

@atilla: müsste Zählenwenn() nicht genau anders herum prüfen?


Code:
=ZÄHLENWENN($E$2:$E$5;B2)>0

Edit: diese Formel als Hilfsformel z.B. in D2 und nach unten kopieren. In C2 dann:

Code:
=ZÄHLENWENNS($A$2:$A$15;A2;$D$2:$D$15;WAHR)>0

Gruß,
steve1da
to top
#7
Hallo Steve,

ja, Du hast recht, macht Sinn.
Gruß Atilla
to top
#8
So funktioniert's, besten Dank.

Eine Folgefrage noch, liesse sich sowas auch in einer sql-Abfrage umsetzen?

Die Daten für meine Tabelle mit den Kunden- und Vertragsnummern habe ich mittels Sql-Abfrage erhoben, die Tabelle umfasst rund 100'000 Zeilen.
Die Werte "WAHR" benötige ich eigentlich gar nicht, idealerweise könnte ich sie bereits in meiner Abfrage aussortieren bzw. gar nicht erst abfragen..?

Danke und schönen Abend,
MiZ
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste