Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

Sumprodukt alphabetisch oder numerisch anordnen ?
#1
Hallo @all,
eine allgemeine Verständnisfrage hätte ich da
Wie mit Summenproduktformel umgehen?
Ergebnis = 21 ist korrekt bei der Formel
PHP-Code:
{=WENN(C3=$B18;SUMMENPRODUKT(WENN(ISTZAHL(E3:G3);E3:G3;VERWEIS(E3:G3;{"aa";"k";"x";"s"};{4;8;9;3}))*1))} 
aber bei der Konstruktion, kommt die Fehlermeldung
#NV
PHP-Code:
{=WENN(C3=$B18;SUMMENPRODUKT(WENN(ISTZAHL(E3:G3);E3:G3;VERWEIS(E3:G3;{"x";"k";"aa";"s"};{9;8;4;3}))*1))} 
Welcher Fehler liegt hier vor?
Feedback ist erwünscht.
Danke vorab
mfg
?mage
to top
#2
Hallo

Der Suchvektor in VERWEIS() muss immer aufsteigend sortiert sein.
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#3
(28.08.2014, 15:42)shift-del schrieb: ..aufsteigend...
Danke für die schnelle Antwort shift-del

mfg
?mage
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste