Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Summenwerte in feste Werte umwandeln
#1
Einen schönen guten Morgen an alle,
im ersten Augenblick erscheint mein Anliegen in der Betreff Zeile kein Problem.
Aber in meiner Tabelle, die ich hochgeladen habe, sieht es etwas anders aus.
Weitere Informationen sind in der Beispieltabelle "Übung" hinterlegt.
Günther


Angehängte Dateien
.xls   Übung.xls (Größe: 49 KB / Downloads: 4)
Antwortento top
#2
Hi Günther,

probier mal so (die Summenbildung in C3 ist überflüssig):

 ABCDE
3  1279 23
4     
5     
610.06.2014100 123 
7Ja  
811.06.201430 153 
9Ja  
1012.06.2014100   
11   
1213.06.201450 303 
13Ja  
1414.06.2014999 1302 
15Ja  
1615.06.2014    
17   
1816.06.2014    
19   

ZelleFormel
C3=SUMME(B6:B25)
D6=WENN(INDIREKT("C"&ZEILE()+1)="";"";WENN(INDIREKT("C"&ZEILE()+1)="Ja";SUMME(INDIREKT("B6:B"&ZEILE()))+$E$3))
D8=WENN(INDIREKT("C"&ZEILE()+1)="";"";WENN(INDIREKT("C"&ZEILE()+1)="Ja";SUMME(INDIREKT("B6:B"&ZEILE()))+$E$3))
D10=WENN(INDIREKT("C"&ZEILE()+1)="";"";WENN(INDIREKT("C"&ZEILE()+1)="Ja";SUMME(INDIREKT("B6:B"&ZEILE()))+$E$3))
D12=WENN(INDIREKT("C"&ZEILE()+1)="";"";WENN(INDIREKT("C"&ZEILE()+1)="Ja";SUMME(INDIREKT("B6:B"&ZEILE()))+$E$3))
D14=WENN(INDIREKT("C"&ZEILE()+1)="";"";WENN(INDIREKT("C"&ZEILE()+1)="Ja";SUMME(INDIREKT("B6:B"&ZEILE()))+$E$3))
D16=WENN(INDIREKT("C"&ZEILE()+1)="";"";WENN(INDIREKT("C"&ZEILE()+1)="Ja";SUMME(INDIREKT("B6:B"&ZEILE()))+$E$3))
D18=WENN(INDIREKT("C"&ZEILE()+1)="";"";WENN(INDIREKT("C"&ZEILE()+1)="Ja";SUMME(INDIREKT("B6:B"&ZEILE()))+$E$3))

ZelleGültigkeitstypOperatorWert1Wert2
C7Liste =$I$2:$I$4 
C9Liste =$I$2:$I$4 
C11Liste =$I$2:$I$4 
C13Liste =$I$2:$I$4 
C15Liste =$I$2:$I$4 
C17Liste =$I$2:$I$4 
C19Liste =$I$2:$I$4 

Wobei sich allerdings die Frage stellt, was mit den Summen in Spalte D /E passieren soll, wenn zwischendrin mal nicht "ja" gewählt ist: Sollen die Werte in Spalte B dann weiter unten mitsummiert werden oder nicht ?
Überlegen macht überlegen
Gruss aus dem schönen Hunsrück
_______ Klaus-Martin _______
Antwortento top
#3
Hallo Kl@us-M.
Danke für Deine Überlegungen, so habe ich mir es vorgestell. Die Summe in Zelle "C3" ist für mich der Gesamtüberblick.
Wenn ich in Spalte "Ja" auswähle, habe ich jetzt Werte die ich weiter nutzen kann. Um "Ja" zu wählen gibt es die unterschiedlichsten Gründe (Ermittlung von Stückzahlen während einer Periode; der Verbrauch an Finanzen usw.). Wichtig ist nur das an einen X-beliebigen Tag (der mit "Ja") bestimmt wird, ein fester Wert erscheint.
Danke für die Antwort, wie gesagt es FUNKTIONIERT!
Günther
Antwortento top
#4
Hallo Kl@us-M., die Formeln habe ich in meine Original-Tabelle übertragen. Auch dort funktioniert es Super.
Aber mir ist aufgefallen, dass die Zelle "C3" für mich wichtig ist, denn dort finden sich auch die Überträge aus Januar bis Mai wieder.
=Januar!...+Februar!... usw.
Das habe ich leider vergessen zu erwähnen. Entschuldigung
Gruß
Günther
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste