Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Summenprodukt und im Ergebnis #Wert
#1
es ist ein Kreuz, da will man was schaffen, aber schafft sich nur noch grauere Haare.

Guten Abend @all

In einer Tabelle stehen Daten horizontal (Personenbezogen) zur Verfügung aus Guthaben und offenen Beträgen.

Die Abfragetabelle hat nun alle Personen In Zeile stehen. Datum nach unten.
Wenn ich nun versuche die Positionen zu berechnen, geht es gut solang nur + oder - Werte in einer Zeile sind.

zuerst berechne ich: Soll - Ist = 40 - 30 = -10€ Minus
zuerst berechne ich: Soll - Ist = 50 - 55 = +5€ Guthaben

Mein Konstrukt schlägt fehl:
Summiere alle Werte die größer sind als Null ... ?
Wenn(Wert höher Null;+(Wert höher Null; ... wie weiter ???

Mir qualmssssssssssssssssss Huh

Wer steigt durch und ist gewillt hier einen Tipp abzugeben.
anbei, kleine konfuse zusammengestrickte Bespieldatei

.xlsx   SUMMENPRODUKT(.xlsx (Größe: 11,6 KB / Downloads: 17)

mfg
Antwortento top
#2
Hallo Frank

Ich habe in deinem Beispiel nirgends #WERT gesehen, sondern einen Zirkelbezug.
Deine Formel in G4
Code:
=WENN(G4<SUM.....
kann so nie funktionieren.

Gruss Sepp
Antwortento top
#3
Hi Frank,

wenn ich dich jetzt nicht komplett missverstanden habe, dann reicht es in G4
PHP-Code:
=WENN(C4<0;C4;""
einzutragen und in I4
PHP-Code:
=WENN(C4>0;C4;""

Das ist dann das Ergebnis:

Tabelle1

ABCDEFGHI
1Minus
anzeigen
Plus
anzeigen
2ArnoArni
3
402.06.2014-3125-31
503.06.201410-7010
Formeln der Tabelle
ZelleFormel
C4=SUMMENPRODUKT(($K$4:$K$7=$A4)*($M$4:$M$7=C$2)*$Q$4:$Q$7)-SUMMENPRODUKT(($K$4:$K$7=$A4)*($M$4:$M$7=C$2)*$O$4:$O$7)
E4=SUMMENPRODUKT(($K$4:$K$7=$A4)*($M$4:$M$7=E$2)*$Q$4:$Q$7)-SUMMENPRODUKT(($K$4:$K$7=$A4)*($M$4:$M$7=E$2)*$O$4:$O$7)
G4=WENN(C4<0;C4;"")
I4=WENN(C4>0;C4;"")
C5=SUMMENPRODUKT(($K$4:$K$7=$A5)*($M$4:$M$7=C$2)*$Q$4:$Q$7)-SUMMENPRODUKT(($K$4:$K$7=$A5)*($M$4:$M$7=C$2)*$O$4:$O$7)
E5=SUMMENPRODUKT(($K$4:$K$7=$A5)*($M$4:$M$7=E$2)*$Q$4:$Q$7)-SUMMENPRODUKT(($K$4:$K$7=$A5)*($M$4:$M$7=E$2)*$O$4:$O$7)
G5=WENN(C5<0;C5;"")
I5=WENN(C5>0;C5;"")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
Antwortento top
#4
Hallo,

ich sehe das so:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGHIJKLMNOPQ
1      Minus
anzeigen
 Plus
anzeigen
        
2  Arno Arni       soll ist
3           
402.06.2014 -31 25 -31 25 02.06.14 Arno 41 10
503.06.2014 10 -70 -70 0 02.06.14 Arni 25 50
6          03.06.14 Arno 100 110
7        03.06.14 Arni 80 10
8                 

ZelleFormel
C4=SUMMENPRODUKT(($K$4:$K$7=$A4)*($M$4:$M$7=C$2)*($Q$4:$Q$7-$O$4:$O$7))
E4=SUMMENPRODUKT(($K$4:$K$7=$A4)*($M$4:$M$7=E$2)*($Q$4:$Q$7-$O$4:$O$7))
G4=SUMMEWENN(C4:E4;"<0")
I4=SUMMEWENN(E4:G4;">0")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#5
Hi Edgar,

ich glaube, du hast natürlich Recht. Ich hatte übersehen, dass da ja noch eine zweite Spalte ist, die ebenfalls mitberechnet werden muss.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
Antwortento top
#6
Josef B Thx
WillWissen Thx
BoskoBiati Thx

Hallo Montagnachmittagg'meinde
- nun eine kleine Ecke weiter
nehmen wir mal an es handelt sich um die gleiche Anordnung, aber jetzt per VBA Code die Formel erstellen.
Habs mal mit dem Makrorekorder versucht, uff, da ist mir mein altes Audio-Tape lieber.

Bin zwar in der Rubrik "Wie verwende ich ...." am lesen, aber das realisieren ist beschi...... .
Zeigt mir einer von euch bitte den Codeschnipsel + Erläuterung.
Text- Combo- Listboxen befüllen geht ja schon, aber das is doch schärfster Tobak für mich.
Mach mir jetzt erst mal ne Pfeife 'Sherry&Cherry' und warte auf ein paar kleine Gedanken.

vorab danke
mfg
(>'I')> Dienstag. 03.Juni.2014 05:04 PM <('I'<)
Antwortento top
#7
Hallo Frank,

Zitat:Habs mal mit dem Makrorekorder versucht, uff, da ist mir mein altes Audio-Tape lieber.

Bin zwar in der Rubrik "Wie verwende ich ...." am lesen, aber das realisieren ist beschi...... .
Zeigt mir einer von euch bitte den Codeschnipsel + Erläuterung.

Das ist im Grunde doch ganz einfach.
Wenn ich das richtig verstanden habe, was Du tun willst, dann geht das so ....

1. Makrorecorder einschalten
2. Auf dem Tabellenblatt das machen, was das Makro machen soll
3. Makrorekorder ausschalten.
4. In den VBA-Editor wechseln, Code anschauen, verstehen und optimieren.
5. Den ganzen Kram speichern.

6. sich freuen, daß Alles läuft 190519
________________________________________________________________________
wer aufgibt, ohne es versucht zu haben, gibt einfach nur auf!

[Bild: schulbild3.jpg]
[-] Folgende(r) 1 Benutzer sagt Danke an Käpt'n Blaubär für diesen Beitrag:
  • WergibtmirRat
Antwortento top
#8
(03.06.2014, 19:12)Käptn Blaubär schrieb: Das ist im Grunde doch ganz einfach.
Wenn ich das richtig verstanden habe, was Du tun willst, dann geht das so .... sich freuen, daß Alles läuft
Tja, geduldig ist der Frickler (wie ich einer bin)
Geht nicht, gibt's bei mir zu 98% nicht.

Danke für die kurze knappe Antwort. Hab es dann doch hinbekommen. [Summenprodukt]

Was nur auffällt bei der Umschaltung von A1;B1; C1 auf Z1;C1, der Code ist noch unleserlicher Huh

mfg
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste