Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Summenprodukt
#1
Hallo Leute,

im Anhang befindet sich eine Beispiel Tabelle.
Ich möchte die Tabelle, je nach dem, nach Konzern A, B oder C filtern.
Für den jeweiligen Konzern möchte ich die den Preis herausfinden, d.h. der jeweilige Listenpreis multipliziert mit der Anzahl in Summe
für den jeweiligen Konzern.

Viele Grüße
Luks


Angehängte Dateien
.xlsx   Mappe1.xlsx (Größe: 15,25 KB / Downloads: 4)
Antwortento top
#2
Habe im Moment einen Wert mit dem Summenprodukt (Spalte B2), jedoch verändert dieser Wert sich bei Filterung nicht.
Antwortento top
#3
Hola,

da sollte doch folgendes reichen:


Code:
=SUMMEWENN(A5:A41;"a";D5:D41)/SUMMEWENN(A5:A41;"a";C5:C41)

Ansonsten:


Code:
=SUMMENPRODUKT(TEILERGEBNIS(9;INDIREKT("D"&ZEILE(5:41)))*(A5:A41="a"))/SUMMENPRODUKT(TEILERGEBNIS(9;INDIREKT("C"&ZEILE(5:41)))*(A5:A41="a"))

Gruß,
steve1da
Antwortento top
#4
Hallo

Oder man macht eine formatierte Tabelle daraus.
Tabelle1 (2)

ABCDE
132463,15789
2
3
4KonzernListenpreis pro FahrzeugAnzahlSpalte1Spalte2
5A30000130000
8A303004121200
11A306007214200
14A3090010309000
17A3120013405600
20A3150016504000
23A3180019604200
26A3210022706200
29A3240025810000
32A3270028915600
35A33000311023000
38A33300341132200
41A33600371243200
42Ergebnis247801840032463,15789
Formeln der Tabelle
ZelleFormel
B1=TEILERGEBNIS(109;Tabelle1[Spalte1])/TEILERGEBNIS(109;Tabelle1[Anzahl])

Tabelle1 (2)

CDE
42247801840032463,15789
Formeln der Tabelle
ZelleFormel
C42=TEILERGEBNIS(109;[Anzahl])
D42=TEILERGEBNIS(109;[Spalte1])
E42=Tabelle1[[#Ergebnisse];[Spalte1]]/Tabelle1[[#Ergebnisse];[Anzahl]]

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#5
Vielen Dank für Eure schnellen Antworten.

@steve1da: Leider verändert sich der Wert nicht, wenn ich die Spalte A nach einem Konzern filter.

Leider muss ich es ohne eine formatierte Tabelle lösen.
Antwortento top
#6
Hola,

sorry, hatte alles auf Konzern A bezogen:


Code:
=SUMMENPRODUKT(TEILERGEBNIS(9;INDIREKT("D"&ZEILE(5:41)))*(A5:A41<>""))/SUMMENPRODUKT(TEILERGEBNIS(9;INDIREKT("C"&ZEILE(5:41)))*(A5:A41<>""))

Gruß,
steve1da
Antwortento top
#7
Super! Vielen Dank.

Hättest du doch eine Lösung, wenn die Spalte D nicht vorhanden wäre?

Viele Grüße
Luks
Antwortento top
#8
Hallöchen,
Im Prinzip mit
=summenprodukt(((a2:a41)="a")*(b2:b42)*(...))
Statt"a" kannst Du einen Zellbezug nehmen, wo a drin steht.
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste