Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Am Sonntag (23.09.) wird das Forum zwischen 06:00 Uhr und 09:00 Uhr kurzzeitig nicht erreichbar sein. Wir stellen auf SSL / HTTPS um.


Summe nach Datum
#1
Hallo,

wie kann ich die Werte aus D in Spalte I summieren? Ich krieg's nicht hin. Ich habe es mit zwei Formeln versucht und mit SummeWennS kann ich die Formel nicht mal abschließen.

Daten
CDEFGHI
302.01.2015400200600Jan 150
405.01.2015164141783#WERT!
507.01.2015154411953
608.01.20150
709.01.2015169301994
812.01.2015236693054
913.01.2015177602374
1014.01.2015211983093
1115.01.2015188162044
1216.01.20155635913
1319.01.2015201282292
1420.01.201599701693
1521.01.2015133471803
1622.01.2015103251284
1723.01.20154333763
1826.01.2015121131343
1927.01.201582721543
2028.01.2015120491693
2129.01.2015113321454
2230.01.20157621973
2302.02.2015110251353
2403.02.2015119281473
2504.02.201595121072Feb 152389
2605.02.20154648942

verwendete Formeln
Zelle Formel Bereich N/A
I3=SUMMEWENN(D: D;MONAT(C:C)=MONAT($H$3);D: D)
I4=SUMMENPRODUKT((MONAT(C:C)=MONAT(H3));D: D)
H3,H25=C3
I25=SUMME(D25: D44)
C3:C26=ARBEITSTAG(DATUM($A$1;1;1)-1;ZEILE(A1);Feiertage!$B$59:$B$87)
F3:F26=D3+E3
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit

Antwortento top
#2
Hallo,

ich würde hier eine Pivottabelle nehmen, aber alternativ sollte auch diese Summenproduktformel funktionieren:

=SUMMENPRODUKT((MONAT(C3:C26)=MONAT(H3))*(D3:D26))

wobei ich hier davon ausgehe, dass wir nur Werte aus dem Kalenderjahr 2015 in der Tabelle haben.
Gruß
Peter
Antwortento top
#3
Hi Ralf,

=SUMMENPRODUKT(N(MONAT(C1:C100)=MONAT(H3));D1:D100)
Antwortento top
#4
Hallo Ralf, oder

=SUMMENPRODUKT((TEXT(C3:C100;"MJJ")=TEXT(H3;"MJJ"))*1;D3:D100)

oder

=SUMMENPRODUKT((TEXT(C3:C100;"M")=TEXT(H3;"M"))*1;D3:D100)
cu Jörg eine Rückmeldung wäre ganz reizend XL2010, XL2016
Antwortento top
#5
Hallo,

SUMMEWENNS wäre auch möglich:

Code:
=SUMMEWENNS(D:D;C:C;">"&H3-TAG(H3);C:C;"<="&MONATSENDE(H3;0))

Arbeitsblatt mit dem Namen 'Tabelle1'
 CDEFGHIJK
22015        
302.01.2015400200600 Jan 152846 01.01.2015
405.01.2015164141783   06.01.2015
507.01.2015154411953    
608.01.2015  0     

ZelleFormatWert
C2JJJJ01.01.2015

NameBezug
FT=Tabelle1!$K$3:$K$4

ZelleFormel
C3=ARBEITSTAG(C2;1;FT)
I3=SUMMEWENNS(D:D;C:C;">"&H3-TAG(H3);C:C;"<="&MONATSENDE(H3;0))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste