Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Summe aus Formel
#1
Moin Moin ihr lieben Excelianer,

Ich habe einen kleinen oder großen Hirnstau im Bezug auf das Bilden einer Summe!

Und zwar folgendes:

Für ein Spiel möchte ich eine Excel-Datei haben, welche mir allerhand Werte ausgeben kann.

Das ganze mache ich mal anhand des ersten Gegenstandes in der Liste!

Ich habe in der Spalte F Werte (Level einzelner Gegenstände), welche händisch einzutragen sind.
Aus den Werten in Spalte F werden in Spalte J die Kosten für das nächste Level des Gegenstandes ausgegeben.
Dafür gibt es folgende Formel:
=0,7*(F2+1)^2
Daraus ergeben sich die Kosten für das nächste Level des Gegenstandes, welcher in Zeile 2 steht!

Nun möchte ich in Spalte K die summierten Kosten des Gegenstandes für das händisch eingetragene Level ermitteln!

Könnt ihr mir da weiterhelfen?

LG GLDKRGN
Antwortento top
#2
Hola,

kannst du mal genau erklären, in welche(r) Zelle(n) was steht und was du gerne wo summiert hättest?

Gruß,
steve1da
Antwortento top
#3
Hola,

ich Liste mal alles auf!

A2 = Name des Gegenstandes
B2 = maximales Gegenstandslevel
C2 = Basisschaden in %
D2 = + Schaden pro Level
E2 = Level (händisch einzutragen)
F2 = Schaden
G2 = Schaden*Bonus
I2 = Kosten für nächstes Level
J2 = Kosten gesamt

relevant für meine Frage sind nur die Zellen E2, I2 und J2

In E2 trage ich z.B. 90 ein, da der Gegenstand auf Level 90 ist
In I2 steht die Formel zur Berechnung der Kosten für Level 91 -> =0,5*(E2+1)^1,7 (In diesem Fall gerundet 1070)
Nun möchte ich in J2 die gesamten Kosten von Level 1 bis 90 ausgerechnet haben!

Und wenn ich halt eine 91 eintrage möchte ich die Kosten für Level 1 bis 91 ausgegeben haben usw.

Hilft das weiter?Smile
Antwortento top
#4
Hi,

mach dir doch einfach eine Hilfsspalte (Angenommen Spalte K), in der du dies vorbereitet hast. Dann kannst du mit

I2 =SUMME(INDIREKT("K1:K" &E2))

dir die benötigte Summe ziehen...

Grüße
Micha
Antwortento top
#5
Hi,

hab' dir mal mit 2 Hilfsspalten einen Vorschlag gebastelt.

a

EIJKL
1LevelKst. next levelKst. gesamtHS LevelHS Kst.
29211103270901070
3911090
4921110
5931131
Formeln der Tabelle
ZelleFormel
I2=SVERWEIS(E2;$K$2:$L$5;2;0)
J2=SUMME(L2:INDIREKT("L"&VERGLEICH(E2;K:K;0)))
L2=RUNDEN(0,5*(K2+1)^1,7;0)
L3=RUNDEN(0,5*(K3+1)^1,7;0)
L4=RUNDEN(0,5*(K4+1)^1,7;0)
L5=RUNDEN(0,5*(K5+1)^1,7;0)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste