Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Stundenplan Erstellung
#1
Hallo,

ich habe Fragen zu einem Stundenplan den ich versuche zu erstellen. 

Die Mitarbeiter geben in Spalte A ihre Anfangszeit im Format 19:15 ein. In Spalte B die Endzeit im gleichen Format. Ich brauche die Stunden die Sie gearbeitet haben im Dezimalformat (z.B. 6.25 für 6 Stunden 15 Minuten (es wird immer nur im 15 Minuten abgerechnet)) in einer weiteren Spalte ('z.B. C) . Außerdem sollte eine Formel vorgesehen werden, dass wenn die Arbeitszeit 6 Stunden überschreitet 30 Minuten Pause abgezogen werden. 

Des Weiteren wird in verschieden  Fällen in der Ausgabe Spalte (in dem Fall die Spalte C) freie Tage eingetragen die einen Code haben (HD, SU, At). Der Stundenwert dieser freien Tage errechnet sich anhand einer Formel (z.B. HD= 8 Stunden x (Prozentsatz der aus einer weiteren Tabelle entsteht (z.B 75%). 

Die gesamten Summen aus der Spalte C sollen Zusammengerechnet werden und mein Ist Stand an Stunden darstellen.  

Hat jemand eine Idee wie ich das verwirklichen kann? 

Vielen Dank für die Hilfe 

Dany
to top
#2
Hi 

Teil 1 und 2 deiner Frage:

=(a2-a1)*24
=WENN(A2-A1>;0,25;A2-A1-0,0208;A2-A1)
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#3
Hi

nun zum zweiten Teil. Einfaches Prozentrechnen dürfte nicht schwer sein. Deine Prozentsatze holst du aus deiner anderen Tabelle mittels SVERWEIS. Addieren dürfte dann auch ohne Hilfe gehen 32

Achte darauf, dass deine Ergebniszelle benutzerdefiniert formatiert ist:
[h]:mm
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Dany
to top
#4
(17.03.2016, 18:27)WillWissen schrieb: Hi

nun zum zweiten Teil. Einfaches Prozentrechnen dürfte nicht schwer sein. Deine Prozentsatze holst du aus deiner anderen Tabelle mittels SVERWEIS. Addieren dürfte dann auch ohne Hilfe gehen 32

Achte darauf, dass deine Ergebniszelle benutzerdefiniert formatiert ist:
[h]:mm

Hallo,

ne das eigentliche Prozentrechnen ist kein Problem :Smile Allerdings weiß ich nicht wie ich es hin bekomme das Excel erkennt das ich den Text "HD" eingebe es dann die Formel so berechnene soll und wenn ich SU eingebe er eine andere Formel nimmt... 

Ich habe versucht es so zu lösen, aber Excel moniert dann #WERT!

=WENN(C7>6;C7-0,5;WENN(C7="HD";8*75%;WENN(C7=SU;4*75%;C7)))

In Spalte C7 steht dann wie gesagt die gearbeitet Stundenzahl im Format 6.25 oder die Begriffe HD oder SU. Der Einfachheit halber  habe ich die Prozente jetzt direkt eingegeben. 

Ich komme einfach nicht drauf Smile

Danke für deine Hilfe.
to top
#5
Hi,

=WENN(C7="HD";8*75%;WENN(C7="SU";4*75%;WENN(C7>6;C7-0,5;"")))
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Dany
to top
#6
Vielen vielen Dank Smile
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste