Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Stundenberechnung
#1
Hallo zusammen,

habe folgendes Problem. Wenn Ich die differenz zwischen zwei Uhrzeiten berrechnen möchte kommen ,85min heraus.

zB: 6:45 Uhr bis 17,30 Uhr ergibt mit der Formel (=SUMME(E20-D20)) 10,85

normal müßten aber 10,45 Std herauskommen.

was für eine Formel muß Ich hier anwenden.

das 2 Problemchen wäre.

wenn Ich in der Spalte Montageort eine Stadt oder Name eingebe, die in den Monat zb 5 vorkommt dann sollte es mir an der rechten Seite anzeigen wieviel Gesamtstunden je Montageort angefallen sind.


sieh Anhang.

Mai

ABCDEFGHIJKLMNOP
71.5.2014DoFeiertag
82.5.2014FrUrlaub0,000,000,0000000
93.5.2014Sa0,000,000,0000000Gesamtstunden
104.5.2014SoArthaus
115.5.2014MoArthaus Augsburg6,3017,3011,0001010Sturm
126.5.2014DiArthaus Augsburg6,3017,3011,0001010
137.5.2014MiSturm Herbrechtingen7,0018,0011,0001010
148.5.2014DoSturm Herbrechtingen7,0017,3010,3001010
159.5.2014FrArthaus Augsburg7,0016,309,3001010
1610.5.2014Sa0,000,000,0000000
1711.5.2014So
1812.5.2014MoRupf Einsingen7,0018,0011,0001010
1913.5.2014DiRupf Einsingen6,3017,3011,0001010
2014.5.2014MiSturm Herbrechtingen6,4517,300,0000010
2115.5.2014Do0,000,000,0000000
2216.5.2014Fr0,000,000,0000000
2317.5.2014Sa0,000,000,0000000
2418.5.2014So
Formeln der Tabelle
ZelleFormel
F8=SUMME(E8-D8)
H8=WENN(F8=0;0;WENN(F8<7,9;1;0))
I8=WENN(F8<7,9;0;WENN(F8<13,9;1;0))
J8=WENN(F8<13,9;0;WENN(F8>13,95;1;0))
K8=WENN(D8=0;0;WENN(L8=1;0;1))
L8=WENN(G8="x";1;0)
F9=SUMME(E9-D9)
H9=WENN(F9=0;0;WENN(F9<7,9;1;0))
I9=WENN(F9<7,9;0;WENN(F9<13,9;1;0))
J9=WENN(F9<13,9;0;WENN(F9>13,95;1;0))
K9=WENN(D9=0;0;WENN(L9=1;0;1))
L9=WENN(G9="x";1;0)
F11=SUMME(E11-D11)
H11=WENN(F11=0;0;WENN(F11<7,9;1;0))
I11=WENN(F11<7,9;0;WENN(F11<13,9;1;0))
J11=WENN(F11<13,9;0;WENN(F11>13,95;1;0))
K11=WENN(D11=0;0;WENN(L11=1;0;1))
L11=WENN(G11="x";1;0)
F12=SUMME(E12-D12)
H12=WENN(F12=0;0;WENN(F12<7,9;1;0))
I12=WENN(F12<7,9;0;WENN(F12<13,9;1;0))
J12=WENN(F12<13,9;0;WENN(F12>13,95;1;0))
K12=WENN(D12=0;0;WENN(L12=1;0;1))
L12=WENN(G12="x";1;0)
F13=SUMME(E13-D13)
H13=WENN(F13=0;0;WENN(F13<7,9;1;0))
I13=WENN(F13<7,9;0;WENN(F13<13,9;1;0))
J13=WENN(F13<13,9;0;WENN(F13>13,95;1;0))
K13=WENN(D13=0;0;WENN(L13=1;0;1))
L13=WENN(G13="x";1;0)
F14=SUMME(E14-D14)
H14=WENN(F14=0;0;WENN(F14<7,9;1;0))
I14=WENN(F14<7,9;0;WENN(F14<13,9;1;0))
J14=WENN(F14<13,9;0;WENN(F14>13,95;1;0))
K14=WENN(D14=0;0;WENN(L14=1;0;1))
L14=WENN(G14="x";1;0)
F15=SUMME(E15-D15)
H15=WENN(F15=0;0;WENN(F15<7,9;1;0))
I15=WENN(F15<7,9;0;WENN(F15<13,9;1;0))
J15=WENN(F15<13,9;0;WENN(F15>13,95;1;0))
K15=WENN(D15=0;0;WENN(L15=1;0;1))
L15=WENN(G15="x";1;0)
F16=SUMME(E16-D16)
H16=WENN(F16=0;0;WENN(F16<7,9;1;0))
I16=WENN(F16<7,9;0;WENN(F16<13,9;1;0))
J16=WENN(F16<13,9;0;WENN(F16>13,95;1;0))
K16=WENN(D16=0;0;WENN(L16=1;0;1))
L16=WENN(G16="x";1;0)
F18=SUMME(E18-D18)
H18=WENN(F18=0;0;WENN(F18<7,9;1;0))
I18=WENN(F18<7,9;0;WENN(F18<13,9;1;0))
J18=WENN(F18<13,9;0;WENN(F18>13,95;1;0))
K18=WENN(D18=0;0;WENN(L18=1;0;1))
L18=WENN(G18="x";1;0)
F19=SUMME(E19-D19)
H19=WENN(F19=0;0;WENN(F19<7,9;1;0))
I19=WENN(F19<7,9;0;WENN(F19<13,9;1;0))
J19=WENN(F19<13,9;0;WENN(F19>13,95;1;0))
K19=WENN(D19=0;0;WENN(L19=1;0;1))
L19=WENN(G19="x";1;0)
F20=N20
H20=WENN(F20=0;0;WENN(F20<7,9;1;0))
I20=WENN(F20<7,9;0;WENN(F20<13,9;1;0))
J20=WENN(F20<13,9;0;WENN(F20>13,95;1;0))
K20=WENN(D20=0;0;WENN(L20=1;0;1))
L20=WENN(G20="x";1;0)
F21=SUMME(E21-D21)
H21=WENN(F21=0;0;WENN(F21<7,9;1;0))
I21=WENN(F21<7,9;0;WENN(F21<13,9;1;0))
J21=WENN(F21<13,9;0;WENN(F21>13,95;1;0))
K21=WENN(D21=0;0;WENN(L21=1;0;1))
L21=WENN(G21="x";1;0)
F22=SUMME(E22-D22)
H22=WENN(F22=0;0;WENN(F22<7,9;1;0))
I22=WENN(F22<7,9;0;WENN(F22<13,9;1;0))
J22=WENN(F22<13,9;0;WENN(F22>13,95;1;0))
K22=WENN(D22=0;0;WENN(L22=1;0;1))
L22=WENN(G22="x";1;0)
F23=SUMME(E23-D23)
H23=WENN(F23=0;0;WENN(F23<7,9;1;0))
I23=WENN(F23<7,9;0;WENN(F23<13,9;1;0))
J23=WENN(F23<13,9;0;WENN(F23>13,95;1;0))
K23=WENN(D23=0;0;WENN(L23=1;0;1))
L23=WENN(G23="x";1;0)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8


mal schaun wer was weiß.
danke im voraus.....
Antwortento top
#2
Hallo, warum "missbrauchst" Du SUMME()...? Und wieso..: zB: 6:45 Uhr bis 17,30 Uhr und nicht zwei Uhrzeiten..?
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
Antwortento top
#3
Hallo,

ich würde die Uhrzeiten im Format hh:mm schreiben und dann folgende Formel verwenden:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABC
106:4517:3010:45

ZelleFormel
C1=REST(B1-A1;1)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Übrigens: zur Eingabe von Zeiten ohne die Nutzung des Doppelpunktes hat sich auch die folgende Methode bewährt:

XL2010: Über Datei - Optionen - Dokumentprüfung - AutoKorrektur-Optionen... eingeben, dass ',,' durch ':' ersetzt werden soll.

Die Zeiteingabe erfolgt dann einfach mit 12,,35 und XL wandelt dies automatisch in 12:35 um.

Das ist, zumindest nach meiner Überzeugung, eine der schnellsten und einfachsten Methoden.
Gruß
Peter
Antwortento top
#4
hallo Peter,

danke hat funktioniert, wenn Ich jetzt aber unten die gesamtstunden berrechne kommt das richtige Ergebniss, jedoch wie folgt:
853000 die letzten 2 Nullen brauch ich nicht.

Mai

EFG
38
3985:45:00
40
Formeln der Tabelle
ZelleFormel
F39=SUMME(F7:F37)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

dann bleibt nur das Problem miot der Gesamtstundenanzahl je Montageort...
Danke
Antwortento top
#5
Hallo

Falls du wirklich die Darstellung der Zeiten im Format hh,mm benötigst dann verwende eine dieser beiden Formeln:
Code:
=NOTIERUNGBRU(REST(NOTIERUNGDEZ(E8;60)/24-NOTIERUNGDEZ(D8;60)/24;1)*24;60)
=KÜRZEN(E8;)-KÜRZEN(D8;)-(REST(E8;1)<REST(D8;1))*0,4+REST(E8;1)-REST(D8;1)
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#6
Hallo,

formatiere die Zelle mit dem Format

Code:
[hh]:mm

Bezüglich der Gesamtstunden könntest du dir die Funktion Summewenn() anschauen, wobei du darauf achten solltest, dass der Eintrag von O10 und O11 mit den Einträgen in Spalte C übereinstimmt.
Gruß
Peter
Antwortento top
#7
(04.01.2015, 19:40)shift-del schrieb: Hallo

Falls du wirklich die Darstellung der Zeiten im Format hh,mm benötigst dann verwende eine dieser beiden Formeln:
Code:
=NOTIERUNGBRU(REST(NOTIERUNGDEZ(E8;60)/24-NOTIERUNGDEZ(D8;60)/24;1)*24;60)
=KÜRZEN(E8;)-KÜRZEN(D8;)-(REST(E8;1)<REST(D8;1))*0,4+REST(E8;1)-REST(D8;1)

in der Zeile funtioniert die Formel,
was mache Ich wenn Ich eine Spalte mit Stunden zusammen rechnen muß sie meine EXCEL Tabellen.

sonst super Formel
Antwortento top
#8
so zusammen nochmals:

zum Thema Zeiten zusammenrechnen der einzelnen Einsatzorte:
Der Tip von Peter mit dem Summewenn funktioniert einwandfrei.

Jetzt kommt die Gretchenfrage dazu. wenn in der Spalte C der erste und jeder neue Montageort eingegeben wird, das dieser automatisch in Spalte O eingetragen wird und hahinter die dazugeörigen Zeiten.

Für mich sieht das kompliziert aus und ich denke es ist nicht machbar.

Vielleicht gibt es doch noch eine Lösung.

2425





Dez

CDEFGHIJKLMNOP
3
42014
5MontageortAnwesenheitArbeitszeitReisespesen / Auslösung für HeimfahrtÜbernachtungMontageortArbeitszeit
6BeginnEnde AZÜbis unter 88-14 Stdab 14 StdGesamt
70:000:000:0000000
80:000:000:0000000
90:000:000:0000000
100:000:000:0000000
Formeln der Tabelle
ZelleFormel
C4=SUMME(Tabelle1!B2)
F7=REST(E7-D7;1)
H7=WENN(F7=0;0;WENN(F7<7,9;1;0))
I7=WENN(F7<7,9;0;WENN(F7<13,9;1;0))
J7=WENN(F7<13,9;0;WENN(F7>13,95;1;0))
K7=WENN(D7=0;0;WENN(L7=1;0;1))
L7=WENN(J7=1;1;0)
F8=REST(E8-D8;1)
H8=WENN(F8=0;0;WENN(F8<7,9;1;0))
I8=WENN(F8<7,9;0;WENN(F8<13,9;1;0))
J8=WENN(F8<13,9;0;WENN(F8>13,95;1;0))
K8=WENN(D8=0;0;WENN(L8=1;0;1))
L8=WENN(J8=1;1;0)
F9=REST(E9-D9;1)
H9=WENN(F9=0;0;WENN(F9<7,9;1;0))
I9=WENN(F9<7,9;0;WENN(F9<13,9;1;0))
J9=WENN(F9<13,9;0;WENN(F9>13,95;1;0))
K9=WENN(D9=0;0;WENN(L9=1;0;1))
L9=WENN(J9=1;1;0)
F10=REST(E10-D10;1)
H10=WENN(F10=0;0;WENN(F10<7,9;1;0))
I10=WENN(F10<7,9;0;WENN(F10<13,9;1;0))
J10=WENN(F10<13,9;0;WENN(F10>13,95;1;0))
K10=WENN(D10=0;0;WENN(L10=1;0;1))
L10=WENN(J10=1;1;0)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Antwortento top
#9
(04.01.2015, 19:52)wavemaster schrieb: in der Zeile funtioniert die Formel,
was mache Ich wenn Ich eine Spalte mit Stunden zusammen rechnen muß

Code:
=NOTIERUNGBRU(SUMMENPRODUKT(KÜRZEN(F8:F23;)+REST(F8:F23;1)/0,6);60)
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
  • wavemaster
Antwortento top
#10
Hallo,
Zitat:Jetzt kommt die Gretchenfrage dazu. wenn in der Spalte C der erste und jeder neue Montageort eingegeben wird, das dieser automatisch in Spalte O eingetragen wird und hahinter die dazugeörigen Zeiten.

Vergiss Summewenn() und arbeite mit einer Pivottabelle. Bezogen auf dein Beispiel:

Löse den Verbund der Zellen C5 und C6 auf und schreibe in C6 'Montageort'.

Markiere den Bereich von C6 bis zur letzten Zelle der Spalte F - Einfügen - Pivottable und folge dem Assistenten.

Ziehe das Feld Montageort und die Zeilenbeschriftung und das Feld AZ in das Wertefeld. Das sollte es gewesen sein.
Gruß
Peter
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste