Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

String mittels links, rechts, teil aufsplitten
#1
Hallo,
habe folgenden Text in einer Zelle stehen:

173 Days 21 Hours 46 Minutes 24 seconds
25 Days 17 Hours 9 Minutes 35 seconds
14 Days 6 Hours 29 Minutes 32 seconds
5 Hours 36 Minutes 6 seconds
12 Days 6 Hours 14 Minutes 0 seconds

Mit diesen Werten kann ich nicht rechnen. Ich brauche entweder alles in Tagen, Stunden, Minuten oder Sekunden.

Ich schaffe es einfach nicht mit Excel die einzelnen Werte mit "Links", "Rechts", "Teil", "Finden",etc. auszulösen damit ich dann damit rechnen kann.

Hat irgendjemand eine Idee?
 
Danke für die Hilfe im vorhinein!!!
to top
#2
Hi,

Daten==> Text in Spalten==>Feste Breite. Danach die Textspalten löschen.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#3
Hi,

hier noch ein Beispiel, wie du alle Werte in Stunden umrechnest.

Tabelle2

ABCDEFGHI
1173Days21Hours46Minutes24secondsSumme in
24152210,7666666670,006666667Std:Min:Sek
34173:46:24
4Alle Werte in Stunden umgewandeltben.def. Format
5[h]:mm:ss
Formeln der Tabelle
ZelleFormel
A2=A1*24
C2=C1*1
E2=E1*1/60
G2=G1*1/60/60
I3=SUMME(A2:H2)/24

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#4
Danke vorerst einmal. Das funktioniert aber nur, wenn ich immer Days, Hours, Minutes, Seconds habe. Sobald einer der Einheiten fehlt, dann habe ich schon ein Problem. Wir reden hier auch nicht von ein paar Einträgen. Ich muss hier 1000de Zellen immer wieder extrahieren. Sprich ein manuelles Nachbessern würde mich im Jahr Tage kosten :-(

Sprich die Option mit Text in Spalten ist nur bedingt möglich.
to top
#5
Hi!
Dann solltest Du mal eine Datei mit ca. 50 Zeilen hochladen.
Könnte sein, dass die Glaskugel dann nicht mehr so trüb ist …

Gruß Ralf
to top
#6
Hi

Dann solltest du mal ein originalgetreues Muster vorstellen. Fünf bis sechs Datensätze reichen, sensible Daten kannst du anonymisieren.

http://www.clever-excel-forum.de/Thread-...ng-stellen
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#7
Hi Günter!
Ich will aber 50!  05 19

Gruß Ralf
to top
#8
Hi Ralf,

du enttäuscht mich. Dachte nicht, dass du soooo gierig bist. 25
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#9
Datei hinzugefügt ... hat 159 Zeilen ;-)
.xlsx   temp.xlsx (Größe: 10,58 KB / Downloads: 7)
to top
#10
Hallo,

so:

Arbeitsblatt mit dem Namen 'Tabelle1 (2)'
 ABCDE
1AverageDayshoursMinutesseconds
262 Days 11 Hours 51 Minutes 20 seconds62115120
358 Days 21 Hours 0 Minutes 55 seconds5821055
462 Days 11 Hours 51 Minutes 20 seconds62115120
525 Days 17 Hours 9 Minutes 35 seconds2517935
64 Days 7 Hours 6 Minutes 5 seconds4765
78 Hours 9 Minutes 3 seconds 893
89 Days 14 Hours 30 Minutes 34 seconds9143034
96 Days 23 Hours 54 Minutes 1 seconds623541
1029 Minutes 46 seconds  2946
1136 seconds   36

ZelleFormel
B2=WENNFEHLER(WECHSELN(A2;TEIL(A2;SUCHEN("Days";A2)-1;99);"")*1;"")
C2=WENNFEHLER(WENN(ANZAHL($B2:B2)=0;LINKS($A2;SUCHEN(C$1;$A2)-1);TEIL($A2;SUCHEN(C$1;$A2)-3;3))*1;"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg


Formel in C nach rechts ziehen, dann alle Formeln nach unten ziehen.
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste