Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Speziellen Mittelwert berechnen
#1
Hallo an alle Ecxel-Profis..... 20

Ich möchte gerne in einer bestehenden Excel-Tabelle den Durchscnitt ermitteln. Das wäre soweit kein Problem...aber das Ergebnis soll immer dividiert durch Anzahl der eingegeben Werte sein. Konkret möchte ich gerne jeden Monat den Stromverbrauch im Durchschmitt errechnen.

In der Reihe 1 in den Spalten "A bis "L" stehen die Monate Januar bis Dezember
In Reihe 2 wird der in dem jewweiligen Monat verbrauchte Strom in Kilowattstunden dargestellt

Hinter der Reihe 2 in Spalte "M" steht Zur zeit die Formel "=MITTELWERT(A1:L1)".

Der ermittelte Durchschnitt ist aber insoweit nicht korrekt, da ich zum jetzigen Zeitpunkz natürlcih erst die Verbräuche Januar bis Mai eringetragen habe...die Formel rechnet aber die Monate Juni bis Dezember auch mit ins Ergebnis ein (mit einem Wert von "0"). Das verfälscht natürlcih unterjährig das Ergebnis. Im Mai müsste die Formel praktisch lauten: Rechne die Werte von Januar bis Mai zusammen und teiel durch 5. Wenn ich einen Wert für Juni erfasst habe, dann muß das Ergebnis lauten: Rechne Januar bis Juni zusammen und teile durch 6....usw.

Hilfeeeee liebe Excel-Cracks...könnt Ihr mir evtl. da einen Tip geben???

Danke vorab... Blush ..!

Viele Grüße

Holger
Antwortento top
#2
Hallo, eine Möglichkeit..:

=MITTELWERT(A1:INDEX(A1:L1;VERGLEICH(-9^9;1:1;-1)))


oder..:


=SUMME(A1:L1)/ZÄHLENWENN(A1:L1;">0")
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
Antwortento top
#3
Hallo Jockel...ich bin immer wieder erstaunt, was so alles möglich ist!!!

Du bist mein Held... 18

Die 2. Formel hat funktioniert!!!

Vielen vielen vielen vielen Dank!!!!! Blush
Antwortento top
#4
(16.06.2015, 17:54)HolgiS2001 schrieb: Hallo Jockel...

Die 2. Formel hat funktioniert!!!

Vielen vielen vielen vielen Dank!!!!!  Blush

Hallöchen, die erste funzt aber auch..:

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFGHIJKL
1123456
2
33,5
43,5
53,5
63,5

ZelleFormel
A3=MITTELWERT(A1:INDEX(A1:L1;VERGLEICH(-9^9;1:1;-1)))
A4=SUMME(A1:L1)/ZÄHLENWENN(A1:L1;">0")
A5=MITTELWERT(A1:INDEX(A1:L1;MONAT(HEUTE())))
A6=MITTELWERT(A1:INDEX(A1:L1;VERGLEICH(MAX(A1:L1);1:1;0)))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
Antwortento top
#5
Vielleicht noch eine andere "Herausforderung"...!

Ein paar Spalten weiter unten wird die durchschnittliche monatlich gezahlte Summe in € ausgewiesen. Hier kann ich die Formel leider nicht anwenden, da sich der Strompreis aus einem fixen Anteil (monatlicher Arbeitspreis) und einem variablen Anteil (Stromverbrauch) zusammensetzt. Der fixe Anteil ändert sich sich aber leider bei mir unterjähring immer zum 01.07, da ich da den Stromanbieter wechsele (der monatliche Arbeitspreis ist als unterschiedlcih hoch....ansonsten hätte ich einfach am Ende der Formel gendert auf ....."...;>11,44". Das heißt, das die Felder für die Zukunft für den monatlichen Betrag schon gefüllt sind mit dem fixen Betrag.

Man könnte das glaube ich hinbekommen, wenn man das Formelergebnis (fixer Wert + variabler Wert) nur dann darstellt, wenn auch der variable Wert gefüllt ist............?!?!?!?! Im Moment its das nur eine simple Summenformel (z.B. Grundgebühr im Monat sind 10,00 €; Verbrauch im Mai 60 € zzgl. 10,00 € Grundgebühr = 70 € ist das Formelergebnis; Verbrauch im Juni kenne ich ja noch nicht zzgl. 10,00 € Grundgebühr = 10 € ..... diese 10 € müssten so alne als "0,00 €" dargestellt werden, bis ich den variablen Wert (also den Verbrauch aus Juni) kenne.

Geht das auch?

Danke schonmal und viele Grüße!!! 19
Antwortento top
#6
(16.06.2015, 18:11)HolgiS2001 schrieb: Vielleicht noch eine andere "Herausforderung"...!

Ein paar Spalten weiter unten ...
Geht das auch?

Danke schonmal und viele Grüße!!! 19

Hi, du meinst Zeilen..!!! Spalten gehen von links nach rechts. Zeilen von oben nach unten... Kannst Du bitte (d)ein (Beispiel)Datei posten... ... mit händisch eingetragenen Ergebnissen...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
Antwortento top
#7
Sorry..vielleicht etwas kompliziert erklärt...

...hier das Beispiel:

Monat Mai

D9: 10,00 € (Grundgebühr)
D10: 50,00 € (Stromverbrauch)
D11: 60,00 € (Summe aus den oberen beiden)

Monat Juni

E9: 10,00 € (Grundgebühr)
E10: weiß ich ja noch nicht (Stromverbrauch)
E11: 10,00 € (Summe aus den oberen beiden)

Kann man das Feld E11 so einstellen, dass es erst dann ein Ergebnis darstellt, wenn der Wert in E10 erfasst wurde? (Ansonsten soll es den Wert "0" haben)

Dann könnte ich auch Deine erste Formel verwenden.

Danke schonmal..!!!
Antwortento top
#8
Hallo, meinst du so..:

Arbeitsblatt mit dem Namen 'Tabelle1'
DE
91010
1050
11600

ZelleFormel
D11=(D10<>"")*SUMME(D9:D10)
E11=(E10<>"")*SUMME(E9:E10)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • HolgiS2001
Antwortento top
#9
Die Formel würde mit Sicherheit gehen, wenn ich alles komplett hingeschrieben hätte................

Also...nochmal das Beispiel komplett:

Monat Mai

D9: 10,00 € (Grundgebühr)
D10: 20 kwh (Verbrauch)
D11: 2,50 € (Preis pro kWh)
D12: 60,00 € (D9 + (D10 * D11)

Monat Juni


E9: 10,00 € (Grundgebühr)

E10: ???? kwh (Verbrauch für Juni, den ich ja noch nicht kenne)
E11: 2,50 € (Preis pro kWh)
E12: 10,00 € (E9 + (E10 * E11)

Jetzt nochmal die korrekte Fragestellung: Kann man das Feld E12 so einstellen, dass es erst dann ein Ergebnis darstellt, wenn der Wert in E10 erfasst wurde? (Ansonsten soll es den Wert "0" haben)

Danke Dir und sorry für die umständliche Beschreibung

Viele Grüße

Holger
Antwortento top
#10
Hallo,

vielleicht so?

Code:
WENN(ISTZAHL(E10);E9+E10*E11;"")
Gruß Stefan
Win 7 / Office 2007
[-] Folgende(r) 1 Benutzer sagt Danke an Steffl für diesen Beitrag:
  • HolgiS2001
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste