Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert sind; Die von diesem Forum gesetzten Cookies düfen nur auf dieser Website verwendet werden und stellen kein Sicherheitsrisiko dar. Cookies auf diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Die Updates sind abgeschlossen. Bitte meldet eventuelle Bugs und Auffälligkeiten im entsprechenden Forum.
Sollte das Loginfenster nicht sichtbar sein, ist es unten links. Entweder Ihr loggt Euch dort ein oder löscht den Browsercache und versucht es noch einmal.


Spalte mit aktuellem Datum in Diagramm darstellen
#1
Hallo,

ich habe 2 Probleme ...

1. Frage:
Ich arbeite derzeit für mein Unternehmen an einem Excel Chart wo verschiedene Daten getracked werden sollen. Über der Tabelle sollen dann anhand dieser Daten Diagramme aktualisiert werden. Ich habe bereits das meiste fertig und stehe nun vor 2 Problemen.

Die Übersicht ist jeweils für den Monat angelegt. 01.08.2017 bis 31.08.2017 (Zeile) und es gibt 200 "Fehler-Faktoren", wo Zahlen eingefügt werden können (Spalte)

Es soll nun ein Diagramm entstehen, dass die 5 "Fehler-Faktoren" anzeigt.

Mein bisheriger Ansatz war folgender:

=HEUTE() um das aktuelle Datum zu vermitteln
=SUMMENPRODUKT((C4:AG4=AB218)*SPALTE(C4:AG4)) um herauszufinden in welcher Spalte sich das Datum befindet

Danach steh ich auf dem Schlauch. Ich wollte damit die Spalte identifizieren, welche das Datum beinhaltet. Das ist mir auch gelungen, nun habe ich aber eine Zahl (in meinem Fall 3) und weiß nicht wie ich die Formel ansetzen muss, damit die Werte des Bereichs C4:C204 für das Diagramm in Frage kommen.


2. Frage

Mein nächstes Problem ist, dass sich diese 200 Fehler Faktoren durch updaten (Makro Update Knopf) nach den Summen ordnen. Da wir in mehrere Schichten untertrennen, bekommt jede Schicht eine eigene Tabelle.

Wie ist es nun möglich eine "Summary" Tabelle zu erstellen? Die Werte der anderen Tabelle bewegen sich schließlich innerhalb der Zeilen und man kann nicht auf eben diese Zeilen verweisen.


Riesen Dank schon einmal Smile

Gruß
Marcus
Antwortento top
#2
Hallo,

zu 1
Du könntest mit dem Namensmanager und INDEX() arbeiten.
Hier mal was aus der Hand und somit ungetestet
=INDEX($C$4:$AG$202;1;SUMMENPRODUKT((C4:AG4=AB218)*SPALTE(C4:AG4))):INDEX($C$4:$AG$202;199;SUMMENPRODUKT((C4:AG4=AB218)*SPALTE(C4:AG4)))

zu 2
dazu fehlt mir die Vorstellungskraft. Ne anonymisierte Bsp.-Datei von Dir, könnte da Abhilfe schaffen.
VG
von René und seinen 3 Gehirnzellen

Antwortento top
#3
Danke schon einmal für die Antwort. Ich werde das mal probieren.


Im Anhang die Datei


Angehängte Dateien
.xls   DOS Chart.xls (Größe: 1,44 MB / Downloads: 1)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste