Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

SVerweis über 2 Kriterien
#1
Hallo Zusammen,
vorab sei gesagt das ich das Thema natürlich gegoogelt habe. Allerdings bekomme ich immer (für mich) zu heftige Lösungen welche ich nicht verstehe und somit für mein Problem nicht ummünzen kann.

Im Tabellenblatt "Artikeleinheiten" sind nach Artikelnummern aufsteigend sortiert die Einheiten mit den jeweiligen Mengen. Da diese Artikel mehrere Einheiten haben, kommt jeder Artikel mindestens 2x vor.
Im Tabellenblatt "Einheiten" soll das Ergebnis eingetragen werden. (In Zeile 2 hab ich mal das richtige Ergebnis manuell eingetragen).

Ich hab mich mal ein bisschen mit den Sverweis gespielt:
=WENN(UND((SVERWEIS(A5527;' - Artikeleinheiten1'!$A$2:$B$14999;2;1)=Einheiten!$J$1);SVERWEIS(A5527;' - Artikeleinheiten1'!$A$2:$B$14999;1;1)=A5527);"Jepp";"Nein")
Dieser ist aber meines Erachtens nicht Zielführend.

Um das ganze zu vereinfachen hab ich mal eine Beispieldatei angehängt.
Kann mir jemand dabei helfen?

gruss
Mike


Angehängte Dateien
.xlsx   Beispiel.xlsx (Größe: 11,07 KB / Downloads: 3)
Antwortento top
#2
Hola,

siehe auch:

http://www.excelformeln.de/formeln.html?welcher=30


Code:
=WENNFEHLER(VERWEIS(2;1/(' - Artikeleinheiten1'!$A$2:$A$18&' - Artikeleinheiten1'!$B$2:$B$18=$A2&E$1);' - Artikeleinheiten1'!$C$2:$C$18);"")


Diese Formel nach rechts und nach unten ziehen.

Gruß,
steve1da
Antwortento top
#3
Perfekte Lösung.
Ich verneige mein Haupt und ziehe meinen Hut.

Danke!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste