Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

SVERWEIS bringt 0 statt leer
#1
Hallöchen,

Beim Auslesen von Daten aus einem Datenbestand, in dem man leere Zellen und Zellen mit der Zahl 0 differenziert, kommt man mit einer einfachen SVERWEIS-Formel nicht zum Ziel. SVERWEIS bringt in beiden Fällen 0 als Ergebnis.
Eine Ergänzung mit ISTZAHL hilft hier. Das ungewöhnliche ist, dass ISTZAHL innerhalb der Formel in Bezug auf den SVERWEIS FALSCH liefert, obwohl der SVERWEIS ohne diese Prüfung augenscheinlich die Zahl 0 ergibt - siehe Formel0. Das liegt aber weniger am SVERWEIS als am Umgang von Excel mit den Funktionen bzw. dem Eintrag der Ergebnisse der Funktionen in die Zellen.  

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABC
1Formel00WAHR
2Formel1 FALSCH
3 Oder komplexer 
4Formel2 FALSCH
5 Oder einfacher 
6Formel3 FALSCH
7 (von shift-del) 

ZelleFormel
B1=SVERWEIS($A1;Tabelle2!$A$1:$B$10;SPALTE();)
C1=ISTZAHL(B1)
B2=WENN(ISTZAHL(SVERWEIS($A2;Tabelle2!$A$1:$B$10;SPALTE();));SVERWEIS($A2;Tabelle2!$A$1:$B$10;SPALTE(););"")
C2=ISTZAHL(B2)
B4=WENN(INDIREKT(ADRESSE(VERGLEICH($A4;Tabelle2!$A$1:$A$10;);SPALTE();;;"Tabelle2"))="";"";SVERWEIS($A4;Tabelle2!$A$1:$B$10;SPALTE();))
C4=ISTZAHL(B4)
B6=WENNFEHLER(--(SVERWEIS($A6;Tabelle2!$A$1:$B$10;SPALTE();)&"");"")
C6=ISTZAHL(B6)
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg

Arbeitsblatt mit dem Namen 'Tabelle2'
 AB
1Formel0 
2Formel1 
3Formel2 
4Formel3 
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste