Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.

SVERWEIS/WVERWEIS????
#11
Hallo BoskoBiati,
das sieht so toll aus, genau wie ich es mir vorgestellt habe, toll.
Leider klappt das bei mir nicht, Ergebnis "wahr".
Habe die Formel in Feld B7 kopiert???
Trau mich gar nicht zu fragen, aber kannst du vielleicht die Excel-Datei mit Formel anhängen?  Huh
Das wäre super, denn irgendwas mache ich falsch.

Danke dir!
Zitieren to top
#12
Hi,


Code:
aber kannst du vielleicht die Excel-Datei mit Formel anhängen?



Nein, habe ich gelöscht. Wahr kann aber niemals das Ergebnis meiner Formel sein, es sei denn es steht Wahr in der Zelle. Hast Du auch ein Kürzel in C3 eingetragen?

Formelauswertung hilft!!!!!!!!!!!!
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Zitieren to top
#13
Hi,

ich wurde von einem Kollegen darauf aufmerksam gemacht, dass die Formel fehlerhafte Ergebnisse bringt. Hier eine korrigierte Version:

Arbeitsblatt mit dem Namen 'Ausgabe'
 ABCD
3  SchmHerr Schmidt
41. Std   
5    
63. StdKlasse?Fach?Raum
74. Std6dMa123
85. Std10aWi123
96. Std10cWi123
107. Std   
118. Std   

ZelleFormel
B7=WENNFEHLER(INDEX(INDEX(Lehrer!$3:$27;1+(SPALTE(A1)>1)*((ZEILE(A1)-1)*3+3+SPALTE(A1)*2););VERGLEICH($C$3;INDEX(Lehrer!$1:$65536;(ZEILE(A1)-1)*3+11;);0));"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • tiaetsch
Zitieren to top
#14
18  Jubel, das funktioniert super!
Jetzt muss ich es nur noch für die Zellen darüber hinkriegen. Nach unten funktioniert ja ausfüllen.
Vielen Dank für deine Hilfe.

Beste Grüße
tiaetsch
Zitieren to top
#15
Ach man, das sit so eine super Formel, aber ich weiß nicht, welche Werte ich ändern muss, um sie in Zelle B4 einzutragen.
Hast du die Zeit noch, bitte?
Zitieren to top
#16
Hallo,

neue Formel für den gesamten Bereich:

Arbeitsblatt mit dem Namen 'Ausgabe'
 ABCD
3  SchmHerr Schmidt
41. Std   
5    
63. Std6dMa123
74. Std10aWi123
85. Std10cWi123

ZelleFormel
B4=WENNFEHLER(INDEX(INDEX(Lehrer!$3:$27;1+(SPALTE(A1)>1)*((ZEILE(A1)-1)*3+1+REST(SPALTE(A1);2)*2););VERGLEICH($C$3;INDEX(Lehrer!$1:$65536;(ZEILE(A1)-1)*3+5;);0));"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß


Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Zitieren to top
#17
Hallo,
die Formel funktioniert einwandfrei, aber ...

Ich muss die Tabellenblätter mit Spreadsheatconverter in Html umwandeln und da streikt der converter.
Es liegt definitiv an der Formel, kann damit nicht umgehen.
Kann man das irgendwie mit SVERWEIS oder WVERWEIS machen, oder gibts noch eine andere Lösung.
Du kennst bestimmt auch einen anderen Weg, oder???
Zitieren to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste