Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Quantil über Aggregat aus Matrix im anderen Blatt mit variabler Zeile
#1
Liebe Excelprofis,
ich habe ein Problem mit der Funktion Aggregat, mit der ich verschiedene Quantile aus Datensätzen in anderen Tabellenblättern bestimmen will. 
Im Tabellenblatt "dash_data" habe ich in Zelle D2 versucht, über folgende Formel testweise das 90%-Perzentil zu bestimmen:
=WENNFEHLER(AGGREGAT(16;6;'2010'!$A$6:$Z$99/('2010'!$A$6:$A$99=$A2);0,9);"")
Dabei ist 2010 das Tabellenblatt, aus dem die Daten übernommen werden und in Zelle A2 steht der Wert, der die jeweilige Zeile in der Matrix bestimmt.
Die Formel rechnet mir zwar Werte aus, allerdings stimmen diese nicht mit Werten überein die ich in D8 bis D12 mit Aggregat ohne variable Zeile ermittelt habe.
Wie muss ich die Formel umbauen, damit es passt?
Vielen Dank!


Angehängte Dateien
.xlsx   Beispiel.xlsx (Größe: 21,08 KB / Downloads: 4)
Antwortento top
#2
Hallo,

... Deine Ergebnisse müssen unterschiedlich sein, denn erstens rechnest Du mit unterschiedlichen k- Werten und zweitens wertest Du mit Deiner Formell in D2 auch Leerzellen aus (der Bereich geht dann von Spalte A bis Z in Deiner Formel D8 nur von D:O).

Vergleichbar wäre die Ergebnisse  wenn in D2:

=WENNFEHLER(AGGREGAT(16;6;INDIREKT(D$1&"!$A$6:$Z$99")/(INDIREKT(D$1&"!$A$6:$A$99")=$A2)/ISTZAHL(INDIREKT(D$1&"!$A$6:$Z$99"));0,25);"")

und nach unten kopieren.
Gruß Werner
.. , - ...
[-] Folgende(r) 1 Benutzer sagt Danke an neopa für diesen Beitrag:
  • Leinad
Antwortento top
#3
Noch eine Frage dazu: 
Wie funktioniert die Formel, wenn man den Mittelwert berechnen möchte? Wenn ich in der Formel als Funktion 1 (= Mittelwert) auswähle und für [k] freilasse, bekomme ich nur eine leere Zelle angezeigt ...
Antwortento top
#4
Hallo,

die Teilfunktion 1 (MITTELWERT) von AGGREGAT() ist (leider) nicht matrixfähig. Dies sind nur die Teilfunktionen ab der 14 (KGRÖSSTE)
Über einen Umweg könnte man dies zwar aber auch mittels AGGREGAT() lösen, aber um den Mittelwert zu ermitteln, ist es deshalb ratsamer dies mit MITTELWERT() in einer "echten" Matrixformel zu tun.
Gruß Werner
.. , - ...
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste