Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Pivot ohne doppelte Werte
#1
Hi,

ich habe eine Liste von Tages-Daten, die ich auswerten muß.

alle Positionen
BCF
1BearbeiterAuftragFertigKdn_Ref_1
2BE07-Okt-14'4503654010
3BE07-Okt-14'4503654010
4BE07-Okt-14'4503654010
5PR24-Okt-14'05035
6PR09-Okt-14'05035
7PR24-Okt-14'05035
8PR24-Okt-14'05035
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit



Anzahl "Kdn_Ref_1" gruppiert nach Jahr und Bearbeiter, doppelte sollen nicht gezählt werden.

Wie mache ich das als Pivot?
Antwortento top
#2
Hallo,

mit einer Hilfsspalte unter Verwendung von Summenprodukt sollte das machbar sein:

http://www.pivot-table.com/2010/03/22/co...vot-table/

Hilft dir das weiter?
Gruß
Peter
Antwortento top
#3
Hallo Ralf

Suchst du das?
http://blog.contextures.com/archives/201...vot-table/
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#4
Hallo,

ich habe es nun mit einer Hilfsspalte (Summenprodukt) versucht, es klappt, ich bekomme Zahlen.

Leider komme ich da aber auf andere Zahlen (tendenziell niedriger), als wenn ich manuell nach Jahr und Bearbeiter filtere, die Spalte F in ein anderes Blatt kopiere und dort mit Spezialfilter die doppelten rauslösche.
Antwortento top
#5
Hallo,

wie sieht denn die von dir verwendete Formel genau aus?

Zitat:Anzahl "Kdn_Ref_1" gruppiert nach Jahr und Bearbeiter, doppelte sollen nicht gezählt werden.

Auf welche Spalte(n) bezieht sich denn das doppelte? Nur den Bearbeiter? Nur die Kundenreferenz oder z.B. Bearbeiter und Kundenreferenz? Oder gibt es bei einer Kundenreferenz immer nur einen Bearbeiter?
Gruß
Peter
Antwortento top
#6
Hi Peter,

(30.10.2014, 17:29)Peter schrieb: wie sieht denn die von dir verwendete Formel genau aus?

Zitat:Anzahl "Kdn_Ref_1" gruppiert nach Jahr und Bearbeiter, doppelte sollen nicht gezählt werden.

Auf welche Spalte(n) bezieht sich denn das doppelte? Nur den Bearbeiter? Nur die Kundenreferenz oder z.B. Bearbeiter und Kundenreferenz? Oder gibt es bei einer Kundenreferenz immer nur einen Bearbeiter?

es gibt 2 Bearbeiter und 5 Jahre in ~10.000 Zeilen mit unterschiedlich vielen Referenzen. Pro Referenz nur einen Bearbeiter und ein Jahr.
Ich muß eine Zusammenfassung haben, wieviele unterschiedliche Kundenreferenzen pro Bearbeiter und Jahr es gibt.

Also:

Tabelle1
HIJKLM
220102011201220132014
3BE221197
4PR183190
5Summe:4043870
Schriftart wird in dieser Tabelle nicht dargestellt

verwendete Formeln
Zelle Formel Bereich N/A
I5:K5=SUMME(I3:I4)

Schriftformate
Zelle Rot Grün Blau Color Stil Unterstreichung Effekte Durchgestrichen Schriftart
H3:H5, I2:M2 0000Fett  
Zellen mit Schriftformatierung automatisch werden nicht dargestellt
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.19 einschl. 64 Bit


Die Formel ist:
=WENN(SUMMENPRODUKT(($B$2:$B2=B2)*($F$2:$F2=F2))>1;0;1)
und das runtergezogen bis zur letzten Zeile
Antwortento top
#7
Hallo,

nur um sicher zu gehen: Du hast die Hilfsspalte dann in den Berichtsfilter gezogen und nach dem Wert 1 gefiltert?


.xlsx   Mappe7.xlsx (Größe: 14,59 KB / Downloads: 3)
Gruß
Peter
Antwortento top
#8
Hallo zusammen,
Hallo Ralf,

Du könntest auch Deine Tabelle kopieren und in der kopierten dann Duplikate entfernen und
daraus dann Deine Pivot erstellen.
Gruß Atilla
Antwortento top
#9
Hi Peter,

(30.10.2014, 19:42)Peter schrieb: nur um sicher zu gehen: Du hast die Hilfsspalte dann in den Berichtsfilter gezogen und nach dem Wert 1 gefiltert?

das probiere ich morgen.

Nein, ich habe die Hilfsspalte in WERTE gezogen und dann "Summe von Hilfsspalte" eingestellt. So wie es in den verlinkten Beiträgen steht.
Antwortento top
#10
Hallo,

Zitat:Nein, ich habe die Hilfsspalte in WERTE gezogen und dann "Summe von Hilfsspalte" eingestellt.

dann, so vermute ich jetzt mal, dürfte hier der Hase im Pfeffer liegen.

Ich bin gespannt auf morgen. 19
Gruß
Peter
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste