Das letzte Clever-Excel-Forum.de - Treffen
fand vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt.

Per '&' viele Zellen auf einmal zusammenführen
#1
Guten Morgen liebe Excel-Freunde,

ich denke mein Problem sollte gar nicht so schwierig sein ^^
Ich habe einen gewissen Datensatz á la:

Anton
Berta
Cäsar
Dora
Emil

Ich möchte nun alle hintereinander weg schreiben.
Ungefähr so:
=A1&A2&A3&A4&A5.....
Da ich aber noch mehr Werte hab und mein Datensatz noch nicht ganz ausgetüftelt ist, erscheint mir das doch sehr langwierig und Zeitverschwenderisch.

Kann man das irgendwie abkürzen, wie:
=&(A1:A99)
(Ich weis, so funktioniert das nicht, aber ich denke es ist eindeutig, was ich möchte ^^)

Ich danke vorab, Exel-senseis
to top
#2
Hi,


drücke Alt + F11
Einfügen Modul

und füge diesen Code ein

Code:
Function verk(rng As Range) As String

Dim rng_cell As Range
For Each rng_cell In rng
    If rng_cell <> "" Then
        verk = verk & rng_cell
    End If
Next
End Function

im Tabellenblatt kannst du nun
=verk(A1:A99)
eingeben.

Soll wirklich kein Trennzeichen zwischen den Zellen sein?
lg Chris
Feedback nicht vergessen.
3a2920576572206973742064656e20646120736f206e65756769657269672e
 ?mage

[-] Folgende(r) 1 Benutzer sagt Danke an chris-ka für diesen Beitrag:
  • Ihroquanshy
to top
#3
Hola,

dazu brauchst du VBA:

http://www.ms-office-forum.net/forum/sho...p?t=273352

Gruß,
steve1da
to top
#4
Danke vielmals chris-ka,
ich hab mich immer vor VBA gedrückt, aber das war wirklich gut beschrieben und einfach umzusetzen.

(17.03.2015, 09:08)chris-ka schrieb: Soll wirklich kein Trennzeichen zwischen den Zellen sein?

Da ich am Ende eine Datenbank hab, die sowieso niemand sieht,
stehen die Trennzeichen dann ungefähr so dazwischen:

Anton
-
Berta
-
Cäsar
_
...


Nochmals Danke (:
to top
#5
Hallo,

geht auch mit Formeln, die letzte Zeile dann über übernehmen:
[html]
Arbeitsblatt mit dem Namen 'Tabelle1'
 AB
1AA
2BA-B
3CA-B-C
4DA-B-C-D
5EA-B-C-D-E

ZelleFormel
B1=A1
B2=WENN(A2="";"";B1&"-"&A2)
B3=WENN(A3="";"";B2&"-"&A3)
B4=WENN(A4="";"";B3&"-"&A4)
B5=WENN(A5="";"";B4&"-"&A5)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
[/html] 
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste