Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Per Mausklick den Inhalt der Spalte B6 in Spalte J6 anzeigen
#1
Hallo!

Ich soll eine mit Hilfe einer Excell etwas erstellen, um Projektnummern für Aufträge zu vergeben.
Habe nun zunächst einmal 4 Spalten gemacht (Projekt,Kunde,Kostenstelle,Produkt) und jeweils die einzelnen Zahlen aufgelistet. Nun möchte ich, dass wenn ich auf ein Projekt klicke (.z.B. in A6), dass der Inhalt dieser Spalte in J6 aufgeführt wird. Damit dann jeweils durch Klick der einzelnen Bereiche am Ende eine Projektnummer herauskommt.

Heißt: in A6 steht die Zahl 001: wenn ich dadrauf klicke soll diese Zahl in J6 erscheinen
          in A7 steht die Zahl 002: wenn ich dadrauf klicke soll diese Zahl in J7 erscheinen

Vielleicht kann mir ja jemand helfen. Danke im Voraus!
to top
#2
Hi Mareike,

das geht nur mit VBA - da kann ich dir aber nicht helfen.

Doch um Projektnummern zu kreieren, die eindeutig sind, würde eine Formellösung doch auch ausreichen. Hier mal mein Vorschlag, falls ich dich überhaupt richtig verstanden habe.

Tabelle1

ABCDE
1ProjektKundeKostenstelleProduktProjektnummer
2001Fa. Braun12345Heizkessel001-Fa. Braun
3002Schwarz98765Dachausbau002-Schwarz
4
5
6
7
8
9
10
Formeln der Tabelle
ZelleFormel
A2=WENN(B2<>"";ZEILE()-1;"")
E2=WENN(ISTZAHL(A2);TEXT(A2;"000")&"-"&B2;"")
A3=WENN(B3<>"";ZEILE()-1;"")
E3=WENN(ISTZAHL(A3);TEXT(A3;"000")&"-"&B3;"")
A4=WENN(B4<>"";ZEILE()-1;"")
E4=WENN(ISTZAHL(A4);TEXT(A4;"000")&"-"&B4;"")
A5=WENN(B5<>"";ZEILE()-1;"")
E5=WENN(ISTZAHL(A5);TEXT(A5;"000")&"-"&B5;"")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#3
Wenn wir die Tabelle nehmen, wie du Sie gerade geschickt hast dann bekommt der Kunde und das Produkt auch jeweils eine Nummer.

Bei Klick auf A2 soll im Feld E2 eine 001 entstehen. Bei Klick auf B2 soll im Feld F2 eine 1 entstehen (wenn Kunde Fa.Braun die 1 bekommt), usw.
Sodass am Ende dann eine Projektnummer, wie 001 1 12345 1 entsteht. 


Ich habe leider überhaupt keine Ahnung von Excel und stehe völlig auf dem Schlauch.
to top
#4
Hi Mareike,

zweiter Versuch.

Tabelle1 (2)

ABCD
1KundeKostenstelleProduktProjektnummer
2Fa. Braun12345Heizkessel001 1 12345 1
3Schwarz98765Dachausbau002 2 98765 2
4Schmitz45685Gartenanlage003 3 45685 3
5Peters95173
6
7
Formeln der Tabelle
ZelleFormel
D2=WENN(ANZAHL2($A2:$C2)=3;TEXT(ZEILE()-1;"000")&" "&ZEILE()-1&" "&B2&" "&ZEILE()-1;"")
D3=WENN(ANZAHL2($A3:$C3)=3;TEXT(ZEILE()-1;"000")&" "&ZEILE()-1&" "&B3&" "&ZEILE()-1;"")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Falls dies immer noch nicht deinen Vorgaben entspricht, solltest du uns (d)eine originalgetreue(!) Mustertabelle hochladen und dann nochmals explizit dein Vorhaben erläutern. Sensible Daten in der Mustertabelle kannst du anonymisieren; 5-6 Zeilen, wie in meinem Beispiel reichen aus.

Und so geht das Hochladen:  http://www.clever-excel-forum.de/Thread-...ng-stellen
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#5

.xlsm   Projektnummer m.xlsm (Größe: 16,57 KB / Downloads: 9)

Ich hoffe, du kannst es nun besser verstehen.

Vermutlich lässt sich das Problem nicht mit der Wenn-Funktion lösen, da ich den Befehl durch anklicken auslösen muss. Die Projektnummern variieren ja mit jedem neuen Projekt, je nachdem wer der Kunde ist, welche Produkte er wünscht, und so weiter.
to top
#6
Hi Mareike,

da bin ich nun raus. Wie du selbst schon angemerkt hast, ist hier eine Formellösung nicht möglich und mit Makros kann ich nicht dienen.

Aber trotz allem verstehe ich den Aufbau nicht. Normalerweise kommt doch Kunde A zu mir und lässt sich bzgl Produkt, Preis, Auftragsdauer usw. beraten. Danach vergebe ich bei Auftragseinigung eine laufende Nummer, die ja durchaus die Kundennummer und auch Kostenstelle enthalten kann als Projektnummer. Der Aufbau, den du aber vorstellst, beinhaltet nach meinem Verständnis laufende Nummern, die keinerlei Zuordnung haben, Kunden, wahllos gemischt und Produkte. Dieser Aufbau entspricht doch nicht deinem Original, oder?
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#7
Hallo.

ohne jegliche Fehlerprüfung und ohne Beachtung einer Reihenfolge, würde ich es mit Doppelklick so lösen:


Code:
Private Sub Worksheet_BeforeDoubleClick(ByVal Target As Range, Cancel As Boolean)
   If Not Intersect(Target, Range("A2:E5")) Is Nothing Then
     Cells(Application.CountA(Columns(Target.Offset(, 8).Column)) + 1, Target.Offset(, 8).Column) = Target
   End If
End Sub
Gruß Atilla
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste