Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Passwörter und Benutzernamen besser lesbar machen
#1
Hallöchen,

ich habe mir mittels Firfox-AddIn alle meine Internetkonten mit Benutzernamen samt Passwort in eine csv Datei geschrieben. Wenn ich diese Daten nun in eine Excel-Tabelle importiere, haben diese Informationen ein etwas sehr sperriges Format und sind benutzerunfreundlich zu lesen.


Insgesamt haben die Daten aus der csv Datei in den einzelnen Excel-Zellen folgende Struktur:
hostname,"username","password","formSubmitURL","httpRealm","usernameField","passwordField"
ergibt in der Praxis:
http://web.de,"klimbim","abcd99","https://login.web.de","","username","password"

Ich möchte nun folgende Ausgabe für dieses sperrige Format haben:
Internetseite: web.de
Benutzer: klimbim
Passwort: abcd99

Könnt ihr einen solchen Code in VBA schreiben?
to top
#2
Hi,

warum denn VBA, wenn es mit ein paar Mausklicks und Bordmitteln geht:

1. Daten -> Text in Spalten -> Trennzeichen Komma
2. Zeilen markieren, kopieren, Inhalte einfügen, Transponieren

Wenn es denn unbedingt VBA sein muss, zeichne die Aktionen mit dem Rekorder auf ...
[-] Folgende(r) 1 Benutzer sagt Danke an Kl@us-M. für diesen Beitrag:
  • VBATartar
to top
#3
@Klaus,
danke für deine Hilfe, aber ich bräuchte dann doch die VBA Lösung.
to top
#4
Hallo Tartar (*lecker*, gleich gibt es ne Knifte!)!
Warum VBA, wenn sich so etwas mit Bordmitteln oder Formeln lösen lässt?
Hast Du mehr als 1.000 Accounts?
Erstmal nur für das wiederkehrende Transponieren der Überschrift:

ABCDE
1hostnameusernamepasswordhostname
2http://web.deklimbimabcd99username
3http://wc.dekokoloresxyz6password
4http://mist.derhabarberjdlf0hostname
5http://kacke.dekamelleuajdöfkjx1username
6password
7hostname
8username
9password
Formeln der Tabelle
ZelleFormel
E1=INDEX(A$1:C$1;1;REST(ZEILE(A3);3)+1)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Gruß Ralf
[-] Folgende(r) 1 Benutzer sagt Danke an RPP63 für diesen Beitrag:
  • VBATartar
to top
#5
Nach der Knifte der Rest:

ABCDEF
1hostnameusernamepasswordhostnamehttp://web.de
2http://web.deklimbimabcd99usernameklimbim
3http://wc.dekokoloresxyz6passwordabcd99
4http://mist.derhabarberjdlf0hostnamehttp://wc.de
5http://kacke.dekamelleuajdöfkjx1usernamekokolores
6passwordxyz6
7hostnamehttp://mist.de
8usernamerhabarber
9passwordjdlf0
10hostnamehttp://kacke.de
11usernamekamelle
12passworduajdöfkjx1
13hostname
14username
15password
Formeln der Tabelle
ZelleFormel
E1=INDEX(A$1:C$1;1;REST(ZEILE(A3);3)+1)
F1=WENNFEHLER(INDEX(A$1:C$5;AUFRUNDEN(ZEILE(A1)/3;0)+1;REST(ZEILE(A3);3)+1);"")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Gruß Ralf
[-] Folgende(r) 1 Benutzer sagt Danke an RPP63 für diesen Beitrag:
  • VBATartar
to top
#6
Hallo Ralf,

Sorry aber ich komme mit deiner Formellösung nicht klar. Habs zig-mal versucht.

Wenn ich in der Zelle A1  bis irgendwas  folgendes drin stehe habe:

http://web.de,"klimbim","abcd99","https://login.web.de","","username","password"

spalten deine Formeln in  E und F bei mir nichts auf.
to top
#7
Hi!
Bevor Du Dich an VBA versuchst:
Eine CSV sollte man in Excel nicht öffnen, sondern über
Daten, externe Daten, aus Text
importieren.
Dann hast Du Dir schon mal das "Text in Spalten" gespart, wenn Du den richtigen Listenseparator eingibst.
Dann brauchst Du nur noch meine beiden Formeln auf Deine Belange anzupassen.

Ich weiß, ist jetzt blöd, aber Du solltest mal tatsächlich die ersten vier Zeilen Deiner .CSV anonymisieren und hier hochladen, dann kann ich Dir auch konkret helfen.

Gruß Ralf
[-] Folgende(r) 1 Benutzer sagt Danke an RPP63 für diesen Beitrag:
  • VBATartar
to top
#8
Hallöchen,

also, wenn Du den kompletten String in einer Zelle hast, kann es nicht gehen. Wie Du aber aus den Antworten entnehmen kannst, steht dort nicht alles in einer Zelle.
Klaus-Martin hat Dir z.B. geschrieben, Du sollst mit "Text ins Spalten" den Text erst mal auf einzelne Zellen verteilen.
Ralf hat dann eine Formellösung gepostet. Die funktioniert auf dieser Basis auch, auch bei mir :

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEF
1hostnameusernamepassword hostnamehttp://web.de
2http://web.deklimbimabcd99 usernameklimbim
3http://wc.dekokoloresxyz6 passwordabcd99
4http://mist.derhabarberjdlf0 hostnamehttp://wc.de
5http://kacke.dekamelleuajdöfkjx1 usernamekokolores
6    passwordxyz6
7    hostnamehttp://mist.de
8    usernamerhabarber
9    passwordjdlf0
10    hostnamehttp://kacke.de
11    usernamekamelle
12    passworduajdöfkjx1

ZelleFormel
E1=INDEX(A$1:C$1;1;REST(ZEILE(A3);3)+1)
F1=WENNFEHLER(INDEX(A$1:C$5;AUFRUNDEN(ZEILE(A1)/3;0)+1;REST(ZEILE(A3);3)+1);"")
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg


Steht denn alles in A1?
Dann passt der Vorschlag von Klaus-Martin aber zu 100%, allerdings wegen einer Zelle ein Makro schreiben ...
Du kannst die Aktionen per Makrorekorder aufzeichnen und dann ablaufen lassen.
irgendeine andere Zele anklicken
Makrorekoder starten
a1 anklicken
text in Spalten ausführen
Daten in Zeile 1 Markieren
Kopieren
A2 anklicken oder gewünschte Zielzelle
Inhalte Einfügen / Option Transponieren
ESC drücken
eventuell Zeile 1 löschen
Makrorekorder beenden.

Falls da doch mehr im Spiel ist als a1 bzw. in A1 dann mehrere Zugänge stehen, kannst Du den Code posten und die Anforderungen genau beschreiben. Wir optimieren das dann. Wäre ja dumm, wenn Du in A1 20 Zugänge hast und immer 3 kopierst, einfügst, die nächsten kopierst ...
Wenn alles dann in einer Zeile steht, wäre aber auch ohne VBA per Formel lösbar ...
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
[-] Folgende(r) 1 Benutzer sagt Danke an schauan für diesen Beitrag:
  • VBATartar
to top
#9
Hallo Leute,

ihr alle hattet absolut Recht es muss nicht immer VBA sein! Ich habs jetzt hingekriegt und mußte einsehen, dass VBA hier eigentlich völlig überflüssig ist.
Danke euch allen!
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste